aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2014-06-15 16:37:03 +0800
committerMartin Wilke <miwi@FreeBSD.org>2014-06-15 16:37:03 +0800
commit85ef09be66d0607a38795b8dbe092cde63b89b24 (patch)
tree5cec66a1773a6be6650399657412ad759dd4b014 /math
parent0211530d7b456b20d760d6c59d2813a1001ffd01 (diff)
downloadfreebsd-ports-gnome-85ef09be66d0607a38795b8dbe092cde63b89b24.tar.gz
freebsd-ports-gnome-85ef09be66d0607a38795b8dbe092cde63b89b24.tar.zst
freebsd-ports-gnome-85ef09be66d0607a38795b8dbe092cde63b89b24.zip
- Update to 0.14.0
PR: 190850
Diffstat (limited to 'math')
-rw-r--r--math/py-pandas/Makefile50
-rw-r--r--math/py-pandas/distinfo4
-rw-r--r--math/py-pandas/files/pkg-message.in30
3 files changed, 48 insertions, 36 deletions
diff --git a/math/py-pandas/Makefile b/math/py-pandas/Makefile
index c19bdd2cc731..6b50697489a1 100644
--- a/math/py-pandas/Makefile
+++ b/math/py-pandas/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= pandas
-PORTVERSION= 0.13.1
-PORTREVISION= 1
+PORTVERSION= 0.14.0
CATEGORIES= math devel python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -17,7 +16,7 @@ RUN_DEPENDS:= ${BUILD_DEPENDS} \
${PYTHON_PKGNAMEPREFIX}dateutil>0:${PORTSDIR}/devel/py-dateutil \
${PYTHON_PKGNAMEPREFIX}pytz>0:${PORTSDIR}/devel/py-pytz \
${PYTHON_PKGNAMEPREFIX}sqlite3>0:${PORTSDIR}/databases/py-sqlite3
-TEST_DEPENDS= ${RUN_DEPENDS} \
+TEST_DEPENDS:= ${RUN_DEPENDS} \
nosetests:${PORTSDIR}/devel/py-nose \
cython:${PORTSDIR}/lang/cython \
${PYTHON_PKGNAMEPREFIX}boto>0:${PORTSDIR}/devel/py-boto \
@@ -27,7 +26,7 @@ TEST_DEPENDS= ${RUN_DEPENDS} \
${PYTHON_PKGNAMEPREFIX}matplotlib>0:${PORTSDIR}/math/py-matplotlib \
${PYTHON_PKGNAMEPREFIX}numexpr>0:${PORTSDIR}/math/py-numexpr \
${PYTHON_PKGNAMEPREFIX}scipy>0:${PORTSDIR}/science/py-scipy \
- ${PYTHON_PKGNAMEPREFIX}openpyxl>0:${PORTSDIR}/textproc/py-openpyxl \
+ ${PYTHON_PKGNAMEPREFIX}openpyxl<2.0.0:${PORTSDIR}/textproc/py-openpyxl1 \
${PYTHON_PKGNAMEPREFIX}xlrd>0:${PORTSDIR}/textproc/py-xlrd \
${PYTHON_PKGNAMEPREFIX}xlwt>0:${PORTSDIR}/textproc/py-xlwt \
${PYTHON_PKGNAMEPREFIX}beautifulsoup>0:${PORTSDIR}/www/py-beautifulsoup \
@@ -35,6 +34,47 @@ TEST_DEPENDS= ${RUN_DEPENDS} \
# Note: we cannot include math/py-statsmodels in TEST_DEPENDS because it
# depends upon us for BUILD and RUN.
+OPTIONS_DEFINE= MPL SCIPY
+OPTIONS_GROUP= ACCEL STORAGE HTML EXCEL
+OPTIONS_GROUP_ACCEL= BTLNCK NUMEXPR
+OPTIONS_GROUP_STORAGE= BOTO TABLES
+OPTIONS_GROUP_HTML= LXML HTML5LIB
+OPTIONS_GROUP_EXCEL= OPENPYXL XLRD XLWT
+
+MPL_DESC= Support graphical plotting output via math/py-matplotlib
+SCIPY_DESC= Support various statistical functions via science/py-scipy
+BTLNCK_DESC= Accelerate certain NaN evals via math/py-bottleneck
+NUMEXPR_DESC= Accelerate certain numerical ops via math/py-numexpr
+BOTO_DESC= Support Amazon S3 storage via devel/py-boto
+TABLES_DESC= Support HDF5-based storage via devel/py-tables
+LXML_DESC= Parse HTML with devel/py-lxml and www/py-beautifulsoup
+HTML5LIB_DESC= Parse HTML with www/py-html5lib and www/py-beautifulsoup
+OPENPYXL_DESC= Read/write MS Excel 2007+ with textproc/py-openpyxl1
+XLRD_DESC= Read MS Excel with textproc/py-xlrd
+XLWT_DESC= Write MS Excel with textproc/py-xlwt
+ACCEL_DESC= Computation Acceleration Add-ons
+STORAGE_DESC= Data Storage Add-ons
+HTML_DESC= HTML Parsing Add-ons
+EXCEL_DESC= MS Excel I/O Add-ons
+
+MPL_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}matplotlib>0:${PORTSDIR}/math/py-matplotlib
+SCIPY_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}scipy>0:${PORTSDIR}/science/py-scipy
+BTLNCK_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}bottleneck>0:${PORTSDIR}/math/py-bottleneck
+NUMEXPR_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}numexpr>0:${PORTSDIR}/math/py-numexpr
+BOTO_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}boto>0:${PORTSDIR}/devel/py-boto
+TABLES_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}tables>0:${PORTSDIR}/devel/py-tables
+LXML_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}lxml>0:${PORTSDIR}/devel/py-lxml
+HTML5LIB_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}html5lib>0:${PORTSDIR}/www/py-html5lib
+OPENPYXL_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}openpyxl<2.0.0:${PORTSDIR}/textproc/py-openpyxl1
+XLRD_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}xlrd>0:${PORTSDIR}/textproc/py-xlrd
+XLWT_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}xlwt>0:${PORTSDIR}/textproc/py-xlwt
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MLXML} || ${PORT_OPTIONS:MHTML5LIB}
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}beautifulsoup>0:${PORTSDIR}/www/py-beautifulsoup
+.endif
+
SUB_FILES= pkg-message
USE_PYTHON= yes
@@ -54,7 +94,7 @@ regression-test: build
${PYTHON_CMD} ${PYSETUP} build_ext --inplace && \
${PYTHON_CMD} -c 'import pandas.util.print_versions as pv; pv.show_versions()' && \
( ${SETENV} ${NOSE_ENV} nosetests ${NOSE_ARGS} || ${TRUE} ) && \
- ${PYTHON_CMD} ${SCRIPTDIR}/print_skipped.py ${XUNITFILE}
+ ${PYTHON_CMD} ${SCRIPTDIR}/print_skipped.py ${XUNITFILE} \
)
.include <bsd.port.mk>
diff --git a/math/py-pandas/distinfo b/math/py-pandas/distinfo
index 395b9da51c26..2f270e2239cc 100644
--- a/math/py-pandas/distinfo
+++ b/math/py-pandas/distinfo
@@ -1,2 +1,2 @@
-SHA256 (pandas-0.13.1.tar.gz) = 6813746caa796550969ed98069f16627f070f6d8d60686cfb3fa0e66c2e0312b
-SIZE (pandas-0.13.1.tar.gz) = 6096890
+SHA256 (pandas-0.14.0.tar.gz) = f7997debca756c4dd5ccdf5a010dfe3d1c7dac98ee706b715d994cf7c9d35528
+SIZE (pandas-0.14.0.tar.gz) = 6526846
diff --git a/math/py-pandas/files/pkg-message.in b/math/py-pandas/files/pkg-message.in
index 09f5e907da6a..1f97e49496c0 100644
--- a/math/py-pandas/files/pkg-message.in
+++ b/math/py-pandas/files/pkg-message.in
@@ -1,31 +1,3 @@
===
-Note that the following ports are not strict dependencies but are highly
-recommended to get the most out of pandas. Install them as needed.
-
-Library Port origin Purpose
-------- ----------- -------
-boto devel/py-boto access Amazon S3
-pytables devel/py-tables necessary for HDF5-based storage
-bottleneck math/py-bottleneck accelerate certain NaN evals
-matplotlib math/py-matplotlib plotting
-numexpr math/py-numexpr accelerate certain numerical ops
-statsmodels math/py-statsmodels enables parts of pandas.stats
-scipy science/py-scipy misc. statistical functions
-openpyxl textproc/py-openpyxl Excel 2007+ I/O
-xlrd textproc/py-xlrd Excel input
-xlwt textproc/py-xlwt Excel output
-
-To use the HTML table parsing capabilities that were introduced in
-pandas 0.12.0, you will need to install
-
-beautifulsoup www/py-beautifulsoup
-
-and one or the other or both of
-
-html5lib www/py-html5lib
-lxml devel/py-lxml
-
-Please read the pandas documentation before deciding:
-
-http://pandas.pydata.org/pandas-docs/stable/gotchas.html#html-gotchas
+If you wish, install math/py-statsmodels to enable parts of pandas.stats.
===