aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authordemon <demon@FreeBSD.org>2014-10-23 22:05:56 +0800
committerdemon <demon@FreeBSD.org>2014-10-23 22:05:56 +0800
commit8784fe95fe5a29e093266128689d757eebbb17ff (patch)
tree0111d381abf7395274ead948e51fcecd5f4b816a /math
parentec0bba6df255a514220803c348107dda4093e1e3 (diff)
downloadfreebsd-ports-gnome-8784fe95fe5a29e093266128689d757eebbb17ff.tar.gz
freebsd-ports-gnome-8784fe95fe5a29e093266128689d757eebbb17ff.tar.zst
freebsd-ports-gnome-8784fe95fe5a29e093266128689d757eebbb17ff.zip
Use std::isspace instead of isspace to fix the following compile error in
py-fst: In file included from fst/_fst.cpp:322: In file included from /usr/local/include/fst/fstlib.h:49: In file included from /usr/local/include/fst/fst.h:34: In file included from /usr/local/include/fst/arc.h:31: In file included from /usr/local/include/fst/power-weight.h:24: /usr/local/include/fst/tuple-weight.h:179:14: error: call to 'isspace' is ambiguous } while (isspace(c)); ^~~~~~~ /usr/include/ctype.h:57:5: note: candidate function int isspace(int); ^ /usr/include/c++/v1/cctype:125:38: note: candidate function inline _LIBCPP_INLINE_VISIBILITY int isspace(int __c) {return __libcpp_isspace(__c);} /usr/include/ctype.h:57:5: note: candidate function int isspace(int); ^ /usr/include/c++/v1/cctype:125:38: note: candidate function inline _LIBCPP_INLINE_VISIBILITY int isspace(int __c) {return __libcpp_isspace(__c);}
Diffstat (limited to 'math')
-rw-r--r--math/openfst/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/math/openfst/Makefile b/math/openfst/Makefile
index c2086bcbf8d5..87a5242b94ef 100644
--- a/math/openfst/Makefile
+++ b/math/openfst/Makefile
@@ -3,7 +3,7 @@
PORTNAME= openfst
PORTVERSION= 1.4.1
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= math
MASTER_SITES= http://www.openfst.org/twiki/pub/FST/FstDownload/
@@ -19,5 +19,6 @@ CONFIGURE_ARGS+=--enable-compact-fsts --enable-const-fsts --enable-far --enable-
post-patch:
${REINPLACE_CMD} -e s#-ldl## ${WRKSRC}/src/extensions/far/Makefile.in ${WRKSRC}/src/extensions/pdt/Makefile.in ${WRKSRC}/src/bin/Makefile.in ${WRKSRC}/src/test/Makefile.in ${WRKSRC}/src/extensions/linear/Makefile.in
+ ${REINPLACE_CMD} -e s#isspace#std::isspace# ${WRKSRC}/src/include/fst/tuple-weight.h ${WRKSRC}/src/include/fst/sparse-tuple-weight.h ${WRKSRC}/src/include/fst/pair-weight.h
.include <bsd.port.mk>