aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-09-17 00:45:35 +0800
committerbapt <bapt@FreeBSD.org>2013-09-17 00:45:35 +0800
commit8a97294176dc73b4561ed2402dc5453250075385 (patch)
tree62ec5ad5c85e69fd9755b85db994f8c7042a1fc0 /math
parentc2a9f33f2d93e1b5f33bb630e61a261db891265a (diff)
downloadfreebsd-ports-gnome-8a97294176dc73b4561ed2402dc5453250075385.tar.gz
freebsd-ports-gnome-8a97294176dc73b4561ed2402dc5453250075385.tar.zst
freebsd-ports-gnome-8a97294176dc73b4561ed2402dc5453250075385.zip
Convert to new perl framework
Convert USE_GMAKE to USES
Diffstat (limited to 'math')
-rw-r--r--math/asymptote/Makefile4
-rw-r--r--math/fftw3/Makefile4
-rw-r--r--math/gotoblas/Makefile3
-rw-r--r--math/isabelle/Makefile10
-rw-r--r--math/mtl/Makefile10
-rw-r--r--math/oleo/Makefile4
-rw-r--r--math/polymake/Makefile9
-rw-r--r--math/yacas/Makefile4
8 files changed, 20 insertions, 28 deletions
diff --git a/math/asymptote/Makefile b/math/asymptote/Makefile
index 8f9cd7f4f3f8..b098e753635d 100644
--- a/math/asymptote/Makefile
+++ b/math/asymptote/Makefile
@@ -27,8 +27,8 @@ CONFIGURE_ARGS= --disable-gc
USE_GHOSTSCRIPT=yes
USE_TEX= latex
USE_GL= glut
-USE_GMAKE= yes
-USE_PERL5_BUILD= yes
+USES= gmake perl5
+USE_PERL5= build
USE_PYTHON= yes
MAKE_JOBS_UNSAFE= yes
diff --git a/math/fftw3/Makefile b/math/fftw3/Makefile
index 9ea1decf50c4..938da4c03588 100644
--- a/math/fftw3/Makefile
+++ b/math/fftw3/Makefile
@@ -19,8 +19,8 @@ FFTW3_FLAVOR?= default
FFTW3_SUFX=
GNU_CONFIGURE= yes
-USES= pathfix pkgconfig
-USE_PERL5_BUILD=yes
+USES= pathfix perl5 pkgconfig
+USE_PERL5= build
USE_LDCONFIG= yes
CONFIGURE_ARGS = --enable-shared --enable-threads --disable-fortran
diff --git a/math/gotoblas/Makefile b/math/gotoblas/Makefile
index 24b482c30409..9750d82e3f4e 100644
--- a/math/gotoblas/Makefile
+++ b/math/gotoblas/Makefile
@@ -29,7 +29,8 @@ USE_GMAKE= yes
USE_LDCONFIG= yes
WRKSRC= ${WRKDIR}/GotoBLAS2
-USE_PERL5_BUILD= yes
+USES= gmake perl5
+USE_PERL5= build
USE_FORTRAN= yes
GOTOLIBS= libgoto2 libgoto2p
GOTOFILES= ${GOTOLIBS:S|$|.so|} ${GOTOLIBS:S|$|.so.1|} ${GOTOLIBS:S|$|.a|}
diff --git a/math/isabelle/Makefile b/math/isabelle/Makefile
index 26ebb87e036b..1d196217b4ab 100644
--- a/math/isabelle/Makefile
+++ b/math/isabelle/Makefile
@@ -29,7 +29,7 @@ HOL_TLA_DESC= Build optional heap: TLA
HOL_HOL4_DESC= Build optional heap: HOL4
EMACS_PKG_DESC= Build with Emacs Packages
-USE_PERL5= yes
+USES= perl5
.include <bsd.port.options.mk>
@@ -39,10 +39,10 @@ DISTFILES= ${DISTNAME}.tar.gz \
.endif
.if ${PORT_OPTIONS:MEMACS_PKG}
- USE_EMACS= yes # for EMACS_SITE_LISPDIR
- EMACS_NO_BUILD_DEPENDS=yes
- EMACS_NO_RUN_DEPENDS=yes
- RUN_DEPENDS+= proofgeneral:${PORTSDIR}/math/proofgeneral
+USE_EMACS= yes # for EMACS_SITE_LISPDIR
+EMACS_NO_BUILD_DEPENDS=yes
+EMACS_NO_RUN_DEPENDS=yes
+RUN_DEPENDS+= proofgeneral:${PORTSDIR}/math/proofgeneral
.else
.endif
diff --git a/math/mtl/Makefile b/math/mtl/Makefile
index 71ae6d367a5a..4497645a0d6d 100644
--- a/math/mtl/Makefile
+++ b/math/mtl/Makefile
@@ -1,10 +1,5 @@
-# ex:ts=8
-# Ports collection makefile for: mtl
-# Date created: Mar 15, 2002
-# Whom: ijliao
-#
+# Created by: ijliao
# $FreeBSD$
-#
PORTNAME= mtl
DISTVERSION= 2.1.2-23.tentative
@@ -23,7 +18,8 @@ CONFIGURE_ENV= CXXCPP="${CXXCPP}"
CXXCPP?= ${CXX} -E
GNU_CONFIGURE= yes
NO_BUILD= yes
-USE_PERL5_BUILD= yes
+USES= perl5
+USE_PERL5= build
WRKSRC = ${WRKDIR}/${DISTNAME:R}
post-patch:
diff --git a/math/oleo/Makefile b/math/oleo/Makefile
index 2717e294d515..0eb30c9bf9f9 100644
--- a/math/oleo/Makefile
+++ b/math/oleo/Makefile
@@ -11,8 +11,8 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= gahr@FreeBSD.org
COMMENT= The GNU spreadsheet for X11 and terminals
-USE_PERL5_BUILD= yes
-USES= bison
+USE_PERL5= build
+USES= bison perl5
USE_AUTOTOOLS= autoconf213
CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib"
CPPFLAGS+= -I${LOCALBASE}/include
diff --git a/math/polymake/Makefile b/math/polymake/Makefile
index a712c9def124..eb86d977c9bc 100644
--- a/math/polymake/Makefile
+++ b/math/polymake/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: polymake
-# Date created: 21 December 2004
-# Whom: Ewgenij Gawrilow <gawrilow@math.tu-berlin.de>
-#
+# Created by: Ewgenij Gawrilow <gawrilow@math.tu-berlin.de>
# $FreeBSD$
-#
PORTNAME= polymake
PORTVERSION= 2.9.9
@@ -25,9 +21,8 @@ RUN_DEPENDS= p5-XML-LibXML>=0:${PORTSDIR}/textproc/p5-XML-LibXML \
LIB_DEPENDS= gmp.10:${PORTSDIR}/math/gmp \
readline.[56]:${PORTSDIR}/devel/readline
-USE_GMAKE= yes
+USES= gmake perl5
USE_BZIP2= yes
-USE_PERL5= yes
USE_GCC= 4.2+
USE_JAVA= yes
JAVA_BUILD= yes
diff --git a/math/yacas/Makefile b/math/yacas/Makefile
index 3956cf1bd887..1e643e0848f8 100644
--- a/math/yacas/Makefile
+++ b/math/yacas/Makefile
@@ -16,8 +16,8 @@ OPTIONS_DEFINE= TESTS DOCS
OPTIONS_DEFAULT= TESTS
TESTS_DESC= Run bundled self-tests after build
-USE_PERL5_BUILD=yes
-USE_GMAKE= yes
+USES= gmake perl5
+USE_PERL5= build
#USE_AUTOTOOLS= libtool
GNU_CONFIGURE= yes