aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorRainer Hurling <rhurlin@FreeBSD.org>2021-01-06 01:05:57 +0800
committerRainer Hurling <rhurlin@FreeBSD.org>2021-01-06 01:05:57 +0800
commit8e2c19381feb34a3388a847cca622a8af5bc96de (patch)
tree9a51ef01ab3eb7e17a487d93a8cfa3191de413a6 /math
parent575191b6a15aea479469124433aea0d793d4739f (diff)
downloadfreebsd-ports-gnome-8e2c19381feb34a3388a847cca622a8af5bc96de.tar.gz
freebsd-ports-gnome-8e2c19381feb34a3388a847cca622a8af5bc96de.tar.zst
freebsd-ports-gnome-8e2c19381feb34a3388a847cca622a8af5bc96de.zip
math/py-matplotlib: Update to 3.3.3
Changelog: https://github.com/matplotlib/matplotlib/releases PR: 252432 Approved by: arrowd (mentor)
Diffstat (limited to 'math')
-rw-r--r--math/py-matplotlib/Makefile11
-rw-r--r--math/py-matplotlib/distinfo6
-rw-r--r--math/py-matplotlib/files/patch-setup.cfg4
3 files changed, 11 insertions, 10 deletions
diff --git a/math/py-matplotlib/Makefile b/math/py-matplotlib/Makefile
index 67361a802cb9..7e8e554a3ad0 100644
--- a/math/py-matplotlib/Makefile
+++ b/math/py-matplotlib/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= matplotlib
-PORTVERSION= 3.3.1
+PORTVERSION= 3.3.3
CATEGORIES= math python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -38,26 +38,27 @@ USE_PYTHON= distutils
LDFLAGS+= -fuse-ld=lld
+PLIST_SUB= VER=${PORTVERSION}
+PORTEXAMPLES= *
+
OPTIONS_DEFINE= EXAMPLES \
QT5AGGBACKEND TKAGGBACKEND
OPTIONS_DEFAULT= TKAGGBACKEND
OPTIONS_SUB= yes
QT5AGGBACKEND_DESC= Qt5Agg backend support
+TKAGGBACKEND_DESC= TKAgg backend support
+
QT5AGGBACKEND_USES= display pyqt:5
QT5AGGBACKEND_USE= PYQT=sip,widgets
QT5AGGBACKEND_VARS= QT5AGG_BACKEND=True
QT5AGGBACKEND_VARS_OFF= QT5AGG_BACKEND=False
-TKAGGBACKEND_DESC= TKAgg backend support
TKAGGBACKEND_BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}tkinter>0:x11-toolkits/py-tkinter@${PY_FLAVOR}
TKAGGBACKEND_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}tkinter>0:x11-toolkits/py-tkinter@${PY_FLAVOR}
TKAGGBACKEND_USES= display tk:run
TKAGGBACKEND_VARS= TKAGG_BACKEND=True
TKAGGBACKEND_VARS_OFF= TKAGG_BACKEND=False
-PLIST_SUB= VER=${PORTVERSION}
-PORTEXAMPLES= *
-
post-extract:
@${FIND} ${WRKSRC} -name '*.py' | ${XARGS} ${CHMOD} -x
diff --git a/math/py-matplotlib/distinfo b/math/py-matplotlib/distinfo
index b690a648c666..16754e58c13e 100644
--- a/math/py-matplotlib/distinfo
+++ b/math/py-matplotlib/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1598015166
-SHA256 (matplotlib-3.3.1.tar.gz) = 87f53bcce90772f942c2db56736788b39332d552461a5cb13f05ff45c1680f0e
-SIZE (matplotlib-3.3.1.tar.gz) = 38780756
+TIMESTAMP = 1609832769
+SHA256 (matplotlib-3.3.3.tar.gz) = b1b60c6476c4cfe9e5cf8ab0d3127476fd3d5f05de0f343a452badaad0e4bdec
+SIZE (matplotlib-3.3.3.tar.gz) = 37944403
diff --git a/math/py-matplotlib/files/patch-setup.cfg b/math/py-matplotlib/files/patch-setup.cfg
index 296628a65950..2a3ff257b7c8 100644
--- a/math/py-matplotlib/files/patch-setup.cfg
+++ b/math/py-matplotlib/files/patch-setup.cfg
@@ -30,8 +30,8 @@
+# is the default behavior
+#
+## Date/timezone support:
-+pytz = False
-+dateutil = False
++pytz = True
++dateutil = True
+
+[gui_support]
+# Matplotlib supports multiple GUI toolkits, including Cocoa,