aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2012-07-13 21:08:15 +0800
committersunpoet <sunpoet@FreeBSD.org>2012-07-13 21:08:15 +0800
commit951d35878d864fab62410db4139477313a87b1b3 (patch)
tree71cc2656577c6701ff46a1867061596cbe8399d5 /math
parent6f56151d2423c3ba9a6167388a9a3d933b185e3e (diff)
downloadfreebsd-ports-gnome-951d35878d864fab62410db4139477313a87b1b3.tar.gz
freebsd-ports-gnome-951d35878d864fab62410db4139477313a87b1b3.tar.zst
freebsd-ports-gnome-951d35878d864fab62410db4139477313a87b1b3.zip
- Convert to new options framework
PR: ports/169821 Submitted by: Anton Shterenlikht <mexas@bristol.ac.uk> (maintainer, new address)
Diffstat (limited to 'math')
-rw-r--r--math/slatec/Makefile15
1 files changed, 7 insertions, 8 deletions
diff --git a/math/slatec/Makefile b/math/slatec/Makefile
index b5cb3806e27f..4f548c449043 100644
--- a/math/slatec/Makefile
+++ b/math/slatec/Makefile
@@ -26,6 +26,7 @@ WRKSRC= ${WRKDIR}/src
SHLIB_MAJOR= 1
PLIST_FILES= lib/libslatec.a lib/libslatec.so lib/libslatec.so.${SHLIB_MAJOR}
+PORTDOCS= guide toc
LDFLAGS+= ${FFLAGS}
LDADD ?= -lgfortran -lm
@@ -33,16 +34,16 @@ SRCCONF= ${NONEXISTENT}
MAKE_ENV+= LDADD="${LDADD}" SHLIB_MAJOR="${SHLIB_MAJOR}" \
SRCCONF="${SRCCONF}"
-OPTIONS= PROFILE "Build a profiling library" Off
+OPTIONS_DEFINE= DOCS PROFILE
.include <bsd.port.options.mk>
-.if defined(WITH_PROFILE)
+.if ${PORT_OPTIONS:MPROFILE}
.if defined(NOPROFILE) || defined(NO_PROFILE) || defined(WITHOUT_PROFILE)
-IGNORE = you have defined WITH_PROFILE, but have also defined\
+IGNORE= you have selected PROFILE option, but have also defined\
WITHOUT_PROFILE, NOPROFILE, or NO_PROFILE
.elif !exists(/usr/lib/libc_p.a)
-IGNORE = you have chosen WITH_PROFILE, but have not installed the\
+IGNORE= you have chosen WITH_PROFILE, but have not installed the\
base system profiling libraries
.endif
PLIST_FILES+= lib/libslatec_p.a
@@ -72,12 +73,10 @@ test-${l}: build
.endfor
-.if !defined(NOPORTDOCS)
-PORTDOCS= guide toc
-
post-install:
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
@cd ${_DISTDIR}; ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
-
.endif
+
.include <bsd.port.mk>