aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authortobik <tobik@FreeBSD.org>2019-05-27 18:10:15 +0800
committertobik <tobik@FreeBSD.org>2019-05-27 18:10:15 +0800
commit97ffb532199cb32d25b55567470a11018bd668e7 (patch)
treee0ea8614483d59b7d2b1f3254fb4863815e74a49 /math
parent7f3e2e3b123116c663b6c9769ef4d10bf4c91d6f (diff)
downloadfreebsd-ports-gnome-97ffb532199cb32d25b55567470a11018bd668e7.tar.gz
freebsd-ports-gnome-97ffb532199cb32d25b55567470a11018bd668e7.tar.zst
freebsd-ports-gnome-97ffb532199cb32d25b55567470a11018bd668e7.zip
math/cvc4: Remove llvm60 build dependency
It was added for FreeBSD 10.x/i386 and is no longer needed. PR: 238162 Approved by: greg@unrelenting.technology (maintainer)
Diffstat (limited to 'math')
-rw-r--r--math/cvc4/Makefile9
1 files changed, 2 insertions, 7 deletions
diff --git a/math/cvc4/Makefile b/math/cvc4/Makefile
index 229c0ffbde89..ff581deff760 100644
--- a/math/cvc4/Makefile
+++ b/math/cvc4/Makefile
@@ -17,7 +17,8 @@ LIB_DEPENDS= libantlr3c.so:devel/libantlr3c \
BUILD_DEPENDS= bash:shells/bash \
antlr3:devel/antlr3
-USES= autoreconf gmake python:3.5+,build libtool localbase pkgconfig shebangfix
+USES= autoreconf compiler:c++17-lang gmake libtool localbase \
+ pkgconfig python:3.5+,build shebangfix
USE_JAVA= yes
JAVA_BUILD= yes
@@ -72,10 +73,4 @@ LICENSE= GPLv3
CONFIGURE_ARGS+= --enable-gpl
.endif
-# use the fixed compiler version from ports to prevent failures on FreeBSD_10
-LLVM_VERSION= 60
-BUILD_DEPENDS+= clang${LLVM_VERSION}:devel/llvm${LLVM_VERSION}
-CC= clang${LLVM_VERSION}
-CXX= clang++${LLVM_VERSION}
-
.include <bsd.port.mk>