aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorfernape <fernape@FreeBSD.org>2019-08-07 01:53:16 +0800
committerfernape <fernape@FreeBSD.org>2019-08-07 01:53:16 +0800
commit9aef22c4afb264a272755114a4c2f582f6208da4 (patch)
treefa4fe6481c6c7a14f245be3baaac3edeccf9dfc6 /math
parent24119b4258dcd55730e75a7a79c17ea28696cbda (diff)
downloadfreebsd-ports-gnome-9aef22c4afb264a272755114a4c2f582f6208da4.tar.gz
freebsd-ports-gnome-9aef22c4afb264a272755114a4c2f582f6208da4.tar.zst
freebsd-ports-gnome-9aef22c4afb264a272755114a4c2f582f6208da4.zip
math/emc2: pet portlint
* Move out of order variable * Remake patches
Diffstat (limited to 'math')
-rw-r--r--math/emc2/Makefile4
-rw-r--r--math/emc2/files/patch-Makefile4
-rw-r--r--math/emc2/files/patch-f3d__u_hp700__prettydate.c8
-rw-r--r--math/emc2/files/patch-f3d__u_hp700__prettytime.c8
-rw-r--r--math/emc2/files/patch-libI77__fio.h4
-rw-r--r--math/emc2/files/patch-libI77__lread.c10
-rw-r--r--math/emc2/files/patch-libemc2_1.c6
7 files changed, 22 insertions, 22 deletions
diff --git a/math/emc2/Makefile b/math/emc2/Makefile
index 8e6b4606c831..6dac0e70630c 100644
--- a/math/emc2/Makefile
+++ b/math/emc2/Makefile
@@ -17,11 +17,11 @@ LICENSE_NAME= INRIA license, perhaps specific to emc2
LICENSE_FILE= ${WRKSRC}/COPYRIGHT
LICENSE_PERMS= auto-accept no-dist-sell no-pkg-sell
-RESTRICTED= No resale, contact author for commercial usage
-
USES= gmake
USE_XORG= x11 xau xcb xdmcp
+
ALL_TARGET= ${PORTNAME}
+RESTRICTED= No resale, contact author for commercial usage
.if defined(LANG) && ${LANG:Mfr*} != ""
CFLAGS+= -DFRENCH
diff --git a/math/emc2/files/patch-Makefile b/math/emc2/files/patch-Makefile
index 2dd8634f9b0b..344fe959b418 100644
--- a/math/emc2/files/patch-Makefile
+++ b/math/emc2/files/patch-Makefile
@@ -1,5 +1,5 @@
---- Makefile.orig Mon Feb 10 09:17:51 2003
-+++ Makefile Tue Dec 16 23:22:42 2003
+--- Makefile.orig 2003-02-10 08:17:51 UTC
++++ Makefile
@@ -8,9 +8,9 @@
# for IBM RS6000
#CC=xlc
diff --git a/math/emc2/files/patch-f3d__u_hp700__prettydate.c b/math/emc2/files/patch-f3d__u_hp700__prettydate.c
index 1cc91f968391..1e8ceb1ea4f7 100644
--- a/math/emc2/files/patch-f3d__u_hp700__prettydate.c
+++ b/math/emc2/files/patch-f3d__u_hp700__prettydate.c
@@ -1,6 +1,6 @@
---- ./f3d/u_hp700/prettydate.c.orig 2010-08-31 08:51:18.000000000 -0400
-+++ ./f3d/u_hp700/prettydate.c 2010-08-31 08:52:44.000000000 -0400
-@@ -6,7 +6,7 @@
+--- f3d/u_hp700/prettydate.c.orig 1999-11-09 14:58:17 UTC
++++ f3d/u_hp700/prettydate.c
+@@ -6,7 +6,7 @@ char *date;
{
time_t timevar;
struct tm *pttm;
@@ -9,7 +9,7 @@
timevar=time(&timevar);
pttm = localtime(&timevar);
-@@ -14,6 +14,6 @@
+@@ -14,6 +14,6 @@ char *date;
sprintf(buffer,"%02d%02d%02d",pttm->tm_year % 100,
pttm->tm_mon+1,
pttm->tm_mday);
diff --git a/math/emc2/files/patch-f3d__u_hp700__prettytime.c b/math/emc2/files/patch-f3d__u_hp700__prettytime.c
index 863755e7427d..ce5e229beab0 100644
--- a/math/emc2/files/patch-f3d__u_hp700__prettytime.c
+++ b/math/emc2/files/patch-f3d__u_hp700__prettytime.c
@@ -1,6 +1,6 @@
---- ./f3d/u_hp700/prettytime.c.orig 2010-08-31 08:51:31.000000000 -0400
-+++ ./f3d/u_hp700/prettytime.c 2010-08-31 08:52:32.000000000 -0400
-@@ -6,7 +6,7 @@
+--- f3d/u_hp700/prettytime.c.orig 1999-11-09 14:58:18 UTC
++++ f3d/u_hp700/prettytime.c
+@@ -6,7 +6,7 @@ char *timeret;
{
time_t timevar;
struct tm *pttm;
@@ -9,7 +9,7 @@
timevar=time(&timevar);
pttm = localtime(&timevar);
-@@ -14,6 +14,6 @@
+@@ -14,6 +14,6 @@ char *timeret;
sprintf(buffer,"%02d%02d%02d000000",pttm->tm_hour,
pttm->tm_min,
pttm->tm_sec);
diff --git a/math/emc2/files/patch-libI77__fio.h b/math/emc2/files/patch-libI77__fio.h
index 1ebd63157a40..83cd08d3a14a 100644
--- a/math/emc2/files/patch-libI77__fio.h
+++ b/math/emc2/files/patch-libI77__fio.h
@@ -1,5 +1,5 @@
---- libI77/fio.h.orig Tue Nov 9 15:58:43 1999
-+++ libI77/fio.h Tue Dec 16 23:53:43 2003
+--- libI77/fio.h.orig 1999-11-09 14:58:43 UTC
++++ libI77/fio.h
@@ -17,6 +17,12 @@
#endif
#endif
diff --git a/math/emc2/files/patch-libI77__lread.c b/math/emc2/files/patch-libI77__lread.c
index c948e6142608..4590305bed6a 100644
--- a/math/emc2/files/patch-libI77__lread.c
+++ b/math/emc2/files/patch-libI77__lread.c
@@ -1,6 +1,6 @@
---- ./libI77/lread.c.orig 2010-08-31 08:39:32.000000000 -0400
-+++ ./libI77/lread.c 2010-08-31 08:40:19.000000000 -0400
-@@ -369,7 +369,7 @@
+--- libI77/lread.c.orig 1999-11-09 14:58:44 UTC
++++ libI77/lread.c
+@@ -369,7 +369,7 @@ l_CHAR(Void)
*p++ = ch;
f__lcount = 10*f__lcount + ch - '0';
if (++i == size) {
@@ -9,7 +9,7 @@
(unsigned int)(size += BUFSIZE));
p = f__lchar + i;
}
-@@ -401,7 +401,7 @@
+@@ -401,7 +401,7 @@ l_CHAR(Void)
noquote:
*p++ = ch;
if (++i == size) {
@@ -18,7 +18,7 @@
(unsigned int)(size += BUFSIZE));
p = f__lchar + i;
}
-@@ -414,7 +414,7 @@
+@@ -414,7 +414,7 @@ l_CHAR(Void)
if(i==size)
{
newone:
diff --git a/math/emc2/files/patch-libemc2_1.c b/math/emc2/files/patch-libemc2_1.c
index eca9f96691b8..6b7ce92b7986 100644
--- a/math/emc2/files/patch-libemc2_1.c
+++ b/math/emc2/files/patch-libemc2_1.c
@@ -1,6 +1,6 @@
---- ./libemc2_1.c.orig 2010-08-31 08:37:40.000000000 -0400
-+++ ./libemc2_1.c 2010-08-31 08:38:38.000000000 -0400
-@@ -1517,7 +1517,7 @@
+--- libemc2_1.c.orig 1999-11-09 14:58:23 UTC
++++ libemc2_1.c
+@@ -1517,7 +1517,7 @@ R*/
i__1[2] = 7, a__1[2] = "' retry";
s_cat(ch__1, a__1, i__1, &c__3, 99L);
scrtch_(ch__1, ii + 19);