aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2014-02-17 06:01:00 +0800
committermarino <marino@FreeBSD.org>2014-02-17 06:01:00 +0800
commita370b559910f84f802a1f062eaa6675ae5f6b7e3 (patch)
tree610c63f437e9ab26bae7afa0b60cfa2607283ffb /math
parent2e6c18141ed0078f5b2647d64f3f5e85342bb75c (diff)
downloadfreebsd-ports-gnome-a370b559910f84f802a1f062eaa6675ae5f6b7e3.tar.gz
freebsd-ports-gnome-a370b559910f84f802a1f062eaa6675ae5f6b7e3.tar.zst
freebsd-ports-gnome-a370b559910f84f802a1f062eaa6675ae5f6b7e3.zip
Add new port math/plplot-ada: Ada bindings to plplot library
Diffstat (limited to 'math')
-rw-r--r--math/Makefile1
-rw-r--r--math/plplot-ada/Makefile30
-rw-r--r--math/plplot-ada/files/Makefile17
-rw-r--r--math/plplot-ada/files/build_plplot.gpr15
-rw-r--r--math/plplot-ada/files/plplot.gpr.in15
-rw-r--r--math/plplot-ada/pkg-descr4
-rw-r--r--math/plplot-ada/pkg-plist17
7 files changed, 99 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index 56703b51fa6b..cec2719dc770 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -535,6 +535,7 @@
SUBDIR += ploticus
SUBDIR += ploticus-nox11
SUBDIR += plplot
+ SUBDIR += plplot-ada
SUBDIR += polymake
SUBDIR += primegen
SUBDIR += prng
diff --git a/math/plplot-ada/Makefile b/math/plplot-ada/Makefile
new file mode 100644
index 000000000000..a0753dab41dd
--- /dev/null
+++ b/math/plplot-ada/Makefile
@@ -0,0 +1,30 @@
+# Created by: John Marino <marino@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= plplot
+PORTVERSION= ${RELEASE}
+CATEGORIES= math
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION}%20Source
+PKGNAMESUFFIX= -ada
+
+MAINTAINER= marino@FreeBSD.org
+COMMENT= Ada bindings for PLplot
+
+LICENSE= LGPL3
+
+LIB_DEPENDS= libplplotd.so:${PORTSDIR}/math/plplot
+
+USES= ada
+
+DISTINFO_FILE= ${.CURDIR}/../plplot/distinfo
+RELEASE!= awk '/SHA/ {split($$2,a,"."); print substr(a[1], 9) "." a[2] "." a[3];}' ${DISTINFO_FILE}
+BUILD_WRKSRC= ${WRKSRC}/bindings
+INSTALL_WRKSRC= ${WRKSRC}/bindings
+
+post-extract:
+ ${CP} ${FILESDIR}/build_plplot.gpr ${FILESDIR}/Makefile \
+ ${BUILD_WRKSRC}
+ ${CAT} ${FILESDIR}/plplot.gpr.in | ${SED} -e "s|@PREFIX@|${PREFIX}|g" > \
+ ${BUILD_WRKSRC}/plplot.gpr
+
+.include <bsd.port.mk>
diff --git a/math/plplot-ada/files/Makefile b/math/plplot-ada/files/Makefile
new file mode 100644
index 000000000000..679a3a66b4ae
--- /dev/null
+++ b/math/plplot-ada/files/Makefile
@@ -0,0 +1,17 @@
+all: build
+
+build:
+ gnatmake -p -P build_plplot
+
+install:
+ mkdir -p ${DESTDIR}${PREFIX}/lib/gnat \
+ ${DESTDIR}${PREFIX}/lib/plplotada \
+ ${DESTDIR}${PREFIX}/include/plplotada
+ ${BSD_INSTALL_LIB} ada/build/lib/libplplotada.a \
+ ${DESTDIR}${PREFIX}/lib/plplotada
+ ${BSD_INSTALL_DATA} ada/build/lib/*.ali \
+ ${DESTDIR}${PREFIX}/lib/plplotada
+ ${BSD_INSTALL_DATA} plplot.gpr \
+ ${DESTDIR}${PREFIX}/lib/gnat
+ ${BSD_INSTALL_DATA} ada/*.ad[bs] \
+ ${DESTDIR}${PREFIX}/include/plplotada
diff --git a/math/plplot-ada/files/build_plplot.gpr b/math/plplot-ada/files/build_plplot.gpr
new file mode 100644
index 000000000000..c347c14716b0
--- /dev/null
+++ b/math/plplot-ada/files/build_plplot.gpr
@@ -0,0 +1,15 @@
+project BUILD_PLPLOT is
+
+ for Languages use ("Ada");
+
+ for Source_Dirs use ("ada");
+ for Object_Dir use "ada/build";
+ for Library_Dir use "ada/build/lib";
+ for Library_Name use "plplotada";
+ for Library_Kind use "static";
+
+ package compiler is
+ for switches ("Ada") use ("-O2", "-gnatn");
+ end compiler;
+
+end BUILD_PLPLOT ;
diff --git a/math/plplot-ada/files/plplot.gpr.in b/math/plplot-ada/files/plplot.gpr.in
new file mode 100644
index 000000000000..a21c7947f14d
--- /dev/null
+++ b/math/plplot-ada/files/plplot.gpr.in
@@ -0,0 +1,15 @@
+library project PLPLOT is
+
+ for Languages use ("Ada");
+
+ for Source_Dirs use ("../../include/plplotada");
+ for Library_Dir use "../../lib/plplotada";
+ for Library_Name use "plplotada";
+ for Library_Kind use "static";
+ for Externally_Built use "True";
+
+ package Linker is
+ for switches ("Ada") use ("-L@PREFIX@/lib", "-lplplotd");
+ end Linker;
+
+end PLPLOT;
diff --git a/math/plplot-ada/pkg-descr b/math/plplot-ada/pkg-descr
new file mode 100644
index 000000000000..8011301b174d
--- /dev/null
+++ b/math/plplot-ada/pkg-descr
@@ -0,0 +1,4 @@
+These are the Ada bindings for math/plplot, a cross-platform software
+package for creating scientific plots.
+
+WWW: http://plplot.sourceforge.net
diff --git a/math/plplot-ada/pkg-plist b/math/plplot-ada/pkg-plist
new file mode 100644
index 000000000000..917125ab2220
--- /dev/null
+++ b/math/plplot-ada/pkg-plist
@@ -0,0 +1,17 @@
+include/plplotada/plplot.adb
+include/plplotada/plplot.ads
+include/plplotada/plplot_auxiliary.adb
+include/plplotada/plplot_auxiliary.ads
+include/plplotada/plplot_thin.adb
+include/plplotada/plplot_thin.ads
+include/plplotada/plplot_traditional.adb
+include/plplotada/plplot_traditional.ads
+lib/gnat/plplot.gpr
+lib/plplotada/libplplotada.a
+lib/plplotada/plplot.ali
+lib/plplotada/plplot_auxiliary.ali
+lib/plplotada/plplot_thin.ali
+lib/plplotada/plplot_traditional.ali
+@dirrm lib/plplotada
+@dirrmtry lib/gnat
+@dirrm include/plplotada