aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2018-04-11 15:40:47 +0800
committerMathieu Arnold <mat@FreeBSD.org>2018-04-11 15:40:47 +0800
commitaa8828b1f73cb4fd7b2e327c658213d18eb8cbb1 (patch)
treeb13cc30e7a0ad1c1224c7dbce49d49e7558488e7 /math
parent9f15be91e47d65bda0143ff7d39b13307b47f239 (diff)
downloadfreebsd-ports-gnome-aa8828b1f73cb4fd7b2e327c658213d18eb8cbb1.tar.gz
freebsd-ports-gnome-aa8828b1f73cb4fd7b2e327c658213d18eb8cbb1.tar.zst
freebsd-ports-gnome-aa8828b1f73cb4fd7b2e327c658213d18eb8cbb1.zip
Use USE_GITHUB correctly.
Sponsored by: Absolight
Diffstat (limited to 'math')
-rw-r--r--math/py-pynleq2/Makefile11
-rw-r--r--math/py-pynleq2/distinfo6
2 files changed, 8 insertions, 9 deletions
diff --git a/math/py-pynleq2/Makefile b/math/py-pynleq2/Makefile
index fb366ecc734a..57ef8f94449e 100644
--- a/math/py-pynleq2/Makefile
+++ b/math/py-pynleq2/Makefile
@@ -3,11 +3,9 @@
PORTNAME= pynleq2
DISTVERSION= 0.0.2
CATEGORIES= math python
-MASTER_SITES= CHEESESHOP \
- https://github.com/PySCeS/pysces/archive/:fortran
+MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
-DISTFILES= ${PORTNAME}-${DISTVERSION}${EXTRACT_SUFX} \
- ${PYSCES_VERSION}${EXTRACT_SUFX}:fortran
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= yuri@FreeBSD.org
COMMENT= Python binding for NLEQ2 algorithm's fortran implementation
@@ -19,16 +17,17 @@ BUILD_DEPENDS= ${PYNUMPY}
USES= fortran:flang python
USE_PYTHON= distutils autoplist
+USE_GITHUB= nodefault
+GH_TUPLE= PySCeS:pysces:0.9.5:fortran
BINARY_ALIAS= gfortran6=flang # it keeps using gfortran6 regardless of the environment variables and arguments
-PYSCES_VERSION= 0.9.5
FORTRAN_FILES= linalg_nleq2.f nleq2.f wnorm.f zibconst.f zibmon.f zibsec.f
pre-build: # compile fortran files into a static library because distutils fails while doing this
@${MKDIR} ${WRKDIR}/.fbuild && \
cd ${WRKDIR}/.fbuild && \
- flang -c ${CFLAGS} -fPIC ${FORTRAN_FILES:C/^/${WRKDIR}\/pysces-${PYSCES_VERSION}\/pysces\/nleq2\//} && \
+ flang -c ${CFLAGS} -fPIC ${FORTRAN_FILES:C,^,${WRKSRC_fortran}/pysces/nleq2/,} && \
${AR} -qc libff.a ${FORTRAN_FILES:S/.f/.o/}
post-install:
diff --git a/math/py-pynleq2/distinfo b/math/py-pynleq2/distinfo
index 3d2edac876ef..0e9436ae5c04 100644
--- a/math/py-pynleq2/distinfo
+++ b/math/py-pynleq2/distinfo
@@ -1,5 +1,5 @@
-TIMESTAMP = 1522600966
+TIMESTAMP = 1523392896
SHA256 (pynleq2-0.0.2.tar.gz) = b9be75bb7def34cd7a82aed87b70f6c3c9f4602cbe9e8d4fcf43a4aae241112d
SIZE (pynleq2-0.0.2.tar.gz) = 6219
-SHA256 (0.9.5.tar.gz) = 14131578b36154593ee5e793b3886572746209dcc3d9ed5ef3787a3476876cf6
-SIZE (0.9.5.tar.gz) = 2119094
+SHA256 (PySCeS-pysces-0.9.5_GH0.tar.gz) = 14131578b36154593ee5e793b3886572746209dcc3d9ed5ef3787a3476876cf6
+SIZE (PySCeS-pysces-0.9.5_GH0.tar.gz) = 2119094