aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2005-06-06 05:14:39 +0800
committerThierry Thomas <thierry@FreeBSD.org>2005-06-06 05:14:39 +0800
commitab8e018a48d73df2842fa779999996bc9aba6d82 (patch)
treef269e29255a505bf21923d826bd6f328433b58e8 /math
parent98046577a307b14545e189d6afe34b68233cc00a (diff)
downloadfreebsd-ports-gnome-ab8e018a48d73df2842fa779999996bc9aba6d82.tar.gz
freebsd-ports-gnome-ab8e018a48d73df2842fa779999996bc9aba6d82.tar.zst
freebsd-ports-gnome-ab8e018a48d73df2842fa779999996bc9aba6d82.zip
Add support of FFLAGS.
PR: ports/81885 (follow-up) Submitted by: maintainer
Diffstat (limited to 'math')
-rw-r--r--math/scilab/Makefile2
-rw-r--r--math/scilab/files/patch-bb8
2 files changed, 6 insertions, 4 deletions
diff --git a/math/scilab/Makefile b/math/scilab/Makefile
index 83597d50085c..a04b4974759a 100644
--- a/math/scilab/Makefile
+++ b/math/scilab/Makefile
@@ -44,7 +44,7 @@ CONFIGURE_ARGS= --with-tk \
--without-java \
--without-ocaml
-CONFIGURE_ENV= PVM_ROOT=${PVM_ROOT} X11BASE=${X11BASE} F77=${F77}
+CONFIGURE_ENV= PVM_ROOT=${PVM_ROOT} X11BASE=${X11BASE} F77=${F77} FFLAGS="${FFLAGS}"
MAKE_ENV= PVM_INCLUDE=${LOCALBASE}/include
PLIST_SUB= PORTVERSION="${PORTVERSION}" DOCSDIR="share/doc/scilab-${PORTVERSION}"
diff --git a/math/scilab/files/patch-bb b/math/scilab/files/patch-bb
index 22531fea1804..afafd49e46bf 100644
--- a/math/scilab/files/patch-bb
+++ b/math/scilab/files/patch-bb
@@ -1,6 +1,6 @@
--- configure.orig Wed May 25 17:00:45 2005
-+++ configure Sat Jun 4 21:48:15 2005
-@@ -21331,12 +21331,12 @@
++++ configure Sun Jun 5 22:59:47 2005
+@@ -21331,13 +21331,13 @@
# FreeBSD systems (not supported by INRIA)
*-*-freebsd*)
GCC=yes
@@ -11,10 +11,12 @@
CC_PICFLAGS='-fPIC'
# script shell f77 have bugs, get ours
- FC=f77
+- FC_OPTIONS="${CFLAGS} -Dfreebsd"
+ FC=$F77
- FC_OPTIONS="${CFLAGS} -Dfreebsd"
++ FC_OPTIONS="${FFLAGS} -Dfreebsd"
FC_OPTIONS_O0='-Dfreebsd'
FC_LDFLAGS='-lm -Wl,--export-dynamic'
+ FC_PICFLAGS='-fPIC'
@@ -24208,7 +24208,8 @@
cat confdefs.h >>conftest.$ac_ext
cat >>conftest.$ac_ext <<_ACEOF