aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorpgollucci <pgollucci@FreeBSD.org>2012-03-09 02:45:38 +0800
committerpgollucci <pgollucci@FreeBSD.org>2012-03-09 02:45:38 +0800
commitbdc7b8de9b4a00d6f78b8a20e6e92ad630e44558 (patch)
tree0af98c25fc0d67ccc871639ecd10e8476cfd8de7 /math
parenta72ed0005b1dc840337c91df5cde89b1015c75f8 (diff)
downloadfreebsd-ports-gnome-bdc7b8de9b4a00d6f78b8a20e6e92ad630e44558.tar.gz
freebsd-ports-gnome-bdc7b8de9b4a00d6f78b8a20e6e92ad630e44558.tar.zst
freebsd-ports-gnome-bdc7b8de9b4a00d6f78b8a20e6e92ad630e44558.zip
- Remove ports that only work with < perl 5.12 (devel/p5-B-Size, devel/p5-Devel-Arena)
- Remove conditionals for PERL_LEVEL < 501200 - Remove regression-test targets b/c this will be centralized in Mk/bsd.perl.mk - Other minor cleanups RUN_DEPENDS = ${BUILD_DEPENDS} -> RUN_DEPENDS:= ${BUILD_DEPENDS} PR: ports/165605 Submitted by: pgollucci (myself) Approved by: portmgr (linimon) Exp Run by: linimon Tested by: make index
Diffstat (limited to 'math')
-rw-r--r--math/p5-Math-GSL/Makefile5
-rw-r--r--math/p5-Math-Prime-XS/Makefile8
-rw-r--r--math/p5-Math-RPN/Makefile8
-rw-r--r--math/p5-bignum/Makefile11
4 files changed, 3 insertions, 29 deletions
diff --git a/math/p5-Math-GSL/Makefile b/math/p5-Math-GSL/Makefile
index fdd176984ed4..5376900b0881 100644
--- a/math/p5-Math-GSL/Makefile
+++ b/math/p5-Math-GSL/Makefile
@@ -82,9 +82,4 @@ MAN3= Math::GSL.3 \
BROKEN= Does not compile on sparc64
.endif
-.if ${PERL_LEVEL} < 501001
-BUILD_DEPENDS+= p5-version>=0.77:${PORTSDIR}/devel/p5-version
-RUN_DEPENDS+= p5-version>=0.77:${PORTSDIR}/devel/p5-version
-.endif
-
.include <bsd.port.post.mk>
diff --git a/math/p5-Math-Prime-XS/Makefile b/math/p5-Math-Prime-XS/Makefile
index a43eadb993a6..acd4f5d647e9 100644
--- a/math/p5-Math-Prime-XS/Makefile
+++ b/math/p5-Math-Prime-XS/Makefile
@@ -27,10 +27,4 @@ PERL_CONFIGURE= yes
MAN3= Math::Prime::XS.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 501000
-BUILD_DEPENDS+= p5-ExtUtils-CBuilder>=0:${PORTSDIR}/devel/p5-ExtUtils-CBuilder
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/math/p5-Math-RPN/Makefile b/math/p5-Math-RPN/Makefile
index 8806d7232dfa..4a2daf1a4921 100644
--- a/math/p5-Math-RPN/Makefile
+++ b/math/p5-Math-RPN/Makefile
@@ -21,10 +21,4 @@ PERL_CONFIGURE= yes
MAN3= Math::RPN.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 501001
-BUILD_DEPENDS+= p5-ExtUtils-MakeMaker>=6.50:${PORTSDIR}/devel/p5-ExtUtils-MakeMaker
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/math/p5-bignum/Makefile b/math/p5-bignum/Makefile
index cdde16596711..8411b83082b3 100644
--- a/math/p5-bignum/Makefile
+++ b/math/p5-bignum/Makefile
@@ -21,13 +21,4 @@ MAN3= bigint.3 \
bignum.3 \
bigrat.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 501000
-BUILD_DEPENDS+= p5-Math-BigInt>=1.880:${PORTSDIR}/math/p5-Math-BigInt \
- p5-Math-BigRat>=0.21:${PORTSDIR}/math/p5-Math-BigRat
-RUN_DEPENDS+= p5-Math-BigInt>=1.880:${PORTSDIR}/math/p5-Math-BigInt \
- p5-Math-BigRat>=0.21:${PORTSDIR}/math/p5-Math-BigRat
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>