aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorstephen <stephen@FreeBSD.org>2019-12-02 08:17:31 +0800
committerstephen <stephen@FreeBSD.org>2019-12-02 08:17:31 +0800
commitbff41f843a10c499d6adaa8ab76280c07711ef49 (patch)
tree40f099c3c23acbec53ba68f195826c462fc28f0a /math
parent44cb58b0a51a4f0a92ade56f0bbdf7e783301d1a (diff)
downloadfreebsd-ports-gnome-bff41f843a10c499d6adaa8ab76280c07711ef49.tar.gz
freebsd-ports-gnome-bff41f843a10c499d6adaa8ab76280c07711ef49.tar.zst
freebsd-ports-gnome-bff41f843a10c499d6adaa8ab76280c07711ef49.zip
- New port math/octave-forge-matgeom.
The octave-forge package is the result of The GNU Octave Repositry project, which is intended to be a central location for custom scripts, functions and extensions for GNU Octave. contains the source for all the functions plus build and install scripts. This is matgeom. Geometry toolbox for 2D/3D geometric computing. WWW: http://octave.sourceforge.net/
Diffstat (limited to 'math')
-rw-r--r--math/Makefile1
-rw-r--r--math/octave-forge-matgeom/Makefile34
-rw-r--r--math/octave-forge-matgeom/distinfo3
-rw-r--r--math/octave-forge-matgeom/pkg-descr10
4 files changed, 48 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index 93d7dad8ae92..7d71394e0e0d 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -436,6 +436,7 @@
SUBDIR += octave-forge-lssa
SUBDIR += octave-forge-ltfat
SUBDIR += octave-forge-mapping
+ SUBDIR += octave-forge-matgeom
SUBDIR += octave-forge-miscellaneous
SUBDIR += octave-forge-missing-functions
SUBDIR += octave-forge-msh
diff --git a/math/octave-forge-matgeom/Makefile b/math/octave-forge-matgeom/Makefile
new file mode 100644
index 000000000000..4e2f3da56e18
--- /dev/null
+++ b/math/octave-forge-matgeom/Makefile
@@ -0,0 +1,34 @@
+# Created by: Stephen Montgomery-Smith <stephen@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= octave-forge-matgeom
+PORTVERSION= 1.2.1
+#DISTVERSIONSUFFIX= .octave
+CATEGORIES= math
+DISTFILES= ${DISTNAME}.octave${EXTRACT_SUFX}
+
+MAINTAINER= stephen@FreeBSD.org
+COMMENT= Octave-forge package ${OCTAVE_PKGNAME}
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKDIR}/${OCTSRC}/COPYING
+
+# OCTSRC is the name of the directory of the package.
+# It is usually ${OCTAVE_PKGNAME} or ${DISTNAME}.
+OCTSRC= ${DISTNAME}
+
+WRKSRC= ${WRKDIR}/${OCTSRC}/src
+
+.include "${.CURDIR}/../../Mk/bsd.octave.mk"
+
+post-extract:
+ @${MV} ${WRKDIR}/${OCTSRC}.octave ${WRKDIR}/${OCTSRC}
+ @${REINPLACE_CMD} -E 's/\.octave//' ${WRKDIR}/${OCTSRC}/DESCRIPTION
+
+do-build:
+ @${DO_NADA}
+
+post-build:
+ cd ${WRKDIR} && ${TAR} cfz ${DISTNAME}.tar.gz ${OCTSRC}
+
+.include <bsd.port.mk>
diff --git a/math/octave-forge-matgeom/distinfo b/math/octave-forge-matgeom/distinfo
new file mode 100644
index 000000000000..0f0df677d397
--- /dev/null
+++ b/math/octave-forge-matgeom/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1575238296
+SHA256 (octave-forge/matgeom-1.2.1.octave.tar.gz) = 2d9b716d39b04b8295cc7b689307f8bd531126ef3f6f930cb5df6912f1d17525
+SIZE (octave-forge/matgeom-1.2.1.octave.tar.gz) = 412608
diff --git a/math/octave-forge-matgeom/pkg-descr b/math/octave-forge-matgeom/pkg-descr
new file mode 100644
index 000000000000..6a0138a0cda8
--- /dev/null
+++ b/math/octave-forge-matgeom/pkg-descr
@@ -0,0 +1,10 @@
+The octave-forge package is the result of The GNU Octave Repositry project,
+which is intended to be a central location for custom scripts, functions and
+extensions for GNU Octave. contains the source for all the functions plus
+build and install scripts.
+
+This is matgeom.
+
+ Geometry toolbox for 2D/3D geometric computing.
+
+WWW: http://octave.sourceforge.net/