aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorbf <bf@FreeBSD.org>2011-08-20 02:46:45 +0800
committerbf <bf@FreeBSD.org>2011-08-20 02:46:45 +0800
commitc1eb47df7027da6d0e8bd342d6da038cef5bdd8b (patch)
tree81577bf6926fa1c58e5ba3d09356599eca10641d /math
parentcb406f1256ae46fe9ab2f73d040fad6aaccb1dd4 (diff)
downloadfreebsd-ports-gnome-c1eb47df7027da6d0e8bd342d6da038cef5bdd8b.tar.gz
freebsd-ports-gnome-c1eb47df7027da6d0e8bd342d6da038cef5bdd8b.tar.zst
freebsd-ports-gnome-c1eb47df7027da6d0e8bd342d6da038cef5bdd8b.zip
enable regression tests on tinderboxes, and add a
workaround to fix builds using clang and newer gcc
Diffstat (limited to 'math')
-rw-r--r--math/prng/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/math/prng/Makefile b/math/prng/Makefile
index ff56ff80fbaa..380e2ecb4235 100644
--- a/math/prng/Makefile
+++ b/math/prng/Makefile
@@ -11,6 +11,7 @@ MASTER_SITES= http://statistik.wu-wien.ac.at/software/prng/
MAINTAINER= bf@FreeBSD.org
COMMENT= Portable, high-performance ANSI-C pseudorandom number generators
+CFLAGS+= -fgnu89-inline
GNU_CONFIGURE= yes
CONFIGURE_ENV+= LDFLAGS="${LDFLAGS}"
INFO= prng
@@ -32,8 +33,8 @@ post-install:
.endfor
.endif
-test: build
+check regression-test test: build
@(cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${MAKE} \
- ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} check)
+ ${MAKE_FLAGS} ${MAKEFILE} ${_MAKE_JOBS} ${MAKE_ARGS} check)
.include <bsd.port.mk>