aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authormaho <maho@FreeBSD.org>2007-01-13 17:35:55 +0800
committermaho <maho@FreeBSD.org>2007-01-13 17:35:55 +0800
commitc4aa9a5ed39cf546ce4a0a2f0292c43650762be5 (patch)
tree4454ab860d9dbd5ab96561880dee9a13e949c226 /math
parent4d2d9ec73673157e680f0ed86824c4d125c51993 (diff)
downloadfreebsd-ports-gnome-c4aa9a5ed39cf546ce4a0a2f0292c43650762be5.tar.gz
freebsd-ports-gnome-c4aa9a5ed39cf546ce4a0a2f0292c43650762be5.tar.zst
freebsd-ports-gnome-c4aa9a5ed39cf546ce4a0a2f0292c43650762be5.zip
* Migrate to gfortran.
* Bump port revision. * Use gfortran compiled atlas/blas/lapack.
Diffstat (limited to 'math')
-rw-r--r--math/it++/Makefile19
1 files changed, 16 insertions, 3 deletions
diff --git a/math/it++/Makefile b/math/it++/Makefile
index 91dc260579c6..c0989d21d495 100644
--- a/math/it++/Makefile
+++ b/math/it++/Makefile
@@ -8,6 +8,7 @@
PORTNAME= it++
PORTVERSION= 3.8.0
+PORTREVISION= 1
CATEGORIES= math
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= itpp
@@ -16,14 +17,26 @@ DISTNAME= ${PORTNAME}${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Mathematical, signal processing and communication library
-LIB_DEPENDS= atlas.1:${PORTSDIR}/math/atlas
+.include <bsd.port.pre.mk>
+
+.if exists(${LOCALBASE}/lib/libatlas_r.so) && !defined(WITH_BLAS)
+WITH_ATLAS= yes
+.endif
+.if defined(WITH_ATLAS)
+LIB_DEPENDS+= atlas.2:${PORTSDIR}/math/atlas
+BLAS= -lf77blas -latlas
+.else
+LIB_DEPENDS+= blas.2:${PORTSDIR}/math/blas
+BLAS= -lblas
+.endif
HAS_CONFIGURE= yes
CONFIGURE_ARGS= opt
USE_GMAKE= yes
USE_GCC= 3.3+
-
-.include <bsd.port.pre.mk>
+BUILD_DEPENDS+= gfortran42:${PORTSDIR}/lang/gcc42
+FC= gfortran42
+F77= gfortran42
post-patch:
@${REINPLACE_CMD} -e "s|sparc|__sparc__|" \