aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorstephen <stephen@FreeBSD.org>2013-03-19 11:01:28 +0800
committerstephen <stephen@FreeBSD.org>2013-03-19 11:01:28 +0800
commitcb4e583551be8380ecc0e736bbd3f073c8a94e84 (patch)
tree0791c5cb17945172213c4bc50cd62e7486497a07 /math
parentdd76d24bc7cbebeed6725481d2cb301b27f55fe5 (diff)
downloadfreebsd-ports-gnome-cb4e583551be8380ecc0e736bbd3f073c8a94e84.tar.gz
freebsd-ports-gnome-cb4e583551be8380ecc0e736bbd3f073c8a94e84.tar.zst
freebsd-ports-gnome-cb4e583551be8380ecc0e736bbd3f073c8a94e84.zip
- Update to 5.8.
- Patch because threaded document building fails under FreeBSD.
Diffstat (limited to 'math')
-rw-r--r--math/sage/Makefile2
-rw-r--r--math/sage/distinfo4
-rw-r--r--math/sage/files/spkg-patch-sage_-_doc_common_builder.py46
-rw-r--r--math/sage/files/spkg-patch-sage_-_sage_misc_getusage.py2
4 files changed, 50 insertions, 4 deletions
diff --git a/math/sage/Makefile b/math/sage/Makefile
index b9ffc589d2d4..d82ece5dd60e 100644
--- a/math/sage/Makefile
+++ b/math/sage/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= sage
-PORTVERSION= 5.7
+PORTVERSION= 5.8
CATEGORIES= math
MASTER_SITES= http://boxen.math.washington.edu/home/sagemath/sage-mirror/src/ \
http://mirrors.xmission.com/sage/src/ \
diff --git a/math/sage/distinfo b/math/sage/distinfo
index ff7b2f75dda6..136596db9378 100644
--- a/math/sage/distinfo
+++ b/math/sage/distinfo
@@ -1,2 +1,2 @@
-SHA256 (sage-5.7.tar) = 325709fdde8836dea82d4b553a6ce0596403e5ace1e3a598988f081e389cc4d0
-SIZE (sage-5.7.tar) = 322447360
+SHA256 (sage-5.8.tar) = 4c34f4533a518e0ef8b34b2ed51443beae57e00d2f9ef31fa2811338610619ba
+SIZE (sage-5.8.tar) = 329318400
diff --git a/math/sage/files/spkg-patch-sage_-_doc_common_builder.py b/math/sage/files/spkg-patch-sage_-_doc_common_builder.py
new file mode 100644
index 000000000000..84659a7dc304
--- /dev/null
+++ b/math/sage/files/spkg-patch-sage_-_doc_common_builder.py
@@ -0,0 +1,46 @@
+--- sage-5.8.rc0/doc/common/builder.py-orig 2013-03-17 20:50:38.000000000 +0000
++++ sage-5.8/doc/common/builder.py 2013-03-17 20:56:42.000000000 +0000
+@@ -272,13 +272,16 @@
+
+ # build the other documents in parallel
+ from multiprocessing import Pool
+- pool = Pool(NUM_THREADS, maxtasksperchild=1)
++ # pool = Pool(NUM_THREADS, maxtasksperchild=1)
+ L = [(doc, name, kwds) + args for doc in others]
+- # map_async handles KeyboardInterrupt correctly. Plain map and
+- # apply_async does not, so don't use it.
+- pool.map_async(build_other_doc, L, 1).get(99999)
+- pool.close()
+- pool.join()
++ # Pool doesn't work properly in FreeBSD. Instead:
++ for iii in L:
++ build_other_doc(iii)
++ # # map_async handles KeyboardInterrupt correctly. Plain map and
++ # # apply_async does not, so don't use it.
++ # pool.map_async(build_other_doc, L, 1).get(99999)
++ # pool.close()
++ # pool.join()
+ logger.warning("Elapsed time: %.1f seconds."%(time.time()-start))
+ logger.warning("Done building the documentation!")
+
+@@ -464,12 +467,15 @@
+ continue
+ output_dir = self._output_dir(format, lang)
+ from multiprocessing import Pool
+- pool = Pool(NUM_THREADS, maxtasksperchild=1)
++ # pool = Pool(NUM_THREADS, maxtasksperchild=1)
+ L = [(doc, lang, format, kwds) + args for doc in self.get_all_documents(refdir)]
+- # (See comment in AllBuilder._wrapper about using map instead of apply.)
+- pool.map_async(build_ref_doc, L, 1).get(99999)
+- pool.close()
+- pool.join()
++ # Pool doesn't work properly in FreeBSD. Instead:
++ for iii in L:
++ build_ref_doc(iii)
++ # # (See comment in AllBuilder._wrapper about using map instead of apply.)
++ # pool.map_async(build_ref_doc, L, 1).get(99999)
++ # pool.close()
++ # pool.join()
+ # The html refman must be build at the end to ensure correct
+ # merging of indexes and inventories.
+ # Sphinx is run here in the current process (not in a
diff --git a/math/sage/files/spkg-patch-sage_-_sage_misc_getusage.py b/math/sage/files/spkg-patch-sage_-_sage_misc_getusage.py
index 4d5dd2f9a8bf..7c0be074b4d4 100644
--- a/math/sage/files/spkg-patch-sage_-_sage_misc_getusage.py
+++ b/math/sage/files/spkg-patch-sage_-_sage_misc_getusage.py
@@ -1,5 +1,5 @@
--- sage-5.7.beta4/sage/misc/getusage.py-old 2013-02-09 23:05:24.000000000 +0000
-+++ sage-5.7/sage/misc/getusage.py 2013-02-09 23:09:50.000000000 +0000
++++ sage-5.8/sage/misc/getusage.py 2013-02-09 23:09:50.000000000 +0000
@@ -20,6 +20,8 @@
"""
Return the 'top' or 'prstat' line that contains this running Sage