aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorerwin <erwin@FreeBSD.org>2005-02-25 19:35:59 +0800
committererwin <erwin@FreeBSD.org>2005-02-25 19:35:59 +0800
commitcb98e97a9f6bda255498514d357a9ca4baf4f4fe (patch)
treefcb080dd49241717c1c4a42c6404f4e349adbc2f /math
parentd67ed191c95b0528660dcc1228985b4b418945ed (diff)
downloadfreebsd-ports-gnome-cb98e97a9f6bda255498514d357a9ca4baf4f4fe.tar.gz
freebsd-ports-gnome-cb98e97a9f6bda255498514d357a9ca4baf4f4fe.tar.zst
freebsd-ports-gnome-cb98e97a9f6bda255498514d357a9ca4baf4f4fe.zip
Add p5-Math-VecStat 0.08, basic statistics on vectors.
PR: ports/78060 Submitted by: Martin Matuska <martin@matuska.org>
Diffstat (limited to 'math')
-rw-r--r--math/Makefile1
-rw-r--r--math/p5-Math-VecStat/Makefile23
-rw-r--r--math/p5-Math-VecStat/distinfo2
-rw-r--r--math/p5-Math-VecStat/pkg-descr1
-rw-r--r--math/p5-Math-VecStat/pkg-plist5
5 files changed, 32 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index 75f54ecf572b..d9664f6ad827 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -161,6 +161,7 @@
SUBDIR += p5-Math-SimpleVariable
SUBDIR += p5-Math-Spline
SUBDIR += p5-Math-TrulyRandom
+ SUBDIR += p5-Math-VecStat
SUBDIR += p5-MatrixReal
SUBDIR += p5-NetCDF
SUBDIR += p5-Number-Compare
diff --git a/math/p5-Math-VecStat/Makefile b/math/p5-Math-VecStat/Makefile
new file mode 100644
index 000000000000..2ceca8d3977e
--- /dev/null
+++ b/math/p5-Math-VecStat/Makefile
@@ -0,0 +1,23 @@
+# vim:ts=8
+# New ports collection makefile for: p5-Math-VecStat
+# Date created: 25 Februar 2005
+# Whom: Martin Matuska <martin@matuska.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Math-VecStat
+PORTVERSION= 0.08
+CATEGORIES= math perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Math
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= martin@matuska.org
+COMMENT= Basic statistics on vectors
+
+PERL_CONFIGURE= yes
+
+MAN3= Math::VecStat.3
+
+.include <bsd.port.mk>
diff --git a/math/p5-Math-VecStat/distinfo b/math/p5-Math-VecStat/distinfo
new file mode 100644
index 000000000000..6b20c11f7481
--- /dev/null
+++ b/math/p5-Math-VecStat/distinfo
@@ -0,0 +1,2 @@
+MD5 (Math-VecStat-0.08.tar.gz) = 3df23fb451f73bb49fd4ea344ba94020
+SIZE (Math-VecStat-0.08.tar.gz) = 4539
diff --git a/math/p5-Math-VecStat/pkg-descr b/math/p5-Math-VecStat/pkg-descr
new file mode 100644
index 000000000000..43ad3906194c
--- /dev/null
+++ b/math/p5-Math-VecStat/pkg-descr
@@ -0,0 +1 @@
+Some basic statistics on vectors (min,max,average,....).
diff --git a/math/p5-Math-VecStat/pkg-plist b/math/p5-Math-VecStat/pkg-plist
new file mode 100644
index 000000000000..a8c630f8b2c3
--- /dev/null
+++ b/math/p5-Math-VecStat/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/VecStat/.packlist
+%%SITE_PERL%%/Math/VecStat.pm
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/VecStat
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Math 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Math 2>/dev/null || true