aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorpkubaj <pkubaj@FreeBSD.org>2019-07-17 15:39:18 +0800
committerpkubaj <pkubaj@FreeBSD.org>2019-07-17 15:39:18 +0800
commitcc969ea00c55c07181e3665cb1e6eb5e76c7a05b (patch)
tree2dd859db5ab3acaadc18841c83360fb17666c2da /math
parent049c64bba25fce5c5c5fa7fd47a9072861b66e64 (diff)
downloadfreebsd-ports-gnome-cc969ea00c55c07181e3665cb1e6eb5e76c7a05b.tar.gz
freebsd-ports-gnome-cc969ea00c55c07181e3665cb1e6eb5e76c7a05b.tar.zst
freebsd-ports-gnome-cc969ea00c55c07181e3665cb1e6eb5e76c7a05b.zip
math/moab: fix build with GCC
Add USES=compiler:c++11-lang to fix: CMake Error at /usr/local/share/cmake/Modules/FindPackageHandleStandardArgs.cmake:137 (message): Could NOT find MPI (missing: MPI_CXX_FOUND) (found version "3.0") Approved by: mentors (implicit approval)
Diffstat (limited to 'math')
-rw-r--r--math/moab/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/math/moab/Makefile b/math/moab/Makefile
index 16e77031e44b..f85060c6a408 100644
--- a/math/moab/Makefile
+++ b/math/moab/Makefile
@@ -16,7 +16,7 @@ LIB_DEPENDS= libhdf5.so:science/hdf5 \
libnetcdf.so:science/netcdf \
libopenblas.so:math/openblas
-USES= cmake:noninja eigen:3 fortran
+USES= cmake:noninja compiler:c++11-lang eigen:3 fortran
USE_LDCONFIG= yes
CMAKE_ARGS= -DBLAS_LIBRARIES:STRING=${LOCALBASE}/lib/libopenblas.so -DLAPACK_LIBRARIES:STRING=${LOCALBASE}/lib/libopenblas.so