aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorjohans <johans@FreeBSD.org>2012-06-17 02:32:54 +0800
committerjohans <johans@FreeBSD.org>2012-06-17 02:32:54 +0800
commitdc89b2aff8e35796f0607fc867ad0c2b86ababd6 (patch)
tree475c386aefdbe2d0835e07d6afad0f2cf2bb9de9 /math
parentdef7ede5315222cd8e0c3a6cec112f91fb893f9d (diff)
downloadfreebsd-ports-gnome-dc89b2aff8e35796f0607fc867ad0c2b86ababd6.tar.gz
freebsd-ports-gnome-dc89b2aff8e35796f0607fc867ad0c2b86ababd6.tar.zst
freebsd-ports-gnome-dc89b2aff8e35796f0607fc867ad0c2b86ababd6.zip
- Update gap to 4.5.4
- Distribution now uses GNU configure scripts - Extra packages no longer ship separately, but are included - Remove patch files that are no longer needed
Diffstat (limited to 'math')
-rw-r--r--math/gap/Makefile98
-rw-r--r--math/gap/distinfo8
-rw-r--r--math/gap/files/patch-gap4r4_cnf_configure.out11
-rw-r--r--math/gap/files/patch-gap4r4_cnf_gac.in19
-rw-r--r--math/gap/files/patch-gap4r4_src_iostream.c32
-rw-r--r--math/gap/files/patch-gap4r4_src_sysfiles.c74
6 files changed, 20 insertions, 222 deletions
diff --git a/math/gap/Makefile b/math/gap/Makefile
index c6117623c929..c5ebde98a8dd 100644
--- a/math/gap/Makefile
+++ b/math/gap/Makefile
@@ -6,99 +6,37 @@
#
PORTNAME= gap
-PORTVERSION= 4.4.12.${GAP_PKGDATE}
+PORTVERSION= 4.5.4.${GAP_DISTDATE}
CATEGORIES= math
-MASTER_SITES= ftp://ftp.gap-system.org/pub/gap/gap4/tar.bz2/ \
+MASTER_SITES= ftp://ftp.gap-system.org/pub/gap/gap45/tar.bz2/ \
ftp://ftp.stack.nl/pub/users/johans/gap/ \
- ftp://ftp.gap-system.org/pub/gap/gap4/old/
-DISTFILES= packages-${GAP_PKGTIME}.tar.bz2 \
- gap4r4p12.tar.bz2 \
- xtom1r1p4.tar.bz2
-DIST_SUBDIR= gap
+ ftp://ftp.gap-system.org/pub/gap/gap45/old/
+DISTNAME= ${GAP_VERSION}p${PORTVERSION:R:E}_${GAP_DISTTIME}
MAINTAINER= johans@FreeBSD.org
COMMENT= GAP is a system for computational discrete algebra
-OPTIONS= COMPRESSED_TOMLIB "Compress tomlib files" On \
- ACE "Build binaries for ace" Off \
- COHOMOLO "Build binaries for cohomolo" Off \
- EDIM "Build binaries for edim" Off \
- EXAMPLE "Build binaries for example" Off \
- KBMAG "Build binaries for kbmag" Off \
- PARGAP "Build binaries for pargap" Off \
- XGAP "Build binaries for xgap" Off \
- GRAPE "Build binaries for grape" Off
+USE_BZIP2= yes
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+ALL_TARGET= default
-#todo anupq fplsa/guava/nq (malloc.h build error) qaos
-
-.include <bsd.port.pre.mk>
-
-GAP_VERSION= gap4r4
-GAP_PKGTIME= 2012_01_05-09_49_UTC
-GAP_PKGDATE= ${GAP_PKGTIME:C/-.*//:S/_//g}
-GAP_WRKSRC= ${WRKSRC}/${GAP_VERSION}
+GAP_VERSION= ${PORTNAME}${PORTVERSION:R:R:S/./r/} # gap4r5
+GAP_DISTTIME= 2012_06_04-23_02
+GAP_DISTDATE= ${GAP_DISTTIME:C/-.*//:S/_//g}
GAP_LIBDIR= ${PREFIX}/lib/${GAP_VERSION}
+WRKSRC= ${WRKDIR}/${GAP_VERSION}
PLIST_FILES= bin/gap
-do-extract:
- (${MKDIR} ${WRKSRC}; \
- cd ${WRKSRC}; \
- ${TAR} xyf ${DISTDIR}/${DIST_SUBDIR}/gap4r4p12.tar.bz2; \
- ${TAR} xyf ${DISTDIR}/${DIST_SUBDIR}/xtom1r1p4.tar.bz2 ; \
- cd ${GAP_WRKSRC}/pkg; \
- ${TAR} xyf ${DISTDIR}/${DIST_SUBDIR}/packages-${GAP_PKGTIME}.tar.bz2 )
-
-post-patch:
- @${REINPLACE_CMD} -e "/^CC=/d" ${GAP_WRKSRC}/Makefile.in
- @${REINPLACE_CMD} -e "s/@CC@/@BASECC@/" ${GAP_WRKSRC}/sysinfo.in
-
-do-configure:
- (cd ${GAP_WRKSRC}; ./configure)
-
-do-build:
- (cd ${GAP_WRKSRC}; make COPTS="${CFLAGS}")
-
-post-build:
-.if defined(WITH_COMPRESSED_TOMLIB)
- (cd ${GAP_WRKSRC}/pkg/tomlib/data; ${SH} -c 'for i in *; do ${GZIP_CMD} $${i};done' )
-.endif
-.if defined(WITH_ACE)
- (cd ${GAP_WRKSRC}/pkg/ace; ./configure ../..; make )
-.endif
-.if defined(WITH_COHOMOLO)
- (cd ${GAP_WRKSRC}/pkg/cohomolo; ./configure ../..; make )
-.endif
-.if defined(WITH_EDIM)
- (cd ${GAP_WRKSRC}/pkg/edim; ./configure ../..; make )
-.endif
-.if defined(WITH_EXAMPLE)
- (cd ${GAP_WRKSRC}/pkg/example; ./configure ../..; make )
-.endif
-#.if defined(WITH_GRAPE)
-# (cd ${GAP_WRKSRC}/pkg/grape; ./configure ../..; make linux-gcc )
-#.endif
-.if defined(WITH_KBMAG)
- (cd ${GAP_WRKSRC}/pkg/kbmag; ./configure ../..; make )
-.endif
-.if defined(WITH_OPENMATH)
- (cd ${GAP_WRKSRC}/pkg/openmath/OMCv1.3c/src/; ./configure; make; cd ../..; ./configure ../../; make )
-.endif
-.if defined(WITH_PARGAP)
- (cd ${GAP_WRKSRC}/pkg/pargap; ./configure ../..; make )
-.endif
-.if defined(WITH_XGAP)
- (cd ${GAP_WRKSRC}/pkg/xgap; ./configure ; make )
-.endif
-
do-install:
- (${SED} -e "s:GAP_DIR=.*:GAP_DIR=${GAP_LIBDIR}:g" -e "s:GAP_PRG=.*:GAP_PRG=gap:g" ${GAP_WRKSRC}/bin/gap.sh > ${PREFIX}/bin/gap; \
+ (${SED} -e "s:GAP_DIR=.*:GAP_DIR=${GAP_LIBDIR}:g" -e "s:GAP_PRG=.*:GAP_PRG=gap:g" ${WRKSRC}/bin/gap.sh > ${PREFIX}/bin/gap; \
${CHMOD} 755 ${PREFIX}/bin/gap; )
@${MKDIR} ${GAP_LIBDIR} ${GAP_LIBDIR}/bin
- @${INSTALL_PROGRAM} ${GAP_WRKSRC}/bin/*/gap ${GAP_LIBDIR}/bin
- @${INSTALL_SCRIPT} ${GAP_WRKSRC}/bin/*/gac ${GAP_LIBDIR}/bin
- @${INSTALL_DATA} ${GAP_WRKSRC}/sysinfo.gap ${GAP_LIBDIR}
+ @${INSTALL_PROGRAM} ${WRKSRC}/bin/*/gap ${GAP_LIBDIR}/bin
+ @${INSTALL_SCRIPT} ${WRKSRC}/bin/*/gac ${GAP_LIBDIR}/bin
+ @${INSTALL_DATA} ${WRKSRC}/sysinfo.gap ${GAP_LIBDIR}
.for subdir in doc etc grp lib pkg prim small trans tst
- @${CP} -R ${GAP_WRKSRC}/${subdir} ${GAP_LIBDIR}/
+ @${CP} -R ${WRKSRC}/${subdir} ${GAP_LIBDIR}/
.endfor
post-install:
@@ -108,4 +46,4 @@ post-install:
@${FIND} ${GAP_LIBDIR} -type d -depth | \
${SED} 's,${PREFIX}/,@dirrm ,' >> ${TMPPLIST}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/math/gap/distinfo b/math/gap/distinfo
index 5e3512ddfc98..b598c9c0d226 100644
--- a/math/gap/distinfo
+++ b/math/gap/distinfo
@@ -1,6 +1,2 @@
-SHA256 (gap/packages-2012_01_05-09_49_UTC.tar.bz2) = 5e99b8126239a2dd6c4ffa852c3d0748adcea7e03e9154ca9d483ce7f4c41426
-SIZE (gap/packages-2012_01_05-09_49_UTC.tar.bz2) = 114652475
-SHA256 (gap/gap4r4p12.tar.bz2) = 5ff56c5eb89b1fd0da9f216dbe1dce8fe44674858b6ad06cb277d36b7960be4d
-SIZE (gap/gap4r4p12.tar.bz2) = 47715810
-SHA256 (gap/xtom1r1p4.tar.bz2) = 5591dfa222d2fb6c4596c3e5c5347db339e08f209798e4a332a0d902035d4f66
-SIZE (gap/xtom1r1p4.tar.bz2) = 11480845
+SHA256 (gap4r5p4_2012_06_04-23_02.tar.bz2) = 71408c272a30c1d5dd0405ac8f9515a4647f90e6c0cd60d10e40467734377807
+SIZE (gap4r5p4_2012_06_04-23_02.tar.bz2) = 208866344
diff --git a/math/gap/files/patch-gap4r4_cnf_configure.out b/math/gap/files/patch-gap4r4_cnf_configure.out
deleted file mode 100644
index ccffbd5f1e9e..000000000000
--- a/math/gap/files/patch-gap4r4_cnf_configure.out
+++ /dev/null
@@ -1,11 +0,0 @@
---- gap4r4/cnf/configure.out.orig Fri Jul 22 16:39:30 2005
-+++ gap4r4/cnf/configure.out Fri Jul 22 16:39:27 2005
-@@ -3708,6 +3708,8 @@ if test "${gp_cv_cflags+set}" = set; the
- echo $ECHO_N "(cached) $ECHO_C" >&6
- else
- case "$host-$CC" in
-+ *-freebsd* )
-+ gp_cv_cflags="";;
- *-gcc | *-linux*-cc )
- gp_cv_cflags="-Wall -g -O2";;
- i686-*-egcs )
diff --git a/math/gap/files/patch-gap4r4_cnf_gac.in b/math/gap/files/patch-gap4r4_cnf_gac.in
deleted file mode 100644
index 412114f27096..000000000000
--- a/math/gap/files/patch-gap4r4_cnf_gac.in
+++ /dev/null
@@ -1,19 +0,0 @@
---- gap4r4/cnf/gac.in.orig Sun May 15 18:26:27 2005
-+++ gap4r4/cnf/gac.in Sun May 15 18:26:23 2005
-@@ -67,13 +67,13 @@ stat_identifier="USER";
-
- # These three should be filled in by the standard autoconf procedures
- c_compiler="@CC@"
--c_options="@CFLAGS@"
-+c_options="@CFLAGS@ ${CFLAGS}"
- c_linker="@CC@"
--c_link_options=""
-+c_link_options="${LDFLAGS}"
- c_libs="@LIBS@"
-
- # These three will need special care
--c_dyn_options="@CDYNOPTIONS@"
-+c_dyn_options="@CDYNOPTIONS@ ${CFLAGS}"
- c_dyn_linker="@CDYNLINKER@"
- c_dyn_linking="@CDYNLINKING@"
- c_dynlibs="@C_DYNLIBS@"
diff --git a/math/gap/files/patch-gap4r4_src_iostream.c b/math/gap/files/patch-gap4r4_src_iostream.c
deleted file mode 100644
index 5791a2b44425..000000000000
--- a/math/gap/files/patch-gap4r4_src_iostream.c
+++ /dev/null
@@ -1,32 +0,0 @@
---- gap4r4/src/iostream.c.orig Thu Feb 19 08:28:32 2004
-+++ gap4r4/src/iostream.c Tue Jun 14 18:41:51 2005
-@@ -340,9 +340,9 @@ static UInt GetMasterPty ( int * pty, Ch
- return 0;
-
- # else
-- static int devindex = 0;
-- static int letter = 0;
-- static int slave = 0;
-+ int devindex = 0;
-+ int letter = 0;
-+ int slave = 0;
-
- while ( SYS_PTYCHAR1[letter] )
- {
-@@ -355,12 +355,16 @@ static UInt GetMasterPty ( int * pty, Ch
- namepty[strlen(namepty)-1] = SYS_PTYCHAR2[devindex];
-
- if ( (*pty = open( namepty, O_RDWR )) >= 0 )
-+ {
- if ( (slave = open( nametty, O_RDWR, 0 )) >= 0 )
- {
- close(slave);
- (void) devindex++;
- return 0;
- }
-+ else
-+ close(*pty);
-+ }
- devindex++;
- }
- devindex = 0;
diff --git a/math/gap/files/patch-gap4r4_src_sysfiles.c b/math/gap/files/patch-gap4r4_src_sysfiles.c
deleted file mode 100644
index ad872f41e609..000000000000
--- a/math/gap/files/patch-gap4r4_src_sysfiles.c
+++ /dev/null
@@ -1,74 +0,0 @@
---- gap4r4/src/sysfiles.c.orig 2006-11-13 07:25:20.000000000 +0100
-+++ gap4r4/src/sysfiles.c 2008-06-12 08:23:32.000000000 +0200
-@@ -1522,7 +1522,7 @@
- ** to cooked mode before stopping GAP and back to raw mode when continueing.
- */
-
--#if !SYS_IS_DARWIN && (SYS_BSD || SYS_MACH || HAVE_SGTTY_H)
-+#if !SYS_IS_DARWIN && (SYS_BSD || SYS_MACH || HAVE_SGTTY_H) && !HAVE_TERMIOS_H
-
- #ifndef SYS_SGTTY_H /* terminal control functions */
- # include <sgtty.h>
-@@ -2072,7 +2072,7 @@
- **
- *f syStopraw( <fid> ) . . . . . . . . . . . . . . . . . . . . . . BSD/MACH
- */
--#if !SYS_IS_DARWIN && (SYS_BSD || SYS_MACH || HAVE_SGTTY_H)
-+#if !SYS_IS_DARWIN && (SYS_BSD || SYS_MACH || HAVE_SGTTY_H) && !HAVE_TERMIOS_H
-
- void syStopraw (
- Int fid )
-@@ -2759,7 +2759,7 @@
- **
- *f syEchoch( <ch>, <fid> ) . . . . . . . . . . . . . . . . . . . . BSD/MACH
- */
--#if SYS_BSD || SYS_MACH || HAVE_SGTTY_H
-+#if (SYS_BSD || SYS_MACH || HAVE_SGTTY_H) && !HAVE_TERMIOS_H
-
- void syEchoch (
- Int ch,
-@@ -2785,7 +2785,7 @@
- **
- *f syEchoch( <ch>, <fid> ) . . . . . . . . . . . . . . . . . . . . . . . USG
- */
--#if SYS_USG || HAVE_TERMIO_H
-+#if SYS_USG || HAVE_TERMIO_H || HAVE_TERMIOS_H
-
- void syEchoch (
- Int ch,
-@@ -2973,7 +2973,7 @@
- **
- *f syEchos( <ch>, <fid> ) . . . . . . . . . . . . . . . . . . . . BSD/MACH
- */
--#if SYS_BSD || SYS_MACH || HAVE_SGTTY_H
-+#if (SYS_BSD || SYS_MACH || HAVE_SGTTY_H) && !HAVE_TERMIOS_H
-
- void syEchos (
- Char * str,
-@@ -2995,7 +2995,7 @@
- **
- *f syEchos( <ch>, <fid> ) . . . . . . . . . . . . . . . . . . . . . . . USG
- */
--#if SYS_USG || HAVE_TERMIO_H
-+#if SYS_USG || HAVE_TERMIO_H || HAVE_TERMIOS_H
-
- void syEchos (
- Char * str,
-@@ -3148,7 +3148,7 @@
- **
- *f SyFputs( <line>, <fid> ) . . . . . . . BSD/MACH/USG/OS2 EMX/VMS/MAC MPW
- */
--#if SYS_BSD||SYS_MACH||SYS_USG||SYS_OS2_EMX||SYS_VMS||SYS_MAC_MPW||HAVE_SGTTY_H||HAVE_TERMIO_H
-+#if SYS_BSD||SYS_MACH||SYS_USG||SYS_OS2_EMX||SYS_VMS||SYS_MAC_MPW||HAVE_SGTTY_H||HAVE_TERMIO_H||HAVE_TERMIOS_H
-
- void SyFputs (
- Char * line,
-@@ -3475,7 +3475,7 @@
- ** that return odd things rather than waiting for a key
- **
- */
--#if SYS_BSD || SYS_MACH || HAVE_SGTTY_H ||SYS_USG || HAVE_TERMIO_H
-+#if SYS_BSD || SYS_MACH || HAVE_SGTTY_H ||SYS_USG || HAVE_TERMIO_H || HAVE_TERMIOS_H
-
- /* In the cygwin environment it is not predictable if text files get the
- * '\r' in their line ends filtered out *before* GAP sees them. This leads