aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authormaho <maho@FreeBSD.org>2007-07-14 11:35:36 +0800
committermaho <maho@FreeBSD.org>2007-07-14 11:35:36 +0800
commitdcb4954862df08fd169681f8e4d149c02a5ffd5d (patch)
tree022e4f0e82461bfadc462922e006f842d1a19a3b /math
parent780518c8f04d8d8dbbc818324391261210df3490 (diff)
downloadfreebsd-ports-gnome-dcb4954862df08fd169681f8e4d149c02a5ffd5d.tar.gz
freebsd-ports-gnome-dcb4954862df08fd169681f8e4d149c02a5ffd5d.tar.zst
freebsd-ports-gnome-dcb4954862df08fd169681f8e4d149c02a5ffd5d.zip
Now we use USE_FORTRAN=yes to use FORTRAN compiler.
Diffstat (limited to 'math')
-rw-r--r--math/freemat/Makefile5
-rw-r--r--math/scalapack/Makefile6
2 files changed, 2 insertions, 9 deletions
diff --git a/math/freemat/Makefile b/math/freemat/Makefile
index 6739fec2d86b..3a929aaa5b16 100644
--- a/math/freemat/Makefile
+++ b/math/freemat/Makefile
@@ -26,10 +26,7 @@ BUILD_DEPENDS= pkg-config:${PORTSDIR}/devel/pkg-config
IGNORE= no MPI support at the moment
.endif
-WANT_FORTRAN= yes #dummy but future use
-BUILD_DEPENDS+= gfortran42:${PORTSDIR}/lang/gcc42
-FC= gfortran42
-F77= gfortran42
+USE_FORTRAN= yes
FFLAGS+= -O2
USE_GL= yes
diff --git a/math/scalapack/Makefile b/math/scalapack/Makefile
index 14049e6b444e..af64db4fef9b 100644
--- a/math/scalapack/Makefile
+++ b/math/scalapack/Makefile
@@ -30,11 +30,7 @@ LIB_DEPENDS= blacs.1:${PORTSDIR}/math/blacs
CONFLICTS= elmer-mathlibs-1*
USE_LDCONFIG= yes
-
-WANT_FORTRAN= yes #dummy but future use
-BUILD_DEPENDS+= gfortran42:${PORTSDIR}/lang/gcc42
-FC= gfortran42
-F77= gfortran42
+USE_FORTRAN= yes
ARCH2FIX= PBLAS/SRC PBLAS/SRC/PBBLAS PBLAS/SRC/PTOOLS PBLAS/SRC/PTZBLAS \
REDIST/SRC SRC TOOLS TOOLS/LAPACK