aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorskreuzer <skreuzer@FreeBSD.org>2015-07-16 01:35:02 +0800
committerskreuzer <skreuzer@FreeBSD.org>2015-07-16 01:35:02 +0800
commitde16e7dffad06f5d274678ebe58dea895ae775ba (patch)
tree85a4e71c036cb47cfc1a5013868b86900f79dde3 /math
parent579944fa4c27ca8460aa4f57d0e1da92c1563ee1 (diff)
downloadfreebsd-ports-gnome-de16e7dffad06f5d274678ebe58dea895ae775ba.tar.gz
freebsd-ports-gnome-de16e7dffad06f5d274678ebe58dea895ae775ba.tar.zst
freebsd-ports-gnome-de16e7dffad06f5d274678ebe58dea895ae775ba.zip
colormath is a simple Python module that spares the user from directly dealing
with color math. Some features include: * Support for a wide range of color spaces. A good chunk of the CIE spaces, RGB, HSL/HSV, CMY/CMYK, and many more. * Conversions between the various color spaces. For example, XYZ to sRGB, Spectral to XYZ, CIE Lab to Adobe RGB. * Calculation of color difference. All CIE Delta E functions, plus CMC. * Chromatic adaptations (changing illuminants). * RGB to hex and vice-versa. * 16-bit RGB support. WWW: https://pypi.python.org/pypi/colormath
Diffstat (limited to 'math')
-rw-r--r--math/Makefile1
-rw-r--r--math/py-colormath/Makefile21
-rw-r--r--math/py-colormath/distinfo2
-rw-r--r--math/py-colormath/pkg-descr15
4 files changed, 39 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index f1028e1ee53a..bdbac0e199d1 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -554,6 +554,7 @@
SUBDIR += py-bitmath
SUBDIR += py-bitvector
SUBDIR += py-bottleneck
+ SUBDIR += py-colormath
SUBDIR += py-cryptominisat
SUBDIR += py-fastcluster
SUBDIR += py-ffc
diff --git a/math/py-colormath/Makefile b/math/py-colormath/Makefile
new file mode 100644
index 000000000000..a972d3712d36
--- /dev/null
+++ b/math/py-colormath/Makefile
@@ -0,0 +1,21 @@
+# Created by: Steven Kreuzer <skreuzer@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= colormath
+PORTVERSION= 2.1.1
+CATEGORIES= math python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= skreuzer@FreeBSD.org
+COMMENT= Module that spares the user from directly dealing with color math
+
+LICENSE= BSD2CLAUSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}numpy>=1.9.2:${PORTSDIR}/math/py-numpy \
+ ${PYTHON_PKGNAMEPREFIX}networkx>=1.9.1:${PORTSDIR}/math/py-networkx
+
+USES= python
+USE_PYTHON= autoplist distutils
+
+.include <bsd.port.mk>
diff --git a/math/py-colormath/distinfo b/math/py-colormath/distinfo
new file mode 100644
index 000000000000..3996d4ad0d4a
--- /dev/null
+++ b/math/py-colormath/distinfo
@@ -0,0 +1,2 @@
+SHA256 (colormath-2.1.1.tar.gz) = 003a2b2d9c1f43aa7d90addf1863fb2d822463c839b1166ae3092950792f9707
+SIZE (colormath-2.1.1.tar.gz) = 39048
diff --git a/math/py-colormath/pkg-descr b/math/py-colormath/pkg-descr
new file mode 100644
index 000000000000..08766dc5ed55
--- /dev/null
+++ b/math/py-colormath/pkg-descr
@@ -0,0 +1,15 @@
+colormath is a simple Python module that spares the user from directly dealing
+with color math.
+
+Some features include:
+
+ * Support for a wide range of color spaces. A good chunk of the CIE spaces,
+ RGB, HSL/HSV, CMY/CMYK, and many more.
+ * Conversions between the various color spaces. For example, XYZ to sRGB,
+ Spectral to XYZ, CIE Lab to Adobe RGB.
+ * Calculation of color difference. All CIE Delta E functions, plus CMC.
+ * Chromatic adaptations (changing illuminants).
+ * RGB to hex and vice-versa.
+ * 16-bit RGB support.
+
+WWW: https://pypi.python.org/pypi/colormath