aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2007-10-01 16:14:05 +0800
committeredwin <edwin@FreeBSD.org>2007-10-01 16:14:05 +0800
commitde1da6587c826146492e4284a01cd9f7bd36af4a (patch)
tree5a822310ef9f87b3c5d197329a358b189a717aa0 /math
parent274f26d19f3da6d6efef83f9e1f600b9d32350f2 (diff)
downloadfreebsd-ports-gnome-de1da6587c826146492e4284a01cd9f7bd36af4a.tar.gz
freebsd-ports-gnome-de1da6587c826146492e4284a01cd9f7bd36af4a.tar.zst
freebsd-ports-gnome-de1da6587c826146492e4284a01cd9f7bd36af4a.zip
New port: math/linux-SHA-1_collision_search_graz Distributed client
searching for weakness in SHA-1 hash SHA-1 Collision Search Graz is a distributed computing project -- people from through out the world download and run software to band together to make one of the largest supercomputers in the world. Every computer makes the project closer to our goals. The project is trying to see if like MD4 in 1996, MD5/RIPEMD in 2004, and the the direct predecessor SHA-0 in 2004 also, there is a weakness in the hash. WWW: http://boinc.iaik.tugraz.at/sha1_coll_search/ PR: ports/116691 Submitted by: Tuc <freebsd-ports@t-b-o-h.net>
Diffstat (limited to 'math')
-rw-r--r--math/Makefile1
-rw-r--r--math/linux-SHA-1_collision_search_graz/Makefile58
-rw-r--r--math/linux-SHA-1_collision_search_graz/distinfo3
-rw-r--r--math/linux-SHA-1_collision_search_graz/files/app_info.xml.in17
-rw-r--r--math/linux-SHA-1_collision_search_graz/pkg-descr10
-rw-r--r--math/linux-SHA-1_collision_search_graz/pkg-message22
-rw-r--r--math/linux-SHA-1_collision_search_graz/pkg-plist4
7 files changed, 115 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index baf3cbd43e1d..d392e3796c9d 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -137,6 +137,7 @@
SUBDIR += libtommath
SUBDIR += linalg
SUBDIR += linpack
+ SUBDIR += linux-SHA-1_collision_search_graz
SUBDIR += linux-relview
SUBDIR += lp_solve
SUBDIR += ltl
diff --git a/math/linux-SHA-1_collision_search_graz/Makefile b/math/linux-SHA-1_collision_search_graz/Makefile
new file mode 100644
index 000000000000..ed9e7cd18742
--- /dev/null
+++ b/math/linux-SHA-1_collision_search_graz/Makefile
@@ -0,0 +1,58 @@
+# Ports collection makefile for: SHA-1_collision_search_graz
+# Date created: 9/27/2007
+# Whom: Tuc <freebsd-ports@t-b-o-h.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= SHA-1_collision_search_graz
+PORTVERSION= 5.35
+CATEGORIES= math
+MASTER_SITES= http://boinc.iaik.tugraz.at/sha1_coll_search/download/
+PKGNAMEPREFIX= linux-
+DISTNAME= sha1_collisionsearch_graz_${PORTVERSION}_i686-pc-linux-gnu
+EXTRACT_SUFX=
+
+MAINTAINER= freebsd-ports@t-b-o-h.com
+COMMENT= Distributed client searching for weakness in SHA-1 hash
+
+RUN_DEPENDS= boinc_client:${PORTSDIR}/net/boinc-client
+
+# these must match settings in ${PORTSDIR}/net/boinc-client/Makefile
+BOINC_USER?= boinc
+BOINC_GROUP?= nobody
+BOINC_HOME?= /var/db/boinc
+
+SHA1_PROJECT= boinc.iaik.tugraz.at_sha1_coll_search
+SHA1_BINARY= ${DISTNAME}
+
+SUB_FILES= app_info.xml
+SUB_LIST= PORTVERSION="${PORTVERSION}" \
+ SHA1_BINARY="${SHA1_BINARY}"
+
+USE_LINUX= yes
+ONLY_FOR_ARCHS= i386
+REINPLACE_ARGS=
+
+PLIST_SUB= SHA1_BINARY="${SHA1_BINARY}" \
+ SHA1_SITE="${SHA1_PROJECT}" \
+ BOINC_HOME=${BOINC_HOME}
+
+do-extract:
+ ${MKDIR} ${WRKSRC}
+ ${CP} ${DISTDIR}/${DISTNAME}${EXTRACT_SUFX} ${WRKSRC}
+
+do-build:
+ ${BRANDELF} -t Linux ${WRKSRC}/${DISTNAME}${EXTRACT_SUFX}
+ ${CHMOD} 755 ${WRKSRC}/${DISTNAME}${EXTRACT_SUFX}
+
+do-install:
+ ${INSTALL} -d -o ${BOINC_USER} -g ${BOINC_GROUP} ${BOINC_HOME}/projects
+ ${INSTALL} -d -o ${BOINC_USER} -g ${BOINC_GROUP} ${BOINC_HOME}/projects/${SHA1_PROJECT}
+ ${INSTALL_PROGRAM} -o ${BOINC_USER} -g ${BOINC_GROUP} ${WRKSRC}/${SHA1_BINARY} ${BOINC_HOME}/projects/${SHA1_PROJECT}/
+ ${INSTALL_DATA} -o ${BOINC_USER} -g ${BOINC_GROUP} ${WRKDIR}/app_info.xml ${BOINC_HOME}/projects/${SHA1_PROJECT}/
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/math/linux-SHA-1_collision_search_graz/distinfo b/math/linux-SHA-1_collision_search_graz/distinfo
new file mode 100644
index 000000000000..86cc6b2ddaf2
--- /dev/null
+++ b/math/linux-SHA-1_collision_search_graz/distinfo
@@ -0,0 +1,3 @@
+MD5 (sha1_collisionsearch_graz_5.35_i686-pc-linux-gnu) = 2845039776feb95eda6894202c58f4b2
+SHA256 (sha1_collisionsearch_graz_5.35_i686-pc-linux-gnu) = 07c06f5149679bf943d77036a517b82281e3ca5225a668bc1e7ef3c6c81ffade
+SIZE (sha1_collisionsearch_graz_5.35_i686-pc-linux-gnu) = 1000032
diff --git a/math/linux-SHA-1_collision_search_graz/files/app_info.xml.in b/math/linux-SHA-1_collision_search_graz/files/app_info.xml.in
new file mode 100644
index 000000000000..e824e09e49f4
--- /dev/null
+++ b/math/linux-SHA-1_collision_search_graz/files/app_info.xml.in
@@ -0,0 +1,17 @@
+<app_info>
+<app>
+<name>sha1_collisionsearch_graz</name>
+</app>
+<file_info>
+<name>%%SHA1_BINARY%%</name>
+<executable/>
+</file_info>
+<app_version>
+<app_name>sha1_collisionsearch_graz</app_name>
+<version_num>%%PORTVERSION%%</version_num>
+<file_ref>
+<file_name>%%SHA1_BINARY%%</file_name>
+<main_program/>
+</file_ref>
+</app_version>
+</app_info>
diff --git a/math/linux-SHA-1_collision_search_graz/pkg-descr b/math/linux-SHA-1_collision_search_graz/pkg-descr
new file mode 100644
index 000000000000..2944da4219d6
--- /dev/null
+++ b/math/linux-SHA-1_collision_search_graz/pkg-descr
@@ -0,0 +1,10 @@
+SHA-1 Collision Search Graz is a distributed computing project -- people
+from through out the world download and run software to band together to
+make one of the largest supercomputers in the world. Every computer makes
+the project closer to our goals.
+
+The project is trying to see if like MD4 in 1996, MD5/RIPEMD in 2004,
+and the the direct predecessor SHA-0 in 2004 also, there is a weakness
+in the hash.
+
+WWW: http://boinc.iaik.tugraz.at/sha1_coll_search/
diff --git a/math/linux-SHA-1_collision_search_graz/pkg-message b/math/linux-SHA-1_collision_search_graz/pkg-message
new file mode 100644
index 000000000000..b6c9ac8c1da7
--- /dev/null
+++ b/math/linux-SHA-1_collision_search_graz/pkg-message
@@ -0,0 +1,22 @@
+*****************************************************************************
+ATTACHING PROJECT
+
+Just run boinc_gui, choose Attach, and follow instructions.
+Project URL is http://boinc.iaik.tugraz.at/sha1_coll_search/
+
+MANUAL INSTALLATION
+ *) If this is your first time in any BOINC project, create a new account at
+ http://boinc.iaik.tugraz.at/sha1_coll_search/create_account_form.php
+
+ *) Or get your account key at
+ http://boinc.iaik.tugraz.at/sha1_coll_search/get_passwd.php
+
+ *) Attach to the project:
+ cd /var/db/boinc
+ boinc_cmd --project_attach \
+ http://boinc.iaik.tugraz.at/sha1_coll_search/ <account key>
+
+ *) DO NOT FORGET to join the "FreeBSD" team after you create your account
+ and show your support for both the SHA-1 project and the FreeBSD
+ Operating System!
+*****************************************************************************
diff --git a/math/linux-SHA-1_collision_search_graz/pkg-plist b/math/linux-SHA-1_collision_search_graz/pkg-plist
new file mode 100644
index 000000000000..077b8dd2ff5a
--- /dev/null
+++ b/math/linux-SHA-1_collision_search_graz/pkg-plist
@@ -0,0 +1,4 @@
+@cwd %%BOINC_HOME%%/projects
+%%SHA1_SITE%%/app_info.xml
+%%SHA1_SITE%%/%%SHA1_BINARY%%
+@dirrmtry %%SHA1_SITE%%