aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2020-02-04 17:59:25 +0800
committerPiotr Kubaj <pkubaj@FreeBSD.org>2020-02-04 17:59:25 +0800
commitf3531eaf9748acb6c81c0ae5d5c8e8665e6df5fd (patch)
tree39bfaf7bdd96115cd555c978d5840219d899bb7c /math
parent70dea289f0d99aa5b4bd79b6d462089fa2ccfcfb (diff)
downloadfreebsd-ports-gnome-f3531eaf9748acb6c81c0ae5d5c8e8665e6df5fd.tar.gz
freebsd-ports-gnome-f3531eaf9748acb6c81c0ae5d5c8e8665e6df5fd.tar.zst
freebsd-ports-gnome-f3531eaf9748acb6c81c0ae5d5c8e8665e6df5fd.zip
math/poly2tri: fix build on GCC architectures
Use C11 compiler: ../poly2tri/common/shapes.cc: In function 'bool p2t::IsDelaunay(const std::vector<p2t::Triangle*, std::allocator<p2t::Triangle*> >&)': ../poly2tri/common/shapes.cc:394: error: a function-definition is not allowed here before ':' token ../poly2tri/common/shapes.cc:409: error: expected primary-expression at end of input
Diffstat (limited to 'math')
-rw-r--r--math/poly2tri/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/math/poly2tri/Makefile b/math/poly2tri/Makefile
index 209043aee69f..9b6c46a55711 100644
--- a/math/poly2tri/Makefile
+++ b/math/poly2tri/Makefile
@@ -12,7 +12,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= libglfw.so:graphics/glfw
-USES= gl localbase:ldflags waf
+USES= compiler:c11 gl localbase:ldflags waf
USE_GITHUB= yes
GH_ACCOUNT= jhasse
GH_TAGNAME= e6e63dd29ef0805b3e40fe1832c2f1fe2307943a