aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorkris <kris@FreeBSD.org>2003-06-05 06:43:38 +0800
committerkris <kris@FreeBSD.org>2003-06-05 06:43:38 +0800
commitf6ac0b4935ea004895ab5cc2800059b8d12c82ba (patch)
tree91894094142566c88cf43e76bf56bd120a3c8119 /math
parenta202830df7532e2bb404143c7bf5ee68b97df9bf (diff)
downloadfreebsd-ports-gnome-f6ac0b4935ea004895ab5cc2800059b8d12c82ba.tar.gz
freebsd-ports-gnome-f6ac0b4935ea004895ab5cc2800059b8d12c82ba.tar.zst
freebsd-ports-gnome-f6ac0b4935ea004895ab5cc2800059b8d12c82ba.zip
Move inclusion of bsd.port.pre.mk later in the file for conditional BROKEN
tag. Early inclusion caused problems for some ports, so to be safe I'm updating all of them. Pointy hat to: kris
Diffstat (limited to 'math')
-rw-r--r--math/R-letter/Makefile12
-rw-r--r--math/R-project/Makefile12
-rw-r--r--math/R/Makefile12
-rw-r--r--math/freefem/Makefile12
-rw-r--r--math/oleo/Makefile12
-rw-r--r--math/qscanplot/Makefile12
-rw-r--r--math/surf/Makefile12
7 files changed, 42 insertions, 42 deletions
diff --git a/math/R-letter/Makefile b/math/R-letter/Makefile
index c550cf5e469c..2828071f6544 100644
--- a/math/R-letter/Makefile
+++ b/math/R-letter/Makefile
@@ -28,12 +28,6 @@ COMMENT= A language for statistical computing and graphics
LIB_DEPENDS= tcl84:${PORTSDIR}/lang/tcl84 \
tk84:${PORTSDIR}/x11-toolkits/tk84
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 500113
-BROKEN= "Does not compile"
-.endif
-
GNU_CONFIGURE= yes
USE_XLIB= yes
USE_PERL5= yes
@@ -49,6 +43,12 @@ PAPERSIZE?= letter
MAN1= R.1
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile"
+.endif
+
test check: build
@(cd ${WRKSRC}; make check)
fullcheck: build
diff --git a/math/R-project/Makefile b/math/R-project/Makefile
index c550cf5e469c..2828071f6544 100644
--- a/math/R-project/Makefile
+++ b/math/R-project/Makefile
@@ -28,12 +28,6 @@ COMMENT= A language for statistical computing and graphics
LIB_DEPENDS= tcl84:${PORTSDIR}/lang/tcl84 \
tk84:${PORTSDIR}/x11-toolkits/tk84
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 500113
-BROKEN= "Does not compile"
-.endif
-
GNU_CONFIGURE= yes
USE_XLIB= yes
USE_PERL5= yes
@@ -49,6 +43,12 @@ PAPERSIZE?= letter
MAN1= R.1
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile"
+.endif
+
test check: build
@(cd ${WRKSRC}; make check)
fullcheck: build
diff --git a/math/R/Makefile b/math/R/Makefile
index c550cf5e469c..2828071f6544 100644
--- a/math/R/Makefile
+++ b/math/R/Makefile
@@ -28,12 +28,6 @@ COMMENT= A language for statistical computing and graphics
LIB_DEPENDS= tcl84:${PORTSDIR}/lang/tcl84 \
tk84:${PORTSDIR}/x11-toolkits/tk84
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 500113
-BROKEN= "Does not compile"
-.endif
-
GNU_CONFIGURE= yes
USE_XLIB= yes
USE_PERL5= yes
@@ -49,6 +43,12 @@ PAPERSIZE?= letter
MAN1= R.1
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile"
+.endif
+
test check: build
@(cd ${WRKSRC}; make check)
fullcheck: build
diff --git a/math/freefem/Makefile b/math/freefem/Makefile
index b5a3cabca675..9e04a64e3661 100644
--- a/math/freefem/Makefile
+++ b/math/freefem/Makefile
@@ -14,12 +14,6 @@ MASTER_SITE_SUBDIR= kfem
MAINTAINER= ports@FreeBSD.org
COMMENT= A language for the Finite Element Method
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 500113
-BROKEN= "Does not compile (bad C++ code)"
-.endif
-
USE_REINPLACE= yes
USE_X_PREFIX= yes
GNU_CONFIGURE= yes
@@ -29,6 +23,12 @@ INSTALLS_SHLIB= yes
MAN1= freefem.1
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile (bad C++ code)"
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|-O3 |\$$CXXFLAGS |g' ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|debian doc freefem|debian freefem|g ; \
diff --git a/math/oleo/Makefile b/math/oleo/Makefile
index 8496c57df252..bc23a643aba3 100644
--- a/math/oleo/Makefile
+++ b/math/oleo/Makefile
@@ -19,12 +19,6 @@ BROKEN= "Does not compile"
LIB_DEPENDS= intl.4:${PORTSDIR}/devel/gettext
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 500113
-BROKEN= "Does not compile"
-.endif
-
USE_REINPLACE= yes
USE_AUTOCONF_VER=213
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
@@ -42,6 +36,12 @@ USE_XLIB= yes
CONFIGURE_ARGS+= --without-motif
.endif
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile"
+.endif
+
pre-everything::
.if !defined(WITH_MOTIF)
@${ECHO_MSG}
diff --git a/math/qscanplot/Makefile b/math/qscanplot/Makefile
index 32467c7f6a3c..b4c8095f63e0 100644
--- a/math/qscanplot/Makefile
+++ b/math/qscanplot/Makefile
@@ -15,12 +15,6 @@ COMMENT= A program to extract data from scanned plots, graphs and figures
BUILD_DEPENDS= tmake:${PORTSDIR}/devel/tmake
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 500113
-BROKEN= "Does not compile (bad C++ code)"
-.endif
-
USE_X_PREFIX= yes
USE_QT_VER= 2
USE_GMAKE= yes
@@ -30,6 +24,12 @@ CONFIGURE_ENV= LDFLAGS="-lm ${PTHREAD_LIBS}" \
LIBQT=-lqt2
MAKE_ENV= QTDIR=${X11BASE}
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile (bad C++ code)"
+.endif
+
post-patch:
@${PERL} -pi -e 's|%%PREFIX%%|${PREFIX}|g' \
${WRKSRC}/qscanplot/templates/sample.qscanplotrc
diff --git a/math/surf/Makefile b/math/surf/Makefile
index 94e623af9383..ced07f21f031 100644
--- a/math/surf/Makefile
+++ b/math/surf/Makefile
@@ -19,12 +19,6 @@ LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
tiff.4:${PORTSDIR}/graphics/tiff \
gmp.6:${PORTSDIR}/math/libgmp4
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 500113
-BROKEN= "Does not compile (bad C++ code)"
-.endif
-
USE_GNOME= gtk12
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
@@ -32,4 +26,10 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
MAN1= surf.1
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile (bad C++ code)"
+.endif
+
.include <bsd.port.post.mk>