aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorNicola Vitale <nivit@FreeBSD.org>2015-02-06 06:40:37 +0800
committerNicola Vitale <nivit@FreeBSD.org>2015-02-06 06:40:37 +0800
commitf6c3cbf6fad7282787e01c7f3452c53f42b1751c (patch)
tree6057bfc11fcd413c9eab13a50b4112df9778bf88 /math
parent237dabc340a6af308e42a5d021387b73841d2100 (diff)
downloadfreebsd-ports-gnome-f6c3cbf6fad7282787e01c7f3452c53f42b1751c.tar.gz
freebsd-ports-gnome-f6c3cbf6fad7282787e01c7f3452c53f42b1751c.tar.zst
freebsd-ports-gnome-f6c3cbf6fad7282787e01c7f3452c53f42b1751c.zip
- Fix build on FreeBSD-9.3-RELEASE [1] with a couple of
patches provided upstream - Remove textproc/libxml2 from dependencies, and so bump PORTREVISION Reported by: pkg-fallout [1]
Diffstat (limited to 'math')
-rw-r--r--math/wxMaxima/Makefile3
-rw-r--r--math/wxMaxima/files/patch-src_MathCtrl.cpp20
-rw-r--r--math/wxMaxima/files/patch-src_MathCtrl.h11
3 files changed, 32 insertions, 2 deletions
diff --git a/math/wxMaxima/Makefile b/math/wxMaxima/Makefile
index 1542ff69675b..8827ec9074e3 100644
--- a/math/wxMaxima/Makefile
+++ b/math/wxMaxima/Makefile
@@ -3,7 +3,7 @@
PORTNAME= wxMaxima
PORTVERSION= 14.12.1
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= math
MASTER_SITES= SF
MASTER_SITE_SUBDIR= ${PORTNAME:tl}/${PORTNAME}/${PORTVERSION}
@@ -23,7 +23,6 @@ GNU_CONFIGURE= yes
PLIST_SUB= DESKTOPDIR=${DESKTOPDIR:S,${PREFIX}/,,}
USES= desktop-file-utils gettext
-USE_GNOME= libxml2
USE_WX= 2.8
WANT_UNICODE= yes
diff --git a/math/wxMaxima/files/patch-src_MathCtrl.cpp b/math/wxMaxima/files/patch-src_MathCtrl.cpp
new file mode 100644
index 000000000000..a7c82e2ab6e5
--- /dev/null
+++ b/math/wxMaxima/files/patch-src_MathCtrl.cpp
@@ -0,0 +1,20 @@
+--- src/MathCtrl.cpp.orig 2015-02-05 22:22:12 UTC
++++ src/MathCtrl.cpp
+@@ -1563,7 +1563,7 @@ void MathCtrl::OnCharInActive(wxKeyEvent
+ * We have a wxKeyEvent with no active editor, shift is down and
+ * keycode (ccode) is WXK_UP/WXK_DOWN
+ */
+-void MathCtrl::SelectWithChar(wxChar ccode) {
++void MathCtrl::SelectWithChar(int ccode) {
+ // start making a selection
+ // m_hCaretPositionStart is the first group selected
+ // m_hCaretPositionEnd is tle last group selected
+@@ -1646,7 +1646,7 @@ void MathCtrl::SelectEditable(EditorCell
+ }
+
+ void MathCtrl::OnCharNoActive(wxKeyEvent& event) {
+- wxChar ccode = event.GetKeyCode();
++ int ccode = event.GetKeyCode();
+ wxString txt; // Usually we open an Editor Cell with initial content txt
+
+ // If Shift is down we are selecting with WXK_UP and WXK_DOWN
diff --git a/math/wxMaxima/files/patch-src_MathCtrl.h b/math/wxMaxima/files/patch-src_MathCtrl.h
new file mode 100644
index 000000000000..8989437353af
--- /dev/null
+++ b/math/wxMaxima/files/patch-src_MathCtrl.h
@@ -0,0 +1,11 @@
+--- src/MathCtrl.h.orig 2015-02-05 22:22:16 UTC
++++ src/MathCtrl.h
+@@ -211,7 +211,7 @@ protected:
+ void OnCharNoActive(wxKeyEvent& event);
+ void OnChar(wxKeyEvent& event);
+ void SelectEditable(EditorCell *editor, bool up);
+- void SelectWithChar(wxChar ccode);
++ void SelectWithChar(int ccode);
+ void ClickNDrag(wxPoint down, wxPoint up);
+ void AdjustSize();
+ void OnEraseBackground(wxEraseEvent& event) { }