aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2021-01-14 07:03:31 +0800
committerMark Linimon <linimon@FreeBSD.org>2021-01-14 07:03:31 +0800
commitf86c964117b6a3ebf2cbf7bb69821dfb8a74f1c2 (patch)
treedee6818341bc298df429631dc617ddfaf949f1e5 /math
parent671839de5f6867f1f9e48aa527390d7495cbb750 (diff)
downloadfreebsd-ports-gnome-f86c964117b6a3ebf2cbf7bb69821dfb8a74f1c2.tar.gz
freebsd-ports-gnome-f86c964117b6a3ebf2cbf7bb69821dfb8a74f1c2.tar.zst
freebsd-ports-gnome-f86c964117b6a3ebf2cbf7bb69821dfb8a74f1c2.zip
Update GCC_DEFAULT from 9 to 10.
A few (mostly Fortran-based) ports need to be patched because GCC 10 is stricter. A handful of ports need to be restricted to GCC 9 because they fail with 10. 5 ports still fail with GCC 10. However, seeing as this work has been ongoing since 2020-05-24, it is simply time to make the commit and notify the affected maintainers. While here, pet portlint (Makevar order). PR: 246700 Submitted by: gerald Approved by: antoine (after many, many, -exp runs)
Diffstat (limited to 'math')
-rw-r--r--math/hs-penrose/Makefile6
-rw-r--r--math/mumps/Makefile5
-rw-r--r--math/octave-forge-optiminterp/Makefile10
-rw-r--r--math/scilab/Makefile7
4 files changed, 27 insertions, 1 deletions
diff --git a/math/hs-penrose/Makefile b/math/hs-penrose/Makefile
index 923541b3ff10..56d3e640e605 100644
--- a/math/hs-penrose/Makefile
+++ b/math/hs-penrose/Makefile
@@ -134,4 +134,10 @@ USE_CABAL= MonadRandom-0.5.1.2 \
x509-1.7.5_1 \
zlib-0.6.2.1_1
+.include <bsd.port.pre.mk>
+
+.if ${GCC_DEFAULT} >= 10
+BROKEN= fails to build with GCC 10: cabal: Missing dependency on a foreign library: Missing (or bad) C library: gfortran
+.endif
+
.include <bsd.port.mk>
diff --git a/math/mumps/Makefile b/math/mumps/Makefile
index fd4a1eea0a91..3ef794a77067 100644
--- a/math/mumps/Makefile
+++ b/math/mumps/Makefile
@@ -44,6 +44,11 @@ MAKE_JOBS_UNSAFE=yes
.include <bsd.port.pre.mk>
.include "${.CURDIR}/../../french/aster/bsd.aster.mk"
+.if ${GCC_DEFAULT} >= 10
+# workaround for Type mismatch in argument 's' at (1); passed INTEGER(4) to LOGICAL(4)
+FCFLAGS+= -fallow-argument-mismatch
+.endif
+
.ifdef WITH_MPI
PKGNAMESUFFIX+= -mpich
.endif
diff --git a/math/octave-forge-optiminterp/Makefile b/math/octave-forge-optiminterp/Makefile
index c8d7e23abdac..b99e212edbc2 100644
--- a/math/octave-forge-optiminterp/Makefile
+++ b/math/octave-forge-optiminterp/Makefile
@@ -24,8 +24,16 @@ GNU_CONFIGURE= yes
MAKE_ENV+= MKOCTFILE_FORTRAN_90=yes MKOCTFILE=mkoctfile
+.include <bsd.port.pre.mk>
+
+.if ${GCC_DEFAULT} >= 10
+# workaround for Rank mismatch between actual argument at (1) and actual argument at (2) (scalar and rank-2)
+# in theory, this should set FCFLAGS, but the port does not conform
+FFLAGS+= -fallow-argument-mismatch
+.endif
+
post-build:
${RM} ${WRKSRC}/Makefile ${WRKSRC}/configure
cd ${WRKDIR} && ${TAR} cfz ${DISTNAME}.tar.gz ${OCTSRC}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/math/scilab/Makefile b/math/scilab/Makefile
index 74bcac97861c..4f3b79aee85d 100644
--- a/math/scilab/Makefile
+++ b/math/scilab/Makefile
@@ -129,6 +129,13 @@ CONFIGURE_ARGS+= --without-openmp
CONFIGURE_ARGS+= --enable-debug
.endif
+.include <bsd.port.pre.mk>
+
+.if ${GCC_DEFAULT} >= 10
+# workaround for Rank mismatch between actual argument at (1) and actual argument at (2) (rank-1 and scalar)
+FFLAGS+= -fallow-argument-mismatch
+.endif
+
post-patch:
@${REINPLACE_CMD} 's,/usr/local,${LOCALBASE},' ${WRKSRC}/etc/librarypath.xml
@${REINPLACE_CMD} -e 's, gfortran, ${FC},' ${WRKSRC}/modules/dynamic_link/src/scripts/configure