aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authornivit <nivit@FreeBSD.org>2006-12-24 17:31:31 +0800
committernivit <nivit@FreeBSD.org>2006-12-24 17:31:31 +0800
commitf968aa4531485ee541cac6edfaf22efa7a4b8a69 (patch)
tree6c012bb7ccbf6bb144e60716c48e9eda949eacf7 /math
parent93d710424e73736a337737eae8c8f9053723f9fb (diff)
downloadfreebsd-ports-gnome-f968aa4531485ee541cac6edfaf22efa7a4b8a69.tar.gz
freebsd-ports-gnome-f968aa4531485ee541cac6edfaf22efa7a4b8a69.tar.zst
freebsd-ports-gnome-f968aa4531485ee541cac6edfaf22efa7a4b8a69.zip
Map data for the py-basemap port.
WWW: http://matplotlib.sourceforge.net/matplotlib.toolkits.basemap.basemap.html PR: ports/104315 Submitted by: mainland at apeiron.net Approved by: alexbl (mentor)
Diffstat (limited to 'math')
-rw-r--r--math/Makefile1
-rw-r--r--math/py-basemap-data/Makefile44
-rw-r--r--math/py-basemap-data/distinfo3
-rw-r--r--math/py-basemap-data/pkg-descr3
4 files changed, 51 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index a53db7d78055..bfbc6f8f177b 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -280,6 +280,7 @@
SUBDIR += proofgeneral
SUBDIR += pspp
SUBDIR += py-basemap
+ SUBDIR += py-basemap-data
SUBDIR += py-fpconst
SUBDIR += py-gato
SUBDIR += py-gnuplot
diff --git a/math/py-basemap-data/Makefile b/math/py-basemap-data/Makefile
new file mode 100644
index 000000000000..15e9bb9dcd2b
--- /dev/null
+++ b/math/py-basemap-data/Makefile
@@ -0,0 +1,44 @@
+# ex:ts=8
+# Ports collection makefile for: py-basemap-data
+# Date created: April 21, 2006
+# Whom: mainland@apeiron.net
+#
+# $FreeBSD$
+#
+
+PORTNAME= basemap-data
+PORTVERSION= 0.9
+CATEGORIES= math python
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= matplotlib
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= mainland@apeiron.net
+COMMENT= Map data for py-basemap
+
+USE_PYTHON= 2.2+
+USE_PYDISTUTILS= yes
+
+DATADIR= ${PREFIX}/share/py-${PORTNAME}
+
+MAKE_ENV= BASEMAP_DATA_PATH=${DATADIR}
+
+PLISTDIR= ${DATADIR}/*_[hi].txt
+
+
+.include <bsd.port.pre.mk>
+
+.if ${PYTHON_REL} >= 250
+PLISTDIR+= ${PYTHON_SITELIBDIR}/basemap_data-0.9-py2.5.egg-info
+.endif
+
+post-install:
+.for dir in ${PLISTDIR}
+ @${FIND} ${dir} ! -type d | \
+ ${SED} 's,^${PREFIX}/,,' >> ${TMPPLIST}
+ @${FIND} ${dir} -type d | ${SORT} -r | \
+ ${SED} 's,^${PREFIX}/,@dirrm ,' >> ${TMPPLIST}
+.endfor
+ @${ECHO} "@dirrm ${DATADIR:S,${PREFIX}/,,}" >> ${TMPPLIST}
+
+.include <bsd.port.post.mk>
diff --git a/math/py-basemap-data/distinfo b/math/py-basemap-data/distinfo
new file mode 100644
index 000000000000..ec7bc579691c
--- /dev/null
+++ b/math/py-basemap-data/distinfo
@@ -0,0 +1,3 @@
+MD5 (basemap-data-0.9.tar.gz) = 5c4baf8f3de54193d64ab31c363a0e89
+SHA256 (basemap-data-0.9.tar.gz) = 6f64baf508ac48ff6776e394e17dbca3ed826c9cad30ad6cfd6bfa26ae582d77
+SIZE (basemap-data-0.9.tar.gz) = 24995626
diff --git a/math/py-basemap-data/pkg-descr b/math/py-basemap-data/pkg-descr
new file mode 100644
index 000000000000..6a288a9cc321
--- /dev/null
+++ b/math/py-basemap-data/pkg-descr
@@ -0,0 +1,3 @@
+Map data for the py-basemap port.
+
+WWW: http://matplotlib.sourceforge.net/matplotlib.toolkits.basemap.basemap.html