aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authormaho <maho@FreeBSD.org>2014-01-23 06:18:37 +0800
committermaho <maho@FreeBSD.org>2014-01-23 06:18:37 +0800
commitfb58f5cc1ffe8491087f765c1df83e1cf4ef1f33 (patch)
tree5cf60bba340cfb126677a623f8e95dc772be3d41 /math
parent65b7a86a455479ddbfa30a65675c761a3dd93f37 (diff)
downloadfreebsd-ports-gnome-fb58f5cc1ffe8491087f765c1df83e1cf4ef1f33.tar.gz
freebsd-ports-gnome-fb58f5cc1ffe8491087f765c1df83e1cf4ef1f33.tar.zst
freebsd-ports-gnome-fb58f5cc1ffe8491087f765c1df83e1cf4ef1f33.zip
Update to 3.8.0
PR: 185991 Submitted by: Max Sterling <maxclsb@gmail.com>
Diffstat (limited to 'math')
-rw-r--r--math/octave/Makefile65
-rw-r--r--math/octave/distinfo4
-rw-r--r--math/octave/files/patch-configure27
-rw-r--r--math/octave/files/patch-gsed88
-rw-r--r--math/octave/files/patch-libcruft+mkf77def.in11
-rw-r--r--math/octave/files/patch-libinterp+dldfcn+__glpk__.cc10
-rw-r--r--math/octave/files/patch-liboctave-eigs-base.cc11
-rw-r--r--math/octave/files/patch-liboctave-numeric-eigs-base.cc11
-rw-r--r--math/octave/files/patch-octave-doc377
-rw-r--r--math/octave/files/patch-scripts+pkg+pkg.m11
-rw-r--r--math/octave/files/patch-scripts+pkg+private+configure__make.m11
-rw-r--r--math/octave/files/patch-src+DLD-FUNCTIONS+__glpk__.cc10
-rw-r--r--math/octave/pkg-plist3
13 files changed, 176 insertions, 463 deletions
diff --git a/math/octave/Makefile b/math/octave/Makefile
index 76006f4aa796..dfdcd1e4200f 100644
--- a/math/octave/Makefile
+++ b/math/octave/Makefile
@@ -2,15 +2,16 @@
# $FreeBSD$
PORTNAME= octave
-PORTVERSION= 3.6.4
-PORTREVISION= 7
+PORTVERSION= 3.8.0
CATEGORIES= math
-MASTER_SITES= ftp://ftp.gnu.org/gnu/octave/ \
- ftp://ftp.u-aizu.ac.jp/pub/SciEng/numanal/Octave/bleeding-edge/
+MASTER_SITES= ${MASTER_SITE_GNU}
+MASTER_SITE_SUBDIR= octave
MAINTAINER= maho@FreeBSD.org
COMMENT= High-level interactive language for numerical computations
+LICENSE= GPLv3
+
BUILD_DEPENDS+= gnuplot:${PORTSDIR}/math/gnuplot \
${LOCALBASE}/bin/gperf:${PORTSDIR}/devel/gperf \
gsed:${PORTSDIR}/textproc/gsed \
@@ -18,7 +19,7 @@ BUILD_DEPENDS+= gnuplot:${PORTSDIR}/math/gnuplot \
RUN_DEPENDS= gnuplot:${PORTSDIR}/math/gnuplot \
gsed:${PORTSDIR}/textproc/gsed \
${LOCALBASE}/bin/makeinfo:${PORTSDIR}/print/texinfo
-LIB_DEPENDS= GraphicsMagick:${PORTSDIR}/graphics/GraphicsMagick \
+LIB_DEPENDS= GraphicsMagick.14:${PORTSDIR}/graphics/GraphicsMagick13 \
arpack:${PORTSDIR}/math/arpack \
curl:${PORTSDIR}/ftp/curl \
fftw3:${PORTSDIR}/math/fftw3 \
@@ -30,7 +31,8 @@ LIB_DEPENDS= GraphicsMagick:${PORTSDIR}/graphics/GraphicsMagick \
qhull.5:${PORTSDIR}/math/qhull5 \
qrupdate:${PORTSDIR}/math/qrupdate \
umfpack.1:${PORTSDIR}/math/suitesparse \
- glpk:${PORTSDIR}/math/glpk
+ glpk:${PORTSDIR}/math/glpk \
+ gl2ps:${PORTSDIR}/print/gl2ps
USES= charsetfix fortran gmake perl5 pkgconfig
USE_BZIP2= yes
@@ -38,11 +40,14 @@ USE_PERL5= build
USE_TEX= dvipsk:build
GNU_CONFIGURE= yes
#USE_AUTOTOOLS= autoconf
+USE_JAVA= yes
+JAVA_VERSION= 1.7+
+CONFIGURE_ENV+= JAVA_HOME=${JAVA_HOME}
+USE_QT4= gui network
-INFO= octave liboctave OctaveFAQ
+INFO= octave liboctave
MAN1= octave.1 mkoctfile.1 octave-config.1
-NO_STAGE= yes
.include <bsd.port.pre.mk>
.if exists(${LOCALBASE}/lib/libopenblas.so)
@@ -90,7 +95,8 @@ LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
CONFIGURE_ARGS= --host=${GNU_HOST} \
--with-blas="-L${LOCALBASE}/lib ${BLAS}" \
--with-lapack="${LAPACK}" \
- --enable-shared
+ --enable-shared \
+ --disable-jit
.if (${OSVERSION} <= 700000)
WITH_PTMALLOC=yes
@@ -102,41 +108,42 @@ CONFIGURE_ENV+= LIBS="-L${LOCALBASE}/lib -lptmalloc"
.endif
post-patch:
- ${REINPLACE_CMD} 's+"makeinfo"+"${PREFIX}/bin/makeinfo"+' ${WRKSRC}/src/help.cc
- ${REINPLACE_CMD} 's+-lumfpack+-lumfpack -lcholmod -lcolamd -llapack+' ${WRKSRC}/configure
+ ${REINPLACE_CMD} 's+"makeinfo"+"${PREFIX}/bin/makeinfo"+' ${WRKSRC}/libinterp/corefcn/help.cc
+ ${REINPLACE_CMD} 's+-lumfpack+-lumfpack -lsuitesparseconfig -lamd -lcholmod -lcolamd ${LAPACK}+' ${WRKSRC}/configure
+ ${REINPLACE_CMD} 's+-lcholmod+-lumfpack -lsuitesparseconfig -lamd -lcholmod -lcolamd ${LAPACK}+' ${WRKSRC}/configure
post-install:
- ${MKDIR} ${DESKTOPDIR}
+ ${MKDIR} ${STAGEDIR}${DESKTOPDIR}
${INSTALL_DATA} ${WRKSRC}/doc/icons/octave.desktop \
- ${DESKTOPDIR}/www.octave.org-octave.desktop
+ ${STAGEDIR}${DESKTOPDIR}/www.octave.org-octave.desktop
.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
-.for file in faq/OctaveFAQ.ps liboctave/liboctave.ps \
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+.for file in liboctave/liboctave.ps \
refcard/refcard-a4.ps refcard/refcard-legal.ps \
refcard/refcard-letter.ps interpreter/octave.ps
- ${INSTALL_DATA} ${WRKSRC}/doc/${file} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/${file} ${STAGEDIR}${DOCSDIR}
.endfor
.endif
${RM} -f ${WRKDIR}/PLIST
-.for d in ${PREFIX}/include/octave-${OCTAVE_VERSION} ${PREFIX}/share/octave/${OCTAVE_VERSION} ${PREFIX}/share/octave/site ${PREFIX}/lib/octave/${OCTAVE_VERSION}
- @${FIND} -s $d -not -type d | \
- ${SED} -e 's#^${PREFIX}/##' >> ${WRKDIR}/PLIST
- @${FIND} -s $d -type d -empty | \
- ${SED} -e 's,^${PREFIX}/,@exec ${MKDIR} %D/,' \
+.for d in ${PREFIX}/include/octave-${OCTAVE_VERSION} ${PREFIX}/share/octave/${OCTAVE_VERSION} ${PREFIX}/share/octave/site ${PREFIX}/lib/octave/${OCTAVE_VERSION} ${PREFIX}/libexec/octave/${OCTAVE_VERSION}
+ @${FIND} -s ${STAGEDIR}$d -not -type d | \
+ ${SED} -e 's#^${STAGEDIR}${PREFIX}/##' >> ${WRKDIR}/PLIST
+ @${FIND} -s ${STAGEDIR}$d -type d -empty | \
+ ${SED} -e 's,^${STAGEDIR}${PREFIX}/,@exec ${MKDIR} %D/,' \
-e 's,$$, 2>/dev/null || true,' >> ${WRKDIR}/PLIST
- @${FIND} -s $d -type d -depth | \
- ${SED} -e 's,^${PREFIX}/,@dirrm ,' >> ${WRKDIR}/PLIST
+ @${FIND} -s ${STAGEDIR}$d -type d -depth | \
+ ${SED} -e 's,^${STAGEDIR}${PREFIX}/,@dirrm ,' >> ${WRKDIR}/PLIST
.endfor
-.for d in ${PREFIX}/libexec/octave/${OCTAVE_VERSION} ${PREFIX}/libexec/octave/api-v45+ ${PREFIX}/libexec/octave/api-v48+ ${PREFIX}/libexec/octave/site ${PREFIX}/lib/octave/site
- @${FIND} -s $d -type d -empty | \
- ${SED} -e 's,^${PREFIX}/,@exec ${MKDIR} %D/,' \
+.for d in ${PREFIX}/libexec/octave/api-v49+ ${PREFIX}/libexec/octave/site ${PREFIX}/lib/octave/site
+ @${FIND} -s ${STAGEDIR}$d -type d -empty | \
+ ${SED} -e 's,^${STAGEDIR}${PREFIX}/,@exec ${MKDIR} %D/,' \
-e 's,$$, 2>/dev/null || true,' >> ${WRKDIR}/PLIST
- @${FIND} -s $d -type d -depth | \
- ${SED} -e 's,^${PREFIX}/,@dirrm ,' >> ${WRKDIR}/PLIST
+ @${FIND} -s ${STAGEDIR}$d -type d -depth | \
+ ${SED} -e 's,^${STAGEDIR}${PREFIX}/,@dirrm ,' >> ${WRKDIR}/PLIST
.endfor
${ECHO_CMD} @dirrm libexec/octave >> ${WRKDIR}/PLIST
${ECHO_CMD} @dirrm share/octave >> ${WRKDIR}/PLIST
- cd ${WRKDIR} ; ${SED} -i -e "/PLIST/ r PLIST" ${TMPPLIST}
+ cd ${WRKDIR} ; ${SED} -i.bak -e "/PLIST/ r PLIST" ${TMPPLIST}
check regression-test: build
@(cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_ARGS} check)
diff --git a/math/octave/distinfo b/math/octave/distinfo
index 7e2488c640ac..096a69133dee 100644
--- a/math/octave/distinfo
+++ b/math/octave/distinfo
@@ -1,2 +1,2 @@
-SHA256 (octave-3.6.4.tar.bz2) = fa185df9591f5d740f4d37ff6eaf06db576fdd3e0ddd9d0737365799e5d1c962
-SIZE (octave-3.6.4.tar.bz2) = 15627315
+SHA256 (octave-3.8.0.tar.bz2) = 519330c6dd34eb69ca26a811722948fceac2acebd67ba924eba9b34a2e5a94f9
+SIZE (octave-3.8.0.tar.bz2) = 17669638
diff --git a/math/octave/files/patch-configure b/math/octave/files/patch-configure
index 14bcdaaef08f..933bf2e05c39 100644
--- a/math/octave/files/patch-configure
+++ b/math/octave/files/patch-configure
@@ -1,11 +1,16 @@
---- configure.orig 2013-02-21 21:21:49.000000000 +0100
-+++ configure 2013-11-22 20:34:49.000000000 +0100
-@@ -58248,7 +58248,7 @@
- main ()
- {
-
-- std::unordered_map m;
-+ std::unordered_map<int, int> m;
-
- ;
- return 0;
+--- configure.orig 2014-01-21 15:52:33.000000000 -0700
++++ configure 2014-01-21 15:54:59.000000000 -0700
+@@ -68380,6 +68380,13 @@
+ fi
+ JAVA_LIBS="-framework JavaVM"
+ ;;
++ freebsd*)
++ if test -n "$JAVA_CPPFLAGS"; then
++ JAVA_CPPFLAGS="-I${JAVA_CPPFLAGS}/include -I${JAVA_CPPFLAGS}/include/freebsd"
++ else
++ JAVA_CPPFLAGS="-I${JAVA_HOME}/include -I${JAVA_HOME}/include/freebsd"
++ fi
++ ;;
+ *)
+ if test -n "$JAVA_CPPFLAGS"; then
+ JAVA_CPPFLAGS="-I${JAVA_CPPFLAGS}/include -I${JAVA_CPPFLAGS}/include/linux"
diff --git a/math/octave/files/patch-gsed b/math/octave/files/patch-gsed
new file mode 100644
index 000000000000..60baf64ae811
--- /dev/null
+++ b/math/octave/files/patch-gsed
@@ -0,0 +1,88 @@
+--- build-aux/find-files-with-tests.sh.orig 2014-01-20 20:35:29.000000000 -0700
++++ build-aux/find-files-with-tests.sh 2014-01-20 20:36:30.000000000 -0700
+@@ -2,7 +2,7 @@
+
+ set -e
+ GREP=${GREP:-grep}
+-SED=${SED:-sed}
++SED=gsed
+
+ srcdir="$1"
+ shift
+--- libinterp/find-defun-files.sh.orig 2014-01-20 20:08:01.000000000 -0700
++++ libinterp/find-defun-files.sh 2014-01-20 20:08:20.000000000 -0700
+@@ -1,7 +1,7 @@
+ #! /bin/sh
+
+ set -e
+-SED=${SED:-sed}
++SED=gsed
+ EGREP=${EGREP:-egrep}
+
+ # Some stupid egreps don't like empty elements in alternation patterns,
+--- libinterp/mk-pkg-add.orig 2014-01-20 20:04:33.000000000 -0700
++++ libinterp/mk-pkg-add 2014-01-20 20:05:01.000000000 -0700
+@@ -20,7 +20,7 @@
+
+ set -e
+
+-SED=${SED:-'sed'}
++SED=gsed
+
+ for f in "$@"; do
+ if [ -f $f ]; then
+--- libinterp/mkbuiltins.orig 2014-01-20 19:17:57.000000000 -0700
++++ libinterp/mkbuiltins 2014-01-20 19:18:24.000000000 -0700
+@@ -23,7 +23,7 @@
+ exit 1
+ fi
+
+-SED=${SED:-'sed'}
++SED=gsed
+
+ make_header=false
+ make_source=false
+--- libinterp/mkdefs.orig 2014-01-20 20:17:00.000000000 -0700
++++ libinterp/mkdefs 2014-01-20 20:17:15.000000000 -0700
+@@ -18,7 +18,7 @@
+ # along with Octave; see the file COPYING. If not, see
+ # <http://www.gnu.org/licenses/>.
+
+-SED=${SED:-'sed'}
++SED=gsed
+
+ if [ $# -ne 2 ]; then
+ echo "usage: mkdefs srcdir file < preprocessed-file-contents" 1>&2
+--- libinterp/mkops.orig 2014-01-20 20:26:24.000000000 -0700
++++ libinterp/mkops 2014-01-20 20:26:50.000000000 -0700
+@@ -18,7 +18,7 @@
+ # along with Octave; see the file COPYING. If not, see
+ # <http://www.gnu.org/licenses/>.
+
+-SED=${SED:-'sed'}
++SED=gsed
+
+ cat << \EOF
+ // DO NOT EDIT! Generated automatically by mkops.
+--- liboctave/cruft/mkf77def.in.orig 2014-01-20 05:27:13.000000000 -0700
++++ liboctave/cruft/mkf77def.in 2014-01-20 05:27:28.000000000 -0700
+@@ -18,7 +18,7 @@
+ # along with Octave; see the file COPYING. If not, see
+ # <http://www.gnu.org/licenses/>.
+
+-SED=${SED:-'sed'}
++SED=gsed
+ AWK=${AWK:-'awk'}
+
+ F77_TOLOWER="@F77_APPEND_UNDERSCORE@"
+--- scripts/mk-pkg-add.orig 2014-01-20 20:30:14.000000000 -0700
++++ scripts/mk-pkg-add 2014-01-20 20:30:36.000000000 -0700
+@@ -24,7 +24,7 @@
+
+ set -e
+
+-SED=${SED:-'sed'}
++SED=gsed
+
+ prefix="$1/"
+ shift
diff --git a/math/octave/files/patch-libcruft+mkf77def.in b/math/octave/files/patch-libcruft+mkf77def.in
deleted file mode 100644
index 7383c372bf5d..000000000000
--- a/math/octave/files/patch-libcruft+mkf77def.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- libcruft/mkf77def.in.orig 2011-02-08 04:00:51.000000000 -0600
-+++ libcruft/mkf77def.in 2011-04-20 18:26:34.000000000 -0500
-@@ -18,7 +18,7 @@
- # along with Octave; see the file COPYING. If not, see
- # <http://www.gnu.org/licenses/>.
-
--SED=${SED:-'sed'}
-+SED=gsed
- AWK=${AWK:-'awk'}
-
- F77_TOLOWER="@F77_APPEND_UNDERSCORE@"
diff --git a/math/octave/files/patch-libinterp+dldfcn+__glpk__.cc b/math/octave/files/patch-libinterp+dldfcn+__glpk__.cc
new file mode 100644
index 000000000000..1064e1f1c1fa
--- /dev/null
+++ b/math/octave/files/patch-libinterp+dldfcn+__glpk__.cc
@@ -0,0 +1,10 @@
+--- libinterp/dldfcn/__glpk__.cc.orig 2014-01-20 06:29:02.000000000 -0700
++++ libinterp/dldfcn/__glpk__.cc 2014-01-20 06:32:50.000000000 -0700
+@@ -46,6 +46,7 @@
+ #include <glpk/glpk.h>
+ #else
+ #include <glpk.h>
++#include <glplpx.h>
+ #endif
+ }
+
diff --git a/math/octave/files/patch-liboctave-eigs-base.cc b/math/octave/files/patch-liboctave-eigs-base.cc
deleted file mode 100644
index a08e6cbc7336..000000000000
--- a/math/octave/files/patch-liboctave-eigs-base.cc
+++ /dev/null
@@ -1,11 +0,0 @@
---- liboctave/eigs-base.cc.orig 2013-02-21 21:19:24.000000000 +0100
-+++ liboctave/eigs-base.cc 2013-11-22 20:19:19.000000000 +0100
-@@ -3832,7 +3832,7 @@
- bool cholB = 0, int disp = 0, int maxit = 300);
- #endif
-
--#ifndef _MSC_VER
-+#if !defined(_MSC_VER) && !defined(__clang__)
- template static octave_idx_type
- lusolve (const SparseMatrix&, const SparseMatrix&, Matrix&);
-
diff --git a/math/octave/files/patch-liboctave-numeric-eigs-base.cc b/math/octave/files/patch-liboctave-numeric-eigs-base.cc
new file mode 100644
index 000000000000..216faa85df43
--- /dev/null
+++ b/math/octave/files/patch-liboctave-numeric-eigs-base.cc
@@ -0,0 +1,11 @@
+--- liboctave/numeric/eigs-base.cc.orig 2014-01-20 05:36:55.000000000 -0700
++++ liboctave/numeric/eigs-base.cc 2014-01-20 05:37:23.000000000 -0700
+@@ -3849,7 +3849,7 @@
+ int disp = 0, int maxit = 300);
+ #endif
+
+-#ifndef _MSC_VER
++#if !defined(_MSC_VER) && !defined(__clang__)
+ template octave_idx_type
+ lusolve (const SparseMatrix&, const SparseMatrix&, Matrix&);
+
diff --git a/math/octave/files/patch-octave-doc b/math/octave/files/patch-octave-doc
deleted file mode 100644
index 8dc1f3cc516a..000000000000
--- a/math/octave/files/patch-octave-doc
+++ /dev/null
@@ -1,377 +0,0 @@
-
---- doc/interpreter/audio.texi 2013-02-21 21:37:50.000000000 +0100
-+++ doc/interpreter/audio.texi 2013-05-01 23:23:21.338665377 +0200
-@@ -146,18 +146,18 @@
- Load the RIFF/WAVE sound file @var{filename}, and return the samples
- in vector @var{y}. If the file contains multichannel data, then
- @var{y} is a matrix with the channels represented as columns.
--
--@deftypefnx {Function File} {[@var{y}, @var{Fs}, @var{bps}] =} wavread (@var{filename})
-+@end deftypefn
-+@deftypefn {Function File} {[@var{y}, @var{Fs}, @var{bps}] =} wavread (@var{filename})
- Additionally return the sample rate (@var{fs}) in Hz and the number of bits
- per sample (@var{bps}).
--
--@deftypefnx {Function File} {[@dots{}] =} wavread (@var{filename}, @var{n})
-+@end deftypefn
-+@deftypefn {Function File} {[@dots{}] =} wavread (@var{filename}, @var{n})
- Read only the first @var{n} samples from each channel.
--
--@deftypefnx {Function File} {[@dots{}] =} wavread (@var{filename}, @var{n1} @var{n2})
-+@end deftypefn
-+@deftypefn {Function File} {[@dots{}] =} wavread (@var{filename}, @var{n1} @var{n2})
- Read only samples @var{n1} through @var{n2} from each channel.
--
--@deftypefnx {Function File} {[@var{samples}, @var{channels}] =} wavread (@var{filename}, "size")
-+@end deftypefn
-+@deftypefn {Function File} {[@var{samples}, @var{channels}] =} wavread (@var{filename}, "size")
- Return the number of samples (@var{n}) and channels (@var{ch})
- instead of the audio data.
- @seealso{@ref{doc-wavwrite,,wavwrite}}
-
---- doc/interpreter/io.texi 2013-02-21 21:37:51.000000000 +0100
-+++ doc/interpreter/io.texi 2013-05-01 22:59:08.537582265 +0200
-@@ -1391,22 +1391,22 @@
- for the file. Valid values for @var{arch} are:
-
- @table @asis
--@samp{native}
-+@item @samp{native}
- The format of the current machine (this is the default).
-
--@samp{ieee-be}
-+@item @samp{ieee-be}
- IEEE big endian format.
-
--@samp{ieee-le}
-+@item @samp{ieee-le}
- IEEE little endian format.
-
--@samp{vaxd}
-+@item @samp{vaxd}
- VAX D floating format.
-
--@samp{vaxg}
-+@item @samp{vaxg}
- VAX G floating format.
-
--@samp{cray}
-+@item @samp{cray}
- Cray floating format.
- @end table
-
-
---- doc/interpreter/octave.texi 2013-02-21 21:19:23.000000000 +0100
-+++ doc/interpreter/octave.texi 2013-05-01 22:58:26.561420772 +0200
-@@ -129,7 +129,9 @@
- @sp 2
- @multitable @columnfractions 0.4 0.025 0.65
- @item
--@flushright @image{octave_logo,2.1in} @end flushright
-+@flushright
-+@image{octave_logo,2.1in}
-+@end flushright
- @tab
- @c this is a spacer column
- @tab
-
---- doc/interpreter/plot.texi 2013-02-21 21:37:52.000000000 +0100
-+++ doc/interpreter/plot.texi 2013-05-01 23:07:36.586442176 +0200
-@@ -2707,21 +2707,20 @@
- Set the data aspect ratio of the current axes. The aspect ratio is
- a normalized 3-element vector representing the span of the x, y, and
- z-axes limits.
--
--@deftypefnx {Function File} {@var{data_aspect_ratio} =} daspect ( )
-+@end deftypefn
-+@deftypefn {Function File} {@var{data_aspect_ratio} =} daspect ( )
- Return the data aspect ratio of the current axes.
--
--@deftypefnx {Function File} {} daspect (@var{mode})
-+@end deftypefn
-+@deftypefn {Function File} {} daspect (@var{mode})
- Set the data aspect ratio mode of the current axes.
--
--@deftypefnx {Function File} {@var{data_aspect_ratio_mode} =} daspect ("mode")
-+@end deftypefn
-+@deftypefn {Function File} {@var{data_aspect_ratio_mode} =} daspect ("mode")
- Return the data aspect ratio mode of the current axes.
--
--@deftypefnx {Function File} {} daspect (@var{hax}, @dots{})
-+@end deftypefn
-+@deftypefn {Function File} {} daspect (@var{hax}, @dots{})
- Use the axes, with handle @var{hax}, instead of the current axes.
--
--@seealso{@ref{doc-axis,,axis}, @ref{doc-pbaspect,,pbaspect}, @ref{doc-xlim,,xlim}, @ref{doc-ylim,,ylim}, @ref{doc-zlim,,zlim}}
- @end deftypefn
-+@seealso{@ref{doc-axis,,axis}, @ref{doc-pbaspect,,pbaspect}, @ref{doc-xlim,,xlim}, @ref{doc-ylim,,ylim}, @ref{doc-zlim,,zlim}}
-
-
- @c pbaspect scripts/plot/pbaspect.m
-@@ -2730,21 +2729,20 @@
- Set the plot box aspect ratio of the current axes. The aspect ratio
- is a normalized 3-element vector representing the rendered lengths of
- the x, y, and z-axes.
--
--@deftypefnx {Function File} {@var{plot_box_aspect_ratio} =} pbaspect ( )
-+@end deftypefn
-+@deftypefn {Function File} {@var{plot_box_aspect_ratio} =} pbaspect ( )
- Return the plot box aspect ratio of the current axes.
--
--@deftypefnx {Function File} {} pbaspect (@var{mode})
-+@end deftypefn
-+@deftypefn {Function File} {} pbaspect (@var{mode})
- Set the plot box aspect ratio mode of the current axes.
--
--@deftypefnx {Function File} {@var{plot_box_aspect_ratio_mode} =} pbaspect ("mode")
-+@end deftypefn
-+@deftypefn {Function File} {@var{plot_box_aspect_ratio_mode} =} pbaspect ("mode")
- Return the plot box aspect ratio mode of the current axes.
--
--@deftypefnx {Function File} {} pbaspect (@var{hax}, @dots{})
-+@end deftypefn
-+@deftypefn {Function File} {} pbaspect (@var{hax}, @dots{})
- Use the axes, with handle @var{hax}, instead of the current axes.
--
--@seealso{@ref{doc-axis,,axis}, @ref{doc-daspect,,daspect}, @ref{doc-xlim,,xlim}, @ref{doc-ylim,,ylim}, @ref{doc-zlim,,zlim}}
- @end deftypefn
-+@seealso{@ref{doc-axis,,axis}, @ref{doc-daspect,,daspect}, @ref{doc-xlim,,xlim}, @ref{doc-ylim,,ylim}, @ref{doc-zlim,,zlim}}
-
-
- @node Three-dimensional Function Plotting
-@@ -3147,7 +3145,7 @@
- @item "hide"
- Hide legend on the plot
-
--@itemx "toggle"
-+@item "toggle"
- Toggles between "hide" and "show"
-
- @item "boxon"
-@@ -3162,7 +3160,7 @@
- @item "right"
- Place text to the right of the keys
-
--@itemx "off"
-+@item "off"
- Delete the legend object
- @end table
- @end deftypefn
-@@ -4139,11 +4137,11 @@
- is sent to a file the size is determined by the plot box defined by
- the figure's "paperposition" property.
-
--@itemx -append
-+@item -append
- Appends the PS, or PDF output to a pre-existing file of the
- same type.
-
--@itemx -r@var{NUM}
-+@item -r@var{NUM}
- Resolution of bitmaps in pixels per inch. For both metafiles and
- SVG the default is the screen resolution, for other it is 150 dpi.
- To specify screen resolution, use "-r0".
-@@ -6296,15 +6294,15 @@
- A character indicating a plot marker to be place at each data point, or
- @code{"none"}, meaning no markers should be displayed.
-
--@itemx markeredgecolor
-+@item markeredgecolor
- The color of the edge around the marker, or @code{"auto"}, meaning that
- the edge color is the same as the face color. @xref{Colors}.
-
--@itemx markerfacecolor
-+@item markerfacecolor
- The color of the marker, or @code{"none"} to indicate that the marker
- should not be filled. @xref{Colors}.
-
--@itemx markersize
-+@item markersize
- A number specifying the size of the marker. The default is 1. A value
- of 2 is twice as large as the default, etc.
- @end table
-@@ -6442,7 +6440,8 @@
- @deftypefn {Function File} {@var{value} =} getappdata (@var{h}, @var{name})
- Return the @var{value} for named application data for the object(s) with
- handle(s) @var{h}.
--@deftypefnx {Function File} {@var{appdata} =} getappdata (@var{h})
-+@end deftypefn
-+@deftypefn {Function File} {@var{appdata} =} getappdata (@var{h})
- Return a structure, @var{appdata}, whose fields correspond to the appdata
- properties.
- @end deftypefn
-
---- doc/interpreter/poly.texi 2013-02-21 21:37:52.000000000 +0100
-+++ doc/interpreter/poly.texi 2013-05-01 23:28:59.515000917 +0200
-@@ -82,8 +82,8 @@
- (@var{x}-@var{mu}(1))/@var{mu}(2).
- If @var{x} is a vector or matrix, the polynomial is evaluated for each of
- the elements of @var{x}.
--
--@deftypefnx {Function File} {[@var{y}, @var{dy}] =} polyval (@var{p}, @var{x}, @var{s})
-+@end deftypefn
-+@deftypefn {Function File} {[@var{y}, @var{dy}] =} polyval (@var{p}, @var{x}, @var{s})
- @deftypefnx {Function File} {[@var{y}, @var{dy}] =} polyval (@var{p}, @var{x}, @var{s}, @var{mu})
- In addition to evaluating the polynomial, the second output
- represents the prediction interval, @var{y} +/- @var{dy}, which
-
---- doc/interpreter/set.texi 2013-02-21 21:37:52.000000000 +0100
-+++ doc/interpreter/set.texi 2013-05-01 23:30:00.161810855 +0200
-@@ -150,8 +150,9 @@
- 3 4
- @end group
- @end example
-+@end deftypefn
-
--@deftypefnx {Function File} {[@var{c}, @var{ia}, @var{ib}] =} union (@var{a}, @var{b})
-+@deftypefn {Function File} {[@var{c}, @var{ia}, @var{ib}] =} union (@var{a}, @var{b})
-
- Return index vectors @var{ia} and @var{ib} such that @code{a(ia)} and
- @code{b(ib)} are disjoint sets whose union is @var{c}.
-
---- doc/interpreter/signal.texi 2013-02-21 21:37:52.000000000 +0100
-+++ doc/interpreter/signal.texi 2013-05-01 23:31:41.111833440 +0200
-@@ -454,17 +454,17 @@
-
- For fastest computation, @var{n} should factor into a small number of
- small primes.
--
--@deftypefnx {Function File} {@var{h} =} freqz (@var{b}, @var{a}, @var{w})
-+@end deftypefn
-+@deftypefn {Function File} {@var{h} =} freqz (@var{b}, @var{a}, @var{w})
- Evaluate the response at the specific frequencies in the vector @var{w}.
- The values for @var{w} are measured in radians.
--
--@deftypefnx {Function File} {[@dots{}] =} freqz (@dots{}, @var{Fs})
-+@end deftypefn
-+@deftypefn {Function File} {[@dots{}] =} freqz (@dots{}, @var{Fs})
- Return frequencies in Hz instead of radians assuming a sampling rate
- @var{Fs}. If you are evaluating the response at specific frequencies
- @var{w}, those frequencies should be requested in Hz rather than radians.
--
--@deftypefnx {Function File} {} freqz (@dots{})
-+@end deftypefn
-+@deftypefn {Function File} {} freqz (@dots{})
- Plot the pass band, stop band and phase response of @var{h} rather
- than returning them.
- @end deftypefn
-
---- doc/interpreter/strings.texi 2013-02-21 21:37:52.000000000 +0100
-+++ doc/interpreter/strings.texi 2013-05-01 22:27:29.646311770 +0200
-@@ -1136,7 +1136,7 @@
- @item %s
- The word is parsed as a string.
-
--@itemx %f
-+@item %f
- @itemx %n
- The word is parsed as a number and converted to double.
-
-
---- doc/interpreter/system.texi 2013-02-21 21:37:52.000000000 +0100
-+++ doc/interpreter/system.texi 2013-05-01 23:45:09.981978551 +0200
-@@ -839,7 +839,7 @@
- @deftypefnx {Function File} {} datetick (@var{axis}, @var{form})
- @deftypefnx {Function File} {} datetick (@dots{}, "keeplimits")
- @deftypefnx {Function File} {} datetick (@dots{}, "keepticks")
--@deftypefnx {Function File} {} datetick (@dots{ax}, @dots{})
-+@comment @deftypefnx {Function File} {} datetick (@dots{ax}, @dots{})
- Add date formatted tick labels to an axis. The axis the apply the
- ticks to is determined by @var{axis} that can take the values "x",
- "y" or "z". The default value is "x". The formatting of the labels is
-@@ -1261,9 +1261,10 @@
- interpreted as filename globbing patterns (as they are used by Unix shells).
- Within a pattern
- @table @code
--@itemx *
-+
-+@item *
- matches any string, including the null string,
--@itemx ?
-+@item ?
- matches any single character, and
-
- @item [@dots{}]
-@@ -2789,8 +2790,8 @@
- Display a header containing the current Octave version number, license
- string and operating system, followed by the installed package names,
- versions, and installation directories.
--
--@deftypefnx {Function File} {v =} ver ()
-+@end deftypefn
-+@deftypefn {Function File} {v =} ver ()
- Return a vector of structures, respecting Octave and each installed package.
- The structure includes the following fields.
-
-@@ -2807,11 +2808,11 @@
- @item Date
- Date respecting the version/revision.
- @end table
--
--@deftypefnx {Function File} {v =} ver ("Octave")
-+@end deftypefn
-+@deftypefn {Function File} {v =} ver ("Octave")
- Return version information for Octave only.
--
--@deftypefnx {Function File} {v =} ver (@var{package})
-+@end deftypefn
-+@deftypefn {Function File} {v =} ver (@var{package})
- Return version information for @var{package}.
-
- @seealso{@ref{doc-version,,version}, @ref{doc-octave_config_info,,octave_config_info}}
-@@ -2878,19 +2879,19 @@
- @anchor{doc-license}
- @deftypefn {Function File} {} license
- Display the license of Octave.
--
--@deftypefnx {Function File} {} license ("inuse")
-+@end deftypefn
-+@deftypefn {Function File} {} license ("inuse")
- Display a list of packages currently being used.
--
--@deftypefnx {Function File} {@var{retval} =} license ("inuse")
-+@end deftypefn
-+@deftypefn {Function File} {@var{retval} =} license ("inuse")
- Return a structure containing the fields @code{feature} and @code{user}.
--
--@deftypefnx {Function File} {@var{retval} =} license ("test", @var{feature})
-+@end deftypefn
-+@deftypefn {Function File} {@var{retval} =} license ("test", @var{feature})
- Return 1 if a license exists for the product identified by the string
- @var{feature} and 0 otherwise. The argument @var{feature} is case
- insensitive and only the first 27 characters are checked.
--
--@deftypefnx {Function File} {} license ("test", @var{feature}, @var{toggle})
-+@end deftypefn
-+@deftypefn {Function File} {} license ("test", @var{feature}, @var{toggle})
- Enable or disable license testing for @var{feature}, depending on
- @var{toggle}, which may be one of:
-
-@@ -2902,8 +2903,8 @@
- @item "disable"
- Future tests for the specified license of @var{feature} return 0.
- @end table
--
--@deftypefnx {Function File} {@var{retval} =} license ("checkout", @var{feature})
-+@end deftypefn
-+@deftypefn {Function File} {@var{retval} =} license ("checkout", @var{feature})
- Check out a license for @var{feature}, returning 1 on success and 0
- on failure.
-
---- doc/liboctave/liboctave.texi.orig 2013-02-22 05:19:23.000000000 +0900
-+++ doc/liboctave/liboctave.texi 2013-10-27 00:04:40.000000000 +0900
-@@ -80,10 +80,10 @@
- @end ifnottex
-
- @titlepage
--@title{Octave C++ Classes}
--@subtitle{Edition 1.0 for Octave version @value{VERSION}}
--@subtitle{September 1993}
--@author{John W. Eaton}
-+@title Octave C++ Classes
-+@subtitle Edition 1.0 for Octave version @value{VERSION}
-+@subtitle September 1993
-+@author John W. Eaton
- @page
- @vskip 0pt plus 1filll
- Copyright @copyright{} 1996, 1997 John W. Eaton.
diff --git a/math/octave/files/patch-scripts+pkg+pkg.m b/math/octave/files/patch-scripts+pkg+pkg.m
deleted file mode 100644
index a6387b96f962..000000000000
--- a/math/octave/files/patch-scripts+pkg+pkg.m
+++ /dev/null
@@ -1,11 +0,0 @@
---- scripts/pkg/pkg.m.orig 2011-02-08 19:00:51.000000000 +0900
-+++ scripts/pkg/pkg.m 2011-05-09 12:18:05.000000000 +0900
-@@ -1326,7 +1326,7 @@
-
- ## Make.
- if (exist (fullfile (src, "Makefile"), "file"))
-- [status, output] = shell (cstrcat (scenv, "make -C '", src, "'"));
-+ [status, output] = shell (cstrcat (scenv, "gmake -C '", src, "'"));
- if (status != 0)
- rm_rf (desc.dir);
- error ("'make' returned the following error: %s", output);
diff --git a/math/octave/files/patch-scripts+pkg+private+configure__make.m b/math/octave/files/patch-scripts+pkg+private+configure__make.m
new file mode 100644
index 000000000000..a4ad64a84165
--- /dev/null
+++ b/math/octave/files/patch-scripts+pkg+private+configure__make.m
@@ -0,0 +1,11 @@
+--- scripts/pkg/private/configure_make.m.orig 2014-01-20 06:14:25.000000000 -0700
++++ scripts/pkg/private/configure_make.m 2014-01-20 06:16:15.000000000 -0700
+@@ -75,7 +75,7 @@
+
+ ## Make.
+ if (exist (fullfile (src, "Makefile"), "file"))
+- [status, output] = shell ([scenv "make -C '" src "'"], verbose);
++ [status, output] = shell ([scenv "gmake -C '" src "'"], verbose);
+ if (status != 0)
+ rmdir (desc.dir, "s");
+ disp (output);
diff --git a/math/octave/files/patch-src+DLD-FUNCTIONS+__glpk__.cc b/math/octave/files/patch-src+DLD-FUNCTIONS+__glpk__.cc
deleted file mode 100644
index bfada7679d8f..000000000000
--- a/math/octave/files/patch-src+DLD-FUNCTIONS+__glpk__.cc
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/DLD-FUNCTIONS/__glpk__.cc.orig 2012-01-03 15:48:37.000000000 -0500
-+++ src/DLD-FUNCTIONS/__glpk__.cc 2013-05-07 09:25:34.000000000 -0400
-@@ -45,6 +45,7 @@
- #include <glpk/glpk.h>
- #else
- #include <glpk.h>
-+#include <glplpx.h>
- #endif
-
- #if 0
diff --git a/math/octave/pkg-plist b/math/octave/pkg-plist
index 7a7763459cde..cda7939b91ba 100644
--- a/math/octave/pkg-plist
+++ b/math/octave/pkg-plist
@@ -2,10 +2,11 @@ bin/mkoctfile
bin/mkoctfile-%%OCTAVE_VERSION%%
bin/octave
bin/octave-%%OCTAVE_VERSION%%
+bin/octave-cli
+bin/octave-cli-%%OCTAVE_VERSION%%
bin/octave-config
bin/octave-config-%%OCTAVE_VERSION%%
share/applications/www.octave.org-octave.desktop
-%%PORTDOCS%%%%DOCSDIR%%/OctaveFAQ.ps
%%PORTDOCS%%%%DOCSDIR%%/liboctave.ps
%%PORTDOCS%%%%DOCSDIR%%/refcard-a4.ps
%%PORTDOCS%%%%DOCSDIR%%/refcard-legal.ps