aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorwen <wen@FreeBSD.org>2017-03-19 08:41:08 +0800
committerwen <wen@FreeBSD.org>2017-03-19 08:41:08 +0800
commitfc880c7a16941546a0d6c36e05ef7625b9b44fb5 (patch)
tree18c822a9e45aa979989880899bcf76f57197dafd /math
parent17b27b2f360d59a204470e293f80a3a92516a855 (diff)
downloadfreebsd-ports-gnome-fc880c7a16941546a0d6c36e05ef7625b9b44fb5.tar.gz
freebsd-ports-gnome-fc880c7a16941546a0d6c36e05ef7625b9b44fb5.tar.zst
freebsd-ports-gnome-fc880c7a16941546a0d6c36e05ef7625b9b44fb5.zip
- Remove dependency on math/openblas if other blas lib is selected
PR: 215764 Submitted by: riggs@
Diffstat (limited to 'math')
-rw-r--r--math/py-numpy/Makefile5
-rw-r--r--math/py-numpy/files/patch-numpy-distutils-system_info.py18
2 files changed, 17 insertions, 6 deletions
diff --git a/math/py-numpy/Makefile b/math/py-numpy/Makefile
index 4889643520f6..4f250c53a2eb 100644
--- a/math/py-numpy/Makefile
+++ b/math/py-numpy/Makefile
@@ -3,7 +3,7 @@
PORTNAME= numpy
PORTVERSION= 1.11.2
-PORTREVISION= 1
+PORTREVISION= 2
PORTEPOCH= 1
CATEGORIES= math python
MASTER_SITES= CHEESESHOP:source \
@@ -41,8 +41,7 @@ GCCLIBDIR_CMDS= ${FC} -print-file-name=libgfortran.so | ${SED} -e s/libgfortran.
ATLAS_USES= blaslapack:atlas
NETLIB_USES= blaslapack:netlib
-NETLIB_LIB_DEPENDS= libcblas.so:math/cblas \
- libopenblas.so:math/openblas
+NETLIB_LIB_DEPENDS= libcblas.so:math/cblas
OPENBLAS_USES= blaslapack:openblas
SUITESPARSE_LIB_DEPENDS=libumfpack.so:math/suitesparse
TESTS_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}nose>=0:devel/py-nose
diff --git a/math/py-numpy/files/patch-numpy-distutils-system_info.py b/math/py-numpy/files/patch-numpy-distutils-system_info.py
index c71c7f922b03..20864eb025d2 100644
--- a/math/py-numpy/files/patch-numpy-distutils-system_info.py
+++ b/math/py-numpy/files/patch-numpy-distutils-system_info.py
@@ -1,6 +1,6 @@
---- numpy/distutils/system_info.py.orig 2013-02-09 22:04:56.000000000 +0100
-+++ numpy/distutils/system_info.py 2013-03-22 21:01:34.000000000 +0100
-@@ -995,8 +995,8 @@
+--- numpy/distutils/system_info.py.orig 2016-10-03 23:42:24 UTC
++++ numpy/distutils/system_info.py
+@@ -1038,8 +1038,8 @@ class atlas_info(system_info):
dir_env_var = 'ATLAS'
_lib_names = ['f77blas', 'cblas']
if sys.platform[:7] == 'freebsd':
@@ -11,3 +11,15 @@
else:
_lib_atlas = ['atlas']
_lib_lapack = ['lapack']
+@@ -1574,11 +1574,6 @@ class blas_opt_info(system_info):
+ self.set_info(**blas_mkl_info)
+ return
+
+- openblas_info = get_info('openblas')
+- if openblas_info:
+- self.set_info(**openblas_info)
+- return
+-
+ atlas_info = get_info('atlas_3_10_blas_threads')
+ if not atlas_info:
+ atlas_info = get_info('atlas_3_10_blas')