aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2015-06-30 01:14:40 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2015-06-30 01:14:40 +0800
commitfcd95768aa9fca0077e245b08c10d9c0f1cd6061 (patch)
treec0c2cecb9b930bc6e5e1fab6ddf7627476d153d6 /math
parentdab588c4015df6589812196d9923cbd2c28f21e5 (diff)
downloadfreebsd-ports-gnome-fcd95768aa9fca0077e245b08c10d9c0f1cd6061.tar.gz
freebsd-ports-gnome-fcd95768aa9fca0077e245b08c10d9c0f1cd6061.tar.zst
freebsd-ports-gnome-fcd95768aa9fca0077e245b08c10d9c0f1cd6061.zip
- Mark BROKEN on 9.x: does not link [1]:
crt1.c:(.text+0x9d): undefined reference to `main' - Fix shebangs Submitted by: pkg-fallout [1] Approved by: portmgr blanket
Diffstat (limited to 'math')
-rw-r--r--math/mosesdecoder/Makefile12
1 files changed, 11 insertions, 1 deletions
diff --git a/math/mosesdecoder/Makefile b/math/mosesdecoder/Makefile
index fc9956d44220..aefbaaa14301 100644
--- a/math/mosesdecoder/Makefile
+++ b/math/mosesdecoder/Makefile
@@ -3,6 +3,7 @@
PORTNAME= mosesdecoder
PORTVERSION= 2.1.1
+PORTREVISION= 1
DISTVERSIONPREFIX= RELEASE-
CATEGORIES= math
@@ -16,13 +17,22 @@ LIB_DEPENDS= libboost_thread.so:${PORTSDIR}/devel/boost-libs \
libirstlm.so:${PORTSDIR}/textproc/irstlm
RUN_DEPENDS= lmplz:${PORTSDIR}/textproc/kenlm
+BROKEN_FreeBSD_9= does not link
+
USE_GITHUB= yes
GH_ACCOUNT= moses-smt
-USES= compiler:c++11-lang
+USES= compiler:c++11-lang shebangfix
+SHEBANG_FILES= scripts/analysis/weight-scan-summarize.sh \
+ scripts/training/wrappers/adam-suffix-array/suffix-array-extract.sh \
+ scripts/training/wrappers/adam-suffix-array/suffix-array-create.sh
MAKE_ENV+= BOOST_BUILD_PATH=${WRKSRC}/jam-files/boost-build
+post-patch:
+ @${FIND} ${WRKSRC}/scripts \( -name "*.pl" -o -name "*.perl" -o -name "*.cgi" \) -exec \
+ ${REINPLACE_CMD} -i '' -e '1s|${perl_OLD_CMD}|${perl_CMD}|' {} \;
+
do-build:
cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} bjam --with-boost=${LOCALBASE} --with-irstlm=${LOCALBASE} --with-randlm=${LOCALBASE} --without-tcmalloc --notrace --toolset=${CHOSEN_COMPILER_TYPE} debug-symbols=off ${_MAKE_JOBS}