aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorjmd <jmd@FreeBSD.org>2019-01-28 11:12:12 +0800
committerjmd <jmd@FreeBSD.org>2019-01-28 11:12:12 +0800
commitfedd1cc25c2e997cd1bd9aae91dd16504ce08ab8 (patch)
treed1c1dfc2603e5020d665af7b7298e73053d1c8e0 /math
parent11320d899e3d8ee60d41970637ec122591479ac9 (diff)
downloadfreebsd-ports-gnome-fedd1cc25c2e997cd1bd9aae91dd16504ce08ab8.tar.gz
freebsd-ports-gnome-fedd1cc25c2e997cd1bd9aae91dd16504ce08ab8.tar.zst
freebsd-ports-gnome-fedd1cc25c2e997cd1bd9aae91dd16504ce08ab8.zip
math/libpgmath: enforce usage of LLVM6
LLVM7 on 13-CURRENT breaks intrinsics definitions.
Diffstat (limited to 'math')
-rw-r--r--math/libpgmath/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/math/libpgmath/Makefile b/math/libpgmath/Makefile
index da0cae4e7842..4d7ee85c6b24 100644
--- a/math/libpgmath/Makefile
+++ b/math/libpgmath/Makefile
@@ -3,7 +3,7 @@
PORTNAME= libpgmath
DISTVERSION= g20180904
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= math
MAINTAINER= jmd@FreeBSD.org
@@ -26,9 +26,10 @@ GH_ACCOUNT= flang-compiler
GH_PROJECT= flang
GH_TAGNAME= 53e368b
-CMAKE_ARGS+= -DLLVM_CONFIG=${LOCALBASE}/bin/llvm-config60 \
- -DCMAKE_CXX_COMPILER=${LOCALBASE}/llvm60/bin/clang++ \
- -DCMAKE_C_COMPILER=${LOCALBASE}/llvm60/bin/clang
+CC= ${LOCALBASE}/llvm60/bin/clang
+CXX= ${LOCALBASE}/llvm60/bin/clang++
+
+CMAKE_ARGS+= -DLLVM_CONFIG=${LOCALBASE}/bin/llvm-config60
WRKSRC_SUBDIR= runtime/libpgmath