aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorpi <pi@FreeBSD.org>2016-02-08 01:41:50 +0800
committerpi <pi@FreeBSD.org>2016-02-08 01:41:50 +0800
commitfefb8a0a5ec5d403f730cdb57eba4017b85b6145 (patch)
treeaddc8f5deb6c8fca307254df1312bbcfe63b2e4b /math
parentfb26322477961e8da8c4983695a99b3bb61b23b7 (diff)
downloadfreebsd-ports-gnome-fefb8a0a5ec5d403f730cdb57eba4017b85b6145.tar.gz
freebsd-ports-gnome-fefb8a0a5ec5d403f730cdb57eba4017b85b6145.tar.zst
freebsd-ports-gnome-fefb8a0a5ec5d403f730cdb57eba4017b85b6145.zip
math/p5-Math-BigInt: the overload of '..' is still not supported in perl
- Similar patch is done in the lang/perl* ports PR: 196773 Submitted by: papowell@astart.com Approved by: tobez (maintainer timeout)
Diffstat (limited to 'math')
-rw-r--r--math/p5-Math-BigInt/Makefile1
-rw-r--r--math/p5-Math-BigInt/files/patch-lib_Math_BigInt.pm11
2 files changed, 12 insertions, 0 deletions
diff --git a/math/p5-Math-BigInt/Makefile b/math/p5-Math-BigInt/Makefile
index f589770ebf77..ebfed2e52d08 100644
--- a/math/p5-Math-BigInt/Makefile
+++ b/math/p5-Math-BigInt/Makefile
@@ -3,6 +3,7 @@
PORTNAME= Math-BigInt
PORTVERSION= 1.999715
+PORTREVISION= 1
CATEGORIES= math perl5
MASTER_SITES= CPAN
MASTER_SITE_SUBDIR= CPAN:PJACKLAM
diff --git a/math/p5-Math-BigInt/files/patch-lib_Math_BigInt.pm b/math/p5-Math-BigInt/files/patch-lib_Math_BigInt.pm
new file mode 100644
index 000000000000..819dd392e960
--- /dev/null
+++ b/math/p5-Math-BigInt/files/patch-lib_Math_BigInt.pm
@@ -0,0 +1,11 @@
+--- lib/Math/BigInt.pm.orig 2016-02-07 17:28:38 UTC
++++ lib/Math/BigInt.pm
+@@ -65,7 +65,7 @@ use overload
+ '>>=' => sub { $_[0]->brsft($_[1]); },
+
+ # not supported by Perl yet
+-'..' => \&_pointpoint,
++#'..' => \&_pointpoint,
+
+ '<=>' => sub { my $rc = $_[2] ?
+ ref($_[0])->bcmp($_[1],$_[0]) :