aboutsummaryrefslogtreecommitdiffstats
path: root/misc/amanda-server/Makefile
diff options
context:
space:
mode:
authorjeh <jeh@FreeBSD.org>2002-09-17 19:45:59 +0800
committerjeh <jeh@FreeBSD.org>2002-09-17 19:45:59 +0800
commita795b50196ea9f8da645303fed260e8f90efedc7 (patch)
tree9541659dff0acf47cdaa8176cb305508ba4c6c38 /misc/amanda-server/Makefile
parent7e532270553fe4db8a5225bcc0cbd96e5b26a30a (diff)
downloadfreebsd-ports-gnome-a795b50196ea9f8da645303fed260e8f90efedc7.tar.gz
freebsd-ports-gnome-a795b50196ea9f8da645303fed260e8f90efedc7.tar.zst
freebsd-ports-gnome-a795b50196ea9f8da645303fed260e8f90efedc7.zip
Currently the gnutar-listdir is defaulting to
/usr/local/var/amanda/gnutar-listdir, which is ugly and just plain wrong! This allows the user to select it via AMANDA_GNUTAR_LISTDIR at compile time. There is no PORTREVISION bump, because there is no change unless this is specified. Submitted by: Josef Karthauser <joe@FreeBSD.org>
Diffstat (limited to 'misc/amanda-server/Makefile')
-rw-r--r--misc/amanda-server/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/misc/amanda-server/Makefile b/misc/amanda-server/Makefile
index 3b07f3a14120..2b0852c3b031 100644
--- a/misc/amanda-server/Makefile
+++ b/misc/amanda-server/Makefile
@@ -119,6 +119,9 @@ pre-fetch:
@${ECHO} " The default is `uname -n`"
@${ECHO} " AMANDA_CONFIG=config to specify the default configuation"
@${ECHO} " The default is user"
+ @${ECHO} " AMANDA_GNUTAR_LISTDIR=dir to specify the directory that"
+ @${ECHO} " the gnutar index files should live in"
+ @${ECHO} " The default is /var/amanda/gnutar-lists"
@${ECHO} ""
CONFIGURE_ARGS= --libexecdir=${PREFIX}/libexec/amanda \
@@ -152,6 +155,10 @@ CONFIGURE_ARGS+= --with-tape-server=${AMANDA_SERVER}
CONFIGURE_ARGS+= --with-config=${AMANDA_CONFIG}
.endif
+.if defined (AMANDA_GNUTAR_LISTDIR)
+CONFIGURE_ARGS+= --with-gnutar-listdir=${AMANDA_GNUTAR_LISTDIR}
+.endif
+
.endif
.include <bsd.port.post.mk>