aboutsummaryrefslogtreecommitdiffstats
path: root/misc/bogosort/files
diff options
context:
space:
mode:
authorroam <roam@FreeBSD.org>2004-08-11 21:57:27 +0800
committerroam <roam@FreeBSD.org>2004-08-11 21:57:27 +0800
commit80a812413c8bb6b25d00e6e93cad940e5d391dd6 (patch)
treea72ddeddbb34102baed74903d7921ac5f5432de9 /misc/bogosort/files
parent837216f1614f6545a93c41420e9ee96cdd7d7086 (diff)
downloadfreebsd-ports-gnome-80a812413c8bb6b25d00e6e93cad940e5d391dd6.tar.gz
freebsd-ports-gnome-80a812413c8bb6b25d00e6e93cad940e5d391dd6.tar.zst
freebsd-ports-gnome-80a812413c8bb6b25d00e6e93cad940e5d391dd6.zip
A whole lotta fixes:
- fix build with gcc-3.4; - fix sortedp.c and zbogotest to handle empty files properly; - add a 'test' target; - use INFO and PLIST_FILES and nuke pkg-plist. And yes, I know that adding HAVE_STRING_H to config.h.in is somewhat hackish; the proper fix - a string.h check in configure.in - is on its way to the bogosort developers :)
Diffstat (limited to 'misc/bogosort/files')
-rw-r--r--misc/bogosort/files/patch-config.h.in7
-rw-r--r--misc/bogosort/files/patch-sortedp.c11
-rw-r--r--misc/bogosort/files/patch-xmalloc.c24
3 files changed, 42 insertions, 0 deletions
diff --git a/misc/bogosort/files/patch-config.h.in b/misc/bogosort/files/patch-config.h.in
new file mode 100644
index 000000000000..f9227f0c1a70
--- /dev/null
+++ b/misc/bogosort/files/patch-config.h.in
@@ -0,0 +1,7 @@
+--- config.h.in.orig Wed Aug 11 16:11:07 2004
++++ config.h.in Wed Aug 11 16:11:13 2004
+@@ -51,3 +51,4 @@
+ /* Version number of package */
+ #undef VERSION
+
++#define HAVE_STRING_H 1
diff --git a/misc/bogosort/files/patch-sortedp.c b/misc/bogosort/files/patch-sortedp.c
new file mode 100644
index 000000000000..bdea40dd489f
--- /dev/null
+++ b/misc/bogosort/files/patch-sortedp.c
@@ -0,0 +1,11 @@
+--- sortedp.c.orig Wed Aug 11 15:30:34 2004
++++ sortedp.c Wed Aug 11 15:30:49 2004
+@@ -38,6 +38,8 @@
+ {
+ int i;
+
++ if (lines[0] == NULL)
++ return 1;
+ for (i = 1; lines[i] != NULL; i++)
+ if (strcmp(lines[i - 1], lines[i]) > 0)
+ return 0;
diff --git a/misc/bogosort/files/patch-xmalloc.c b/misc/bogosort/files/patch-xmalloc.c
new file mode 100644
index 000000000000..0a6c6581e450
--- /dev/null
+++ b/misc/bogosort/files/patch-xmalloc.c
@@ -0,0 +1,24 @@
+--- xmalloc.c.orig Wed Aug 11 15:25:47 2004
++++ xmalloc.c Wed Aug 11 15:26:35 2004
+@@ -54,6 +54,8 @@
+ # define EXIT_FAILURE 1
+ #endif
+
++#include "system.h"
++
+ /* Prototypes for functions defined here. */
+ #if defined (__STDC__) && __STDC__
+ static VOID *fixup_null_alloc (size_t n);
+@@ -67,12 +69,6 @@
+ /* Exit value when the requested amount of memory is not available.
+ The caller may set it to some other value. */
+ int xmalloc_exit_failure = EXIT_FAILURE;
+-
+-#if __STDC__ && (HAVE_VPRINTF || HAVE_DOPRNT)
+-void error (int, int, const char *, ...);
+-#else
+-void error ();
+-#endif
+
+ static VOID *
+ fixup_null_alloc (n)