aboutsummaryrefslogtreecommitdiffstats
path: root/misc/boxes
diff options
context:
space:
mode:
authormharo <mharo@FreeBSD.org>2000-04-03 07:56:28 +0800
committermharo <mharo@FreeBSD.org>2000-04-03 07:56:28 +0800
commitda1002b5c1fd81f59c23ee3130a3ad744fcbbd82 (patch)
treeda5996fa4a222196e562267c8c39dc73fc5de19f /misc/boxes
parentee03bd5f3cd37c9a41be131558535c73472e4e58 (diff)
downloadfreebsd-ports-gnome-da1002b5c1fd81f59c23ee3130a3ad744fcbbd82.tar.gz
freebsd-ports-gnome-da1002b5c1fd81f59c23ee3130a3ad744fcbbd82.tar.zst
freebsd-ports-gnome-da1002b5c1fd81f59c23ee3130a3ad744fcbbd82.zip
Add boxes, a text filter which draws ASCII art boxes around text.
PR: 17327 Submitted by: Patrick Seal <patseal@hyperhost.net>
Diffstat (limited to 'misc/boxes')
-rw-r--r--misc/boxes/Makefile30
-rw-r--r--misc/boxes/distinfo1
-rw-r--r--misc/boxes/pkg-comment1
-rw-r--r--misc/boxes/pkg-descr17
-rw-r--r--misc/boxes/pkg-plist3
5 files changed, 52 insertions, 0 deletions
diff --git a/misc/boxes/Makefile b/misc/boxes/Makefile
new file mode 100644
index 000000000000..cde5825a1a26
--- /dev/null
+++ b/misc/boxes/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: boxes
+# Version required: 1.0
+# Date created: 3 March 2000
+# Whom: Patrick Seal (patseal@hyperhost.net)
+#
+# $FreeBSD$
+#
+
+DISTNAME= boxes-1.0
+CATEGORIES= misc
+MASTER_SITES= http://www6.informatik.uni-erlangen.de/~tsjensen/software/boxes/download/ \
+ ${MASTER_SITE_SUNSITE}
+MASTER_SITE_SUBDIR= utils/text
+EXTRACT_SUFX= .src.tar.gz
+
+MAINTAINER= patseal@hyperhost.net
+
+MAN1= boxes.1
+USE_GMAKE= yes
+
+do-build:
+ cd $(WRKSRC); $(GMAKE)
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/boxes ${PREFIX}/bin
+ ${MKDIR} ${PREFIX}/share/boxes
+ ${INSTALL_DATA} ${WRKSRC}/boxes-config ${PREFIX}/share/boxes
+ ${INSTALL_MAN} ${WRKSRC}/doc/$(MAN1) ${PREFIX}/man/man1
+
+.include <bsd.port.mk>
diff --git a/misc/boxes/distinfo b/misc/boxes/distinfo
new file mode 100644
index 000000000000..e9bc0b0adc6e
--- /dev/null
+++ b/misc/boxes/distinfo
@@ -0,0 +1 @@
+MD5 (boxes-1.0.src.tar.gz) = fce851c773342ea80cb746ca917448e5
diff --git a/misc/boxes/pkg-comment b/misc/boxes/pkg-comment
new file mode 100644
index 000000000000..86383186b009
--- /dev/null
+++ b/misc/boxes/pkg-comment
@@ -0,0 +1 @@
+Boxes is a text filter which draws ASCII art boxes around text
diff --git a/misc/boxes/pkg-descr b/misc/boxes/pkg-descr
new file mode 100644
index 000000000000..db21a5ca7bf6
--- /dev/null
+++ b/misc/boxes/pkg-descr
@@ -0,0 +1,17 @@
+ /*********************/
+ boxes draws any /* boxes draws any */
+ kind of boxes ===> /* kind of boxes */
+ around your text! /* around your text! */
+ /*********************/
+
+boxes is a text filter which can draw ASCII art boxes around its input
+text. These boxes may also be removed, even if they have been badly
+damaged by editing of the text inside. Since boxes may be open on any
+side, boxes can also be used to create regional comments in any
+programming language. With the help of an editor macro or mapping,
+damaged boxes can easily be repaired.
+
+WWW: http://www6.informatik.uni-erlangen.de/~tsjensen/boxes/
+
+- Patrick
+patseal@hyperhost.net
diff --git a/misc/boxes/pkg-plist b/misc/boxes/pkg-plist
new file mode 100644
index 000000000000..d85e62d21281
--- /dev/null
+++ b/misc/boxes/pkg-plist
@@ -0,0 +1,3 @@
+bin/boxes
+share/boxes/boxes-config
+@dirrm share/boxes