aboutsummaryrefslogtreecommitdiffstats
path: root/misc/cdcollect
diff options
context:
space:
mode:
authorRomain Tartière <romain@FreeBSD.org>2011-06-13 03:06:25 +0800
committerRomain Tartière <romain@FreeBSD.org>2011-06-13 03:06:25 +0800
commite62990bc203f17dc309d9ee4aeaa6b56a23a2fe0 (patch)
treec51cf11179114c316bacd488d1b0fa34059d925b /misc/cdcollect
parentf884f9fa5ee7ab8faeb6cba2670939473825bfd0 (diff)
downloadfreebsd-ports-gnome-e62990bc203f17dc309d9ee4aeaa6b56a23a2fe0.tar.gz
freebsd-ports-gnome-e62990bc203f17dc309d9ee4aeaa6b56a23a2fe0.tar.zst
freebsd-ports-gnome-e62990bc203f17dc309d9ee4aeaa6b56a23a2fe0.zip
Hello Mono 2.10!
Main updates ------------ devel/mono-tools 2.6.2 -> 2.10 lang/mono 2.6.7 -> 2.10.2 lang/mono-basic 2.6.2 -> 2.10.2 www/mod_mono 2.6.3 -> 2.10 www/xsp 2.6.5 -> 2.10.2 x11-toolkits/libgdiplus 2.6.7 -> 2.10 Other updates ------------- deskutils/tomboy 1.4.2 -> 1.6.1 devel/mono-addins 0.5 -> 0.6.1 devel/monodevelop 2.4 -> 2.4.2 graphics/f-spot 0.8.0 -> 0.8.2 print/pdfmod 0.9.0 -> 0.9.1 x11-toolkits/gnome-sharp20 2.24.1 -> 2.24.2 Ports marked BROKEN ------------------- multimedia/banshee multimedia/moonlight PR: ports/155948 Submitted by: me
Diffstat (limited to 'misc/cdcollect')
-rw-r--r--misc/cdcollect/Makefile8
-rw-r--r--misc/cdcollect/files/patch-src_DBsql.cs19
2 files changed, 27 insertions, 0 deletions
diff --git a/misc/cdcollect/Makefile b/misc/cdcollect/Makefile
index d3d4f1623799..d689757819b2 100644
--- a/misc/cdcollect/Makefile
+++ b/misc/cdcollect/Makefile
@@ -25,4 +25,12 @@ GCONF_SCHEMAS= cdcollect.schemas
USE_GETTEXT= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
+post-extract:
+ ${REINPLACE_CMD} -e 's,SqliteClient,Sqlite,' \
+ ${WRKSRC}/src/Makefile.in \
+ ${WRKSRC}/src/CDIcon.cs \
+ ${WRKSRC}/src/CDItem.cs \
+ ${WRKSRC}/src/CompPluginWindow.cs \
+ ${WRKSRC}/src/DBsql.cs
+
.include <bsd.port.mk>
diff --git a/misc/cdcollect/files/patch-src_DBsql.cs b/misc/cdcollect/files/patch-src_DBsql.cs
new file mode 100644
index 000000000000..8fb253b77e7d
--- /dev/null
+++ b/misc/cdcollect/files/patch-src_DBsql.cs
@@ -0,0 +1,19 @@
+
+$FreeBSD$
+
+--- src/DBsql.cs.orig
++++ src/DBsql.cs
+@@ -958,10 +958,10 @@
+ private int sql_command_id (string comm)
+ {
+ IDbCommand command = sqlite_connection.CreateCommand ();
+- command.CommandText = comm;
+- command.ExecuteScalar ();
++ command.CommandText = comm + "; SELECT last_insert_rowid() AS [ID]";
++ string s = command.ExecuteScalar ().ToString ();
+ command.Dispose ();
+- return (((SqliteConnection)sqlite_connection).LastInsertRowId);
++ return Int32.Parse (s);
+ }
+
+ private void sql_command (string comm)