aboutsummaryrefslogtreecommitdiffstats
path: root/misc/dahdi
diff options
context:
space:
mode:
authorfjoe <fjoe@FreeBSD.org>2010-03-03 21:11:47 +0800
committerfjoe <fjoe@FreeBSD.org>2010-03-03 21:11:47 +0800
commitb0039e2d9e9cffd65613903a5b025b9204de6f71 (patch)
treee895c559cda10c4d96462f1a80627c4504d4dca9 /misc/dahdi
parent37233dca241ad03a916e33dc68671e37c555c1dd (diff)
downloadfreebsd-ports-gnome-b0039e2d9e9cffd65613903a5b025b9204de6f71.tar.gz
freebsd-ports-gnome-b0039e2d9e9cffd65613903a5b025b9204de6f71.tar.zst
freebsd-ports-gnome-b0039e2d9e9cffd65613903a5b025b9204de6f71.zip
- Remove overdebug.
- Mute ${REINPLACE_CMD} - Fix zaptel -> dahdi typo Feature safe: yes
Diffstat (limited to 'misc/dahdi')
-rw-r--r--misc/dahdi/Makefile5
-rw-r--r--misc/dahdi/files/patch-freebsd-drivers-dahdi-wct4xxp-base.c18
2 files changed, 21 insertions, 2 deletions
diff --git a/misc/dahdi/Makefile b/misc/dahdi/Makefile
index 3a194c0de06b..bde17b751bb6 100644
--- a/misc/dahdi/Makefile
+++ b/misc/dahdi/Makefile
@@ -7,6 +7,7 @@
PORTNAME= dahdi
PORTVERSION= ${DAHDI_VERSION:S/-//g}
+PORTREVISION= 1
CATEGORIES= misc kld
MASTER_SITES= ${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= fjoe
@@ -42,13 +43,13 @@ MAN8= dahdi_cfg.8\
pre-everything::
@if [ ! -f /usr/src/sys/Makefile ]; then \
- ${ECHO_MSG} ">> The zaptel port needs FreeBSD kernel source code to compile."; \
+ ${ECHO_MSG} ">> The dahdi port needs FreeBSD kernel source code to compile."; \
${ECHO_MSG} ">> Please install FreeBSD kernel source code in /usr/src/sys."; \
${FALSE}; \
fi
post-patch:
- ${REINPLACE_CMD} -e 's,/etc,${PREFIX}/etc,g'\
+ @${REINPLACE_CMD} -e 's,/etc,${PREFIX}/etc,g'\
${WRKSRC}/tools/dahdi_cfg.c ${WRKSRC}/tools/fxotune.c\
${WRKSRC}/tools/doc/dahdi_cfg.8 ${WRKSRC}/tools/doc/fxotune.8
diff --git a/misc/dahdi/files/patch-freebsd-drivers-dahdi-wct4xxp-base.c b/misc/dahdi/files/patch-freebsd-drivers-dahdi-wct4xxp-base.c
new file mode 100644
index 000000000000..3838d69fb38f
--- /dev/null
+++ b/misc/dahdi/files/patch-freebsd-drivers-dahdi-wct4xxp-base.c
@@ -0,0 +1,18 @@
+--- freebsd/drivers/dahdi/wct4xxp/base.c.orig 2010-03-03 19:04:37.000000000 +0600
++++ freebsd/drivers/dahdi/wct4xxp/base.c 2010-03-03 19:04:51.000000000 +0600
+@@ -3070,7 +3070,6 @@
+ {
+ struct t4 *wc = (struct t4 *)data;
+
+- DPRINTF(wc->dev, "%s\n", __FUNCTION__);
+ #ifdef VPM_SUPPORT
+ if (wc->vpm) {
+ if (test_and_clear_bit(T4_CHECK_VPM, &wc->checkflag)) {
+@@ -3214,7 +3213,6 @@
+ res = FILTER_HANDLED;
+ #endif
+ if (unlikely(test_bit(T4_CHECK_VPM, &wc->checkflag))) {
+- DPRINTF(wc->dev, "scheduling filter thread\n");
+ #if defined(__FreeBSD__)
+ res |= FILTER_SCHEDULE_THREAD;
+ #else