aboutsummaryrefslogtreecommitdiffstats
path: root/misc/excel-writer
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2014-04-01 01:47:01 +0800
committermarino <marino@FreeBSD.org>2014-04-01 01:47:01 +0800
commit667195028ad625241eb70403bb428dc9cbfa4d8a (patch)
treed2fe930693afc169e63e7e0a11beb6cd029fe463 /misc/excel-writer
parentcc8d13b5966ab7bfa98fca0f6e8d82a88902429e (diff)
downloadfreebsd-ports-gnome-667195028ad625241eb70403bb428dc9cbfa4d8a.tar.gz
freebsd-ports-gnome-667195028ad625241eb70403bb428dc9cbfa4d8a.tar.zst
freebsd-ports-gnome-667195028ad625241eb70403bb428dc9cbfa4d8a.zip
misc/excel-writer: Upgrade version 11 -> 12
Diffstat (limited to 'misc/excel-writer')
-rw-r--r--misc/excel-writer/Makefile10
-rw-r--r--misc/excel-writer/distinfo4
-rw-r--r--misc/excel-writer/files/example.gpr2
-rw-r--r--misc/excel-writer/files/runme.sh.in4
4 files changed, 10 insertions, 10 deletions
diff --git a/misc/excel-writer/Makefile b/misc/excel-writer/Makefile
index 28d8eab64835..28586b979857 100644
--- a/misc/excel-writer/Makefile
+++ b/misc/excel-writer/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= excel-writer
-PORTVERSION= 11
+PORTVERSION= 12
CATEGORIES= misc
MASTER_SITES= http://sourceforge.net/projects/${SFPATH}/
DISTNAME= excel_writer_${PORTVERSION}
@@ -16,7 +16,7 @@ USES= ada zip dos2unix
SFPATH= excel-writer/files/excel-writer
WRKSRC= ${WRKDIR}/Excel_Writer
PORTDOCS= excel_writer.txt
-PORTEXAMPLES= example.gpr excel_out_test.adb runme.sh
+PORTEXAMPLES= example.gpr excel_out_demo.adb runme.sh
OPTIONS_DEFINE= DOCS EXAMPLES
@@ -25,7 +25,7 @@ OPTIONS_DEFINE= DOCS EXAMPLES
post-extract:
${CP} ${FILESDIR}/construct.gpr ${FILESDIR}/biff_dump.gpr ${WRKSRC}
${MKDIR} ${WRKSRC}/src ${WRKDIR}/data
- ${MV} ${WRKSRC}/Big.xls ${WRKDIR}/data
+ ${MV} "${WRKSRC}/Big [BIFF3].xls" ${WRKDIR}/data/Big.xls
(cd ${WRKSRC}; ${MV} excel_out.ad[bs] ieee* extras/csv.* src)
${SED} -e "s,@PREFIX@,${LOCALBASE},g" ${FILESDIR}/runme.sh.in \
> ${WRKSRC}/runme.sh
@@ -34,7 +34,7 @@ post-patch:
@${REINPLACE_CMD} -e "s|Big.xls|${DATADIR}/Big.xls|" \
-e 's|\$$Dump\$$|_dump_|g' ${WRKSRC}/extras/biff_dump.adb
${REINPLACE_CMD} -e 's/"\(.*\.xls\)"/"\/tmp\/\1"/g' \
- ${WRKSRC}/excel_out_test.adb
+ ${WRKSRC}/excel_out_demo.adb
do-build:
(cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} gnatmake -p -Pconstruct)
@@ -60,7 +60,7 @@ do-install:
.if ${PORT_OPTIONS:MEXAMPLES}
${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
${INSTALL_SCRIPT} ${WRKSRC}/runme.sh ${STAGEDIR}${EXAMPLESDIR}
- ${INSTALL_DATA} ${WRKSRC}/excel_out_test.adb \
+ ${INSTALL_DATA} ${WRKSRC}/excel_out_demo.adb \
${FILESDIR}/example.gpr ${STAGEDIR}${EXAMPLESDIR}
.endif
diff --git a/misc/excel-writer/distinfo b/misc/excel-writer/distinfo
index 3c95fa7ba8d1..584baf5c9fb5 100644
--- a/misc/excel-writer/distinfo
+++ b/misc/excel-writer/distinfo
@@ -1,2 +1,2 @@
-SHA256 (excel_writer_11.zip) = fef80c7e375800aa4ea601d44be68abe76bbceb313457a1d1f401df018980998
-SIZE (excel_writer_11.zip) = 39706
+SHA256 (excel_writer_12.zip) = f688da19501e0451a3c235ca95875e4e145f56f618135614a216de5dc148467f
+SIZE (excel_writer_12.zip) = 44584
diff --git a/misc/excel-writer/files/example.gpr b/misc/excel-writer/files/example.gpr
index 62837d5167c6..948514e19ada 100644
--- a/misc/excel-writer/files/example.gpr
+++ b/misc/excel-writer/files/example.gpr
@@ -3,7 +3,7 @@ project Example is
for Exec_Dir use "/tmp";
for Object_Dir use "/tmp";
- for Main use ("excel_out_test.adb");
+ for Main use ("excel_out_demo.adb");
package Compiler is
for Default_Switches ("ada") use ("-O2", "-gnat05");
diff --git a/misc/excel-writer/files/runme.sh.in b/misc/excel-writer/files/runme.sh.in
index 32475de8363a..77928856d45e 100644
--- a/misc/excel-writer/files/runme.sh.in
+++ b/misc/excel-writer/files/runme.sh.in
@@ -11,7 +11,7 @@ export ADA_PROJECT_PATH
${GNATMAKE} -P example
echo
-echo "The source for the example is excel_out_test.adb"
-echo "The executable example is located in /tmp/excel_out_test"
+echo "The source for the example is excel_out_demo.adb"
+echo "The executable example is located in /tmp/excel_out_demo"
echo "It requires no options; just run it"
echo 'You may want to execute "rm /tmp/excel_out*" when you are done.'