aboutsummaryrefslogtreecommitdiffstats
path: root/misc/explosions/Makefile
diff options
context:
space:
mode:
authorlioux <lioux@FreeBSD.org>2001-08-09 01:56:08 +0800
committerlioux <lioux@FreeBSD.org>2001-08-09 01:56:08 +0800
commit8fc8d79403e4a26b283fd2f0387187c2057281e4 (patch)
treeb7ee0a6d5e0f2ceb44367735f725ad1e1c67777a /misc/explosions/Makefile
parent8c7aec6892c73109d5a0f7ecb17fd1b175047a4c (diff)
downloadfreebsd-ports-gnome-8fc8d79403e4a26b283fd2f0387187c2057281e4.tar.gz
freebsd-ports-gnome-8fc8d79403e4a26b283fd2f0387187c2057281e4.tar.zst
freebsd-ports-gnome-8fc8d79403e4a26b283fd2f0387187c2057281e4.zip
New port explosions version 0.2001.08.05: 3D objects flying around
resembling explosions with various effects. Submitted by: Pete Fritchman <petef@databits.net>
Diffstat (limited to 'misc/explosions/Makefile')
-rw-r--r--misc/explosions/Makefile42
1 files changed, 42 insertions, 0 deletions
diff --git a/misc/explosions/Makefile b/misc/explosions/Makefile
new file mode 100644
index 000000000000..835811836c42
--- /dev/null
+++ b/misc/explosions/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: explosions
+# Date created: 8 August 2001
+# Whom: Pete Fritchman <petef@databits.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= explosions
+PORTVERSION= 0.2001.08.05
+CATEGORIES= misc
+MASTER_SITES= ftp://ftp.sonic.net/pub/users/nbs/unix/x/explosions/
+DISTNAME= ${PORTNAME}-${PORTVERSION:S/^0.//}
+
+MAINTAINER= petef@databits.net
+
+LIB_DEPENDS= SDL-1.1.3:${PORTSDIR}/devel/sdl12 \
+ SDL_image.10:${PORTSDIR}/graphics/sdl_image
+
+USE_GMAKE= yes
+USE_X_PREFIX= yes
+
+SDL_CONFIG= ${LOCALBASE}/bin/sdl11-config
+
+post-patch:
+ @${PERL} -pi -e 's!CFLAGS=-Wall -O2!CFLAGS+=-Wall!; \
+ s!sdl-config!${SDL_CONFIG}!' \
+ ${WRKSRC}/Makefile
+ @${PERL} -pi -e 's!spark%d.png!${DATADIR}/spark%d.png!' \
+ ${WRKSRC}/explosions.c
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/explosions ${PREFIX}/bin
+ @${MKDIR} ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/spark?.png ${DATADIR}
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for file in BUGS.txt CHANGES.txt README.txt
+ ${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>