aboutsummaryrefslogtreecommitdiffstats
path: root/misc/granulate
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2001-02-18 01:13:39 +0800
committerijliao <ijliao@FreeBSD.org>2001-02-18 01:13:39 +0800
commit7c3694dfbc21cc407c7319c49eb7f1dda4214467 (patch)
tree1f7878b0e2b2bacc8c0977a2642ab40b2d9bd8f8 /misc/granulate
parent9bd4d8a3a3f2e610aea128c380eb60c3712d31e2 (diff)
downloadfreebsd-ports-gnome-7c3694dfbc21cc407c7319c49eb7f1dda4214467.tar.gz
freebsd-ports-gnome-7c3694dfbc21cc407c7319c49eb7f1dda4214467.tar.zst
freebsd-ports-gnome-7c3694dfbc21cc407c7319c49eb7f1dda4214467.zip
add granulate, a program for splitting files in place
Diffstat (limited to 'misc/granulate')
-rw-r--r--misc/granulate/Makefile19
-rw-r--r--misc/granulate/distinfo1
-rw-r--r--misc/granulate/pkg-comment1
-rw-r--r--misc/granulate/pkg-descr6
-rw-r--r--misc/granulate/pkg-plist1
5 files changed, 28 insertions, 0 deletions
diff --git a/misc/granulate/Makefile b/misc/granulate/Makefile
new file mode 100644
index 000000000000..88ed6b5f2d3e
--- /dev/null
+++ b/misc/granulate/Makefile
@@ -0,0 +1,19 @@
+# ex:ts=8
+# New ports collection makefile for: granulate
+# Date created: Feb 17, 2001
+# Whom: Ying-Chieh Liao <ijliao@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= granulate
+PORTVERSION= 0.1
+CATEGORIES= misc
+MASTER_SITES= ftp://134.74.16.12/pub/
+
+MAINTAINER= ijliao@FreeBSD.org
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/misc/granulate/distinfo b/misc/granulate/distinfo
new file mode 100644
index 000000000000..99b8a6204115
--- /dev/null
+++ b/misc/granulate/distinfo
@@ -0,0 +1 @@
+MD5 (granulate-0.1.tar.gz) = e4500c32f3013f8e5bb78f7815e35a79
diff --git a/misc/granulate/pkg-comment b/misc/granulate/pkg-comment
new file mode 100644
index 000000000000..e365e64cf651
--- /dev/null
+++ b/misc/granulate/pkg-comment
@@ -0,0 +1 @@
+Granulate is a program for splitting files in place
diff --git a/misc/granulate/pkg-descr b/misc/granulate/pkg-descr
new file mode 100644
index 000000000000..87512afcdc49
--- /dev/null
+++ b/misc/granulate/pkg-descr
@@ -0,0 +1,6 @@
+Granulate is a program for splitting files in place. The program
+serves a purpose similar to the standard UNIX split, but differs in
+one important way. For split to operate on a 40MB file, you must have
+more than 40MB of free space on the disk. On the other hand,
+granulate only needs one chunk of free space on the hard drive, where
+a chunk is the requested size for the output files.
diff --git a/misc/granulate/pkg-plist b/misc/granulate/pkg-plist
new file mode 100644
index 000000000000..f55726d87c62
--- /dev/null
+++ b/misc/granulate/pkg-plist
@@ -0,0 +1 @@
+bin/granulate