aboutsummaryrefslogtreecommitdiffstats
path: root/misc/gretl/Makefile
diff options
context:
space:
mode:
authornaddy <naddy@FreeBSD.org>2003-04-29 06:52:48 +0800
committernaddy <naddy@FreeBSD.org>2003-04-29 06:52:48 +0800
commita12442efe01cc26ba8acb955a2ae754c671d77ea (patch)
treebe5a0fedec70e632f529ce67134e0a1c8958f5a7 /misc/gretl/Makefile
parentca37f412437d0b0ec96d1b33552a056daf812a38 (diff)
downloadfreebsd-ports-gnome-a12442efe01cc26ba8acb955a2ae754c671d77ea.tar.gz
freebsd-ports-gnome-a12442efe01cc26ba8acb955a2ae754c671d77ea.tar.zst
freebsd-ports-gnome-a12442efe01cc26ba8acb955a2ae754c671d77ea.zip
Merge in remaining changes from
PR: 51233 Submitted by: Ports Fury
Diffstat (limited to 'misc/gretl/Makefile')
-rw-r--r--misc/gretl/Makefile18
1 files changed, 11 insertions, 7 deletions
diff --git a/misc/gretl/Makefile b/misc/gretl/Makefile
index bda9fa6e65a2..f2362325e1fb 100644
--- a/misc/gretl/Makefile
+++ b/misc/gretl/Makefile
@@ -22,8 +22,9 @@ RUN_DEPENDS= gnuplot:${PORTSDIR}/math/gnuplot
USE_BZIP2= yes
USE_X_PREFIX= yes
-USE_GNOME= gtk20 libxml2
USE_GMAKE= yes
+WANT_GNOME= yes
+USE_GNOME= gtk20 libxml2
USE_AUTOCONF_VER= 253
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
@@ -33,12 +34,15 @@ INSTALLS_SHLIB= yes
MAN1= gretl.1 gretl-config.1
-.if defined(WITHOUT_GNOME2)
-CONFIGURE_ARGS+= --without-gnome
-PLIST_SUB+= GNOME2:="@comment " DATADIR="share"
+.include <bsd.port.pre.mk>
+
+.if ${HAVE_GNOME:Mlibgnomeui}!=""
+PKGNAMESUFFIX= -gnome
+USE_GNOME+= gnomeprefix libgnomeprintui
+PLIST_SUB+= GRETLDATADIR="share/gnome"
.else
-USE_GNOME+= gnomeprefix libgnomeprintui libgnomeui
-PLIST_SUB+= GNOME2:="" DATADIR="share/gnome"
+CONFIGURE_ARGS+= --without-gnome
+PLIST_SUB+= GRETLDATADIR="share"
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>