aboutsummaryrefslogtreecommitdiffstats
path: root/misc/ipbt
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2014-02-26 18:00:45 +0800
committerehaupt <ehaupt@FreeBSD.org>2014-02-26 18:00:45 +0800
commit3a2ebe91b19dde992b4bd0bfb72cac2c0931216a (patch)
treec3ac5e0b79f0922036f18bfcbb412a26c83d95ba /misc/ipbt
parentca7b47b8832a637cbb02b98d3747e0b65cb36df3 (diff)
downloadfreebsd-ports-gnome-3a2ebe91b19dde992b4bd0bfb72cac2c0931216a.tar.gz
freebsd-ports-gnome-3a2ebe91b19dde992b4bd0bfb72cac2c0931216a.tar.zst
freebsd-ports-gnome-3a2ebe91b19dde992b4bd0bfb72cac2c0931216a.zip
- Support staging
- Use shebangfix
Diffstat (limited to 'misc/ipbt')
-rw-r--r--misc/ipbt/Makefile22
1 files changed, 8 insertions, 14 deletions
diff --git a/misc/ipbt/Makefile b/misc/ipbt/Makefile
index 330d1dc988eb..123c2e512fad 100644
--- a/misc/ipbt/Makefile
+++ b/misc/ipbt/Makefile
@@ -5,28 +5,22 @@ PORTNAME= ipbt
DISTVERSION= r8765
CATEGORIES= misc
MASTER_SITES= http://www.chiark.greenend.org.uk/~sgtatham/ipbt/ \
- ${MASTER_SITE_LOCAL}
+ LOCAL
MASTER_SITE_SUBDIR= uqs
MAINTAINER= uqs@FreeBSD.org
COMMENT= A high-tech ttyrec player with improvements over ttyplay
-MAN1= ipbt.1
-
-USES= perl5
+USES= perl5 shebangfix
ALL_TARGET= ${PORTNAME}
-PLIST_FILES= bin/ipbt bin/ttygrep bin/ttydump
-
-NO_STAGE= yes
-post-patch:
- @${REINPLACE_CMD} -e '1s|.*|#!${PERL} -w|' ${WRKSRC}/sbcsgen.pl
- @${REINPLACE_CMD} -e 's|perl|${PERL}|' ${WRKSRC}/${MAKEFILE}
+PLIST_FILES= bin/ipbt bin/ttygrep bin/ttydump man/man1/ipbt.1.gz
+SHEBANG_FILES= sbcsgen.pl Makefile ttygrep ttydump
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
- ${INSTALL_SCRIPT} ${WRKSRC}/ttydump ${PREFIX}/bin
- ${INSTALL_SCRIPT} ${WRKSRC}/ttygrep ${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/ipbt.1 ${PREFIX}/man/man1
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/ttydump ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/ttygrep ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/ipbt.1 ${STAGEDIR}${MANPREFIX}/man/man1
.include <bsd.port.mk>