aboutsummaryrefslogtreecommitdiffstats
path: root/misc/kbdscan/Makefile
diff options
context:
space:
mode:
authorjacula <jacula@FreeBSD.org>2010-08-03 21:45:22 +0800
committerjacula <jacula@FreeBSD.org>2010-08-03 21:45:22 +0800
commited9e706f87d69870493f56db1bd6775ed17238ad (patch)
tree010bc0754abf59d5f656baa60082ab74948a0a60 /misc/kbdscan/Makefile
parent761cb724abdb348991bc8df7f47ca91773c77ee2 (diff)
downloadfreebsd-ports-gnome-ed9e706f87d69870493f56db1bd6775ed17238ad.tar.gz
freebsd-ports-gnome-ed9e706f87d69870493f56db1bd6775ed17238ad.tar.zst
freebsd-ports-gnome-ed9e706f87d69870493f56db1bd6775ed17238ad.zip
kbdscan is a small program to set the FreeBSD console keyboard in
raw scancode mode and show scancodes of keys pressed and released. Five seconds of inactivity resets the console to the original mode and quits the program. WWW: http://hack.org/mc/hacks/kbdscan/ PR: ports/146010 Submitted by: Eitan Adler <EitanAdlerList@gmail.com> Approved by: pgj (mentor)
Diffstat (limited to 'misc/kbdscan/Makefile')
-rw-r--r--misc/kbdscan/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/misc/kbdscan/Makefile b/misc/kbdscan/Makefile
new file mode 100644
index 000000000000..9793087a6c7d
--- /dev/null
+++ b/misc/kbdscan/Makefile
@@ -0,0 +1,31 @@
+# ex:ts=8
+# Ports collection makefile for: kbdscan
+# Date created: April 23, 2010
+# Whom: Eitan Adler
+#
+# $FreeBSD$
+#
+
+PORTNAME= kbdscan
+PORTVERSION= 20100427
+CATEGORIES= misc
+MASTER_SITES= http://hack.org/mc/hacks/${PORTNAME}/
+
+MAINTAINER= eitanadlerlist@gmail.com
+COMMENT= Kbdscan shows the scancodes of keys pressed
+
+USE_BZIP2= yes
+
+LICENSE= ISC
+LICENSE_NAME= ISC License - ISCL
+LICENSE_GROUPS= FSF GPL OSI
+LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
+# cut and paste the text from kbdscan.c
+LICENSE_FILE= ${FILESDIR}/LICENSE-kbdscan
+
+PLIST_FILES= bin/${PORTNAME}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/
+
+.include <bsd.port.mk>