aboutsummaryrefslogtreecommitdiffstats
path: root/misc/kcd
diff options
context:
space:
mode:
authorkris <kris@FreeBSD.org>2006-03-11 09:19:17 +0800
committerkris <kris@FreeBSD.org>2006-03-11 09:19:17 +0800
commit962193613f858175483cc86f5486fa1d551ed7e3 (patch)
tree32e5624292213522039871f808aa29c86ff82990 /misc/kcd
parent7fd66ba7b5cb3b4fe0ee1ad3d3b743b6ce1bb69e (diff)
downloadfreebsd-ports-gnome-962193613f858175483cc86f5486fa1d551ed7e3.tar.gz
freebsd-ports-gnome-962193613f858175483cc86f5486fa1d551ed7e3.tar.zst
freebsd-ports-gnome-962193613f858175483cc86f5486fa1d551ed7e3.zip
Mark IGNORE on 7.x: the configure script attempts to force a memory
allocation failure by using setrlimit(RLIMIT_DATA, ...) and doing malloc, except malloc no longer uses sbrk() to allocate memory so this ends up running the entire machine out of swap. Approved by: portmgr (implicit)
Diffstat (limited to 'misc/kcd')
-rw-r--r--misc/kcd/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/misc/kcd/Makefile b/misc/kcd/Makefile
index 9c891cebeadd..729f332d988e 100644
--- a/misc/kcd/Makefile
+++ b/misc/kcd/Makefile
@@ -24,6 +24,12 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
MAN1= kcd.1
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} > 700013
+IGNORE= allocates an infinite amount of memory in configure script
+.endif
+
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/kcd-inst ${PREFIX}/bin
${INSTALL_SCRIPT} ${WRKSRC}/kcdscr ${PREFIX}/bin
@@ -42,4 +48,4 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/kcd.sh.init ${EXAMPLESDIR}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>