aboutsummaryrefslogtreecommitdiffstats
path: root/misc/lile
diff options
context:
space:
mode:
authorjmz <jmz@FreeBSD.org>2001-01-24 06:57:24 +0800
committerjmz <jmz@FreeBSD.org>2001-01-24 06:57:24 +0800
commitb6af6eb653f5badf86e507edf2d077369496d8d7 (patch)
treea3ce072100a94fd6458afc1b13e21baa11eaa6f3 /misc/lile
parentefb9f401e4e16d9cdbc16fd8ecc146f8d708e043 (diff)
downloadfreebsd-ports-gnome-b6af6eb653f5badf86e507edf2d077369496d8d7.tar.gz
freebsd-ports-gnome-b6af6eb653f5badf86e507edf2d077369496d8d7.tar.zst
freebsd-ports-gnome-b6af6eb653f5badf86e507edf2d077369496d8d7.zip
The lile port had a couple of issues with process id's
(signed/unsigned int mess ups) and not handling the error when it occurred. Submitted by: Andy Newman <atrn@zeta.org.au>
Diffstat (limited to 'misc/lile')
-rw-r--r--misc/lile/Makefile1
-rw-r--r--misc/lile/files/patch-aa32
2 files changed, 28 insertions, 5 deletions
diff --git a/misc/lile/Makefile b/misc/lile/Makefile
index 44b6455b69ab..30d1748c88cb 100644
--- a/misc/lile/Makefile
+++ b/misc/lile/Makefile
@@ -7,6 +7,7 @@
PORTNAME= ile
PORTVERSION= 2.0
+PORTREVISION= 1
CATEGORIES= misc
MASTER_SITES= ftp://ftp.inria.fr/system/user/
DISTNAME= lile-2.0
diff --git a/misc/lile/files/patch-aa b/misc/lile/files/patch-aa
index d9c70f461f6a..486576b625f3 100644
--- a/misc/lile/files/patch-aa
+++ b/misc/lile/files/patch-aa
@@ -1,6 +1,6 @@
---- ile.c.orig Wed Jun 25 01:54:50 1997
-+++ ile.c Wed Jun 25 01:55:24 1997
-@@ -65,7 +65,7 @@
+--- dist/ile.c Wed Jun 9 13:12:33 1993
++++ ile.c Sat Jan 20 08:23:07 2001
+@@ -51,7 +51,7 @@
#include <errno.h>
#include <sys/ioctl.h>
#include <sys/types.h>
@@ -8,8 +8,8 @@
+#include <sys/dirent.h>
#include <sys/file.h>
#include <sys/time.h>
- /*
-@@ -75,7 +75,6 @@
+ #include <sys/wait.h>
+@@ -63,7 +63,6 @@
/* Definitions of system stuff. */
extern int errno;
@@ -17,3 +17,25 @@
char *malloc();
char *realloc();
time_t time();
+@@ -113,7 +112,7 @@
+ struct ltchars tty_ltchars;
+ struct winsize tty_winsize;
+ int expect_exception, ignorestop, new_prompt, output_complete;
+-int childpid;
++pid_t childpid;
+ int tty_ldisc;
+ int tty_mode;
+
+@@ -269,8 +268,10 @@
+ void handle_child() {
+ union wait status;
+
+- if (wait3(&status, WUNTRACED, NULL) != childpid) {
++ if (wait3(&status.w_status, WUNTRACED, NULL) != childpid) {
+ fprintf(stderr, "ile: notified by unknown process\r\n");
++ /* note the change so that we don't die after select */
++ expect_exception = TRUE;
+ return;
+ }
+
+