aboutsummaryrefslogtreecommitdiffstats
path: root/misc/lxde-common
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2016-06-30 03:33:02 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2016-06-30 03:33:02 +0800
commitd39352dd6f5403dfd3126db2c72ef2b1ce0691cc (patch)
treeb820a954db1525b6ef66c728c47a8ba3a65dae5a /misc/lxde-common
parent5e5c4691d91ba75ef54537f6b5c2662fc44367c1 (diff)
downloadfreebsd-ports-gnome-d39352dd6f5403dfd3126db2c72ef2b1ce0691cc.tar.gz
freebsd-ports-gnome-d39352dd6f5403dfd3126db2c72ef2b1ce0691cc.tar.zst
freebsd-ports-gnome-d39352dd6f5403dfd3126db2c72ef2b1ce0691cc.zip
- Add LICENSE_FILE
- Don't redundantly pass --prefix to GNU configure - Switch to options helpers - Add NO_ARCH - Style fixes
Diffstat (limited to 'misc/lxde-common')
-rw-r--r--misc/lxde-common/Makefile9
1 files changed, 6 insertions, 3 deletions
diff --git a/misc/lxde-common/Makefile b/misc/lxde-common/Makefile
index 79ce19111cec..ddc0b7fd7180 100644
--- a/misc/lxde-common/Makefile
+++ b/misc/lxde-common/Makefile
@@ -11,21 +11,23 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= LXDE Common files
LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
USES= gmake iconv
USE_GNOME= gtk20
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --prefix=${PREFIX} \
- CPPFLAGS="-I${LOCALBASE}/include" \
+CONFIGURE_ARGS= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib" \
GMSGFMT="${LOCALBASE}/bin/msgfmt" \
--with-xsession-path=${PREFIX}/share/xsessions \
--with-xdg-path=${PREFIX}/share/applications
+NO_ARCH= yes
DATADIR= ${PREFIX}/share/lxde
-INSTALLS_ICONS= YES
+INSTALLS_ICONS= yes
PORTDOCS= AUTHORS README
+
OPTIONS_DEFINE= DOCS
post-install:
@@ -34,6 +36,7 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/pcmanfm/pcmanfm.conf \
${STAGEDIR}${PREFIX}/etc/xdg/pcmanfm/LXDE/pcmanfm.conf.sample
+post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}