aboutsummaryrefslogtreecommitdiffstats
path: root/misc/man.el/Makefile
diff options
context:
space:
mode:
authortaoka <taoka@FreeBSD.org>1999-09-07 03:40:54 +0800
committertaoka <taoka@FreeBSD.org>1999-09-07 03:40:54 +0800
commit05f46b4984e534d0ce82492b4dad382185e702ae (patch)
tree31777b0a1ce9fcd57ad3aa9dd606e3f5baa2031b /misc/man.el/Makefile
parentca183df99e8fe888bf6c6b6028e4f4316ecc1ec4 (diff)
downloadfreebsd-ports-gnome-05f46b4984e534d0ce82492b4dad382185e702ae.tar.gz
freebsd-ports-gnome-05f46b4984e534d0ce82492b4dad382185e702ae.tar.zst
freebsd-ports-gnome-05f46b4984e534d0ce82492b4dad382185e702ae.zip
Modified for XEmacs
Added a script to byte-compile PR: 13389 Submitted by: maintainer
Diffstat (limited to 'misc/man.el/Makefile')
-rw-r--r--misc/man.el/Makefile17
1 files changed, 15 insertions, 2 deletions
diff --git a/misc/man.el/Makefile b/misc/man.el/Makefile
index a6a4527d67d9..af55d8d4e0f9 100644
--- a/misc/man.el/Makefile
+++ b/misc/man.el/Makefile
@@ -13,16 +13,29 @@ MASTER_SITES= ftp://daemon.jp.freebsd.org/pub/FreeBSD-jp/man-jp/ \
MAINTAINER= kiri@kiri.toba-cmt.ac.jp
-RUN_DEPENDS= jman:${PORTSDIR}/japanese/man
+# If you use Japanese manuals, install japanese/man as well.
NO_BUILD= yes
WRKSRC= ${WRKDIR}
ELISPDIR= ${PREFIX}/share/emacs/site-lisp
+SITEPKGDIR= ${PREFIX}/lib/xemacs/site-packages
+PKGMODULES= i18n-man-de i18n-man-en i18n-man-ja
do-install:
- @${MKDIR} ${ELISPDIR}
+ @${MKDIR} ${ELISPDIR} ${PREFIX}/share/doc/i18n-man
@cd ${WRKSRC}; \
${INSTALL_DATA} `${TAR} tzf ${DISTDIR}/${DISTFILES}` ${ELISPDIR}
+# For xemacs package install configuration
+ ${MKDIR} ${SITEPKGDIR}/pkginfo
+.for f in ${PKGMODULES}
+ ${MKDIR} ${SITEPKGDIR}/lisp/${f}
+ ${LN} -sf ${ELISPDIR}/${f}.el ${SITEPKGDIR}/lisp/${f}/${f}.el
+ ${LN} -sf ${ELISPDIR}/i18n-man.el ${SITEPKGDIR}/lisp/${f}/i18n-man.el
+ ${ECHO} "pkginfo/MANIFEST.${f}" > ${SITEPKGDIR}/pkginfo/MANIFEST.${f}
+ ${ECHO} "lisp/${f}/${f}.el" >> ${SITEPKGDIR}/pkginfo/MANIFEST.${f}
+ ${ECHO} "lisp/${f}/i18n-man.el" >> ${SITEPKGDIR}/pkginfo/MANIFEST.${f}
+.endfor
+ ${INSTALL_SCRIPT} ${FILESDIR}/byte-compile ${PREFIX}/share/doc/i18n-man
.include <bsd.port.mk>