aboutsummaryrefslogtreecommitdiffstats
path: root/misc/mc
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2015-04-27 20:19:45 +0800
committeradamw <adamw@FreeBSD.org>2015-04-27 20:19:45 +0800
commitf63771873791c007bfb04ec784126b1c7c161a39 (patch)
tree668b540195985a27fbdf5ae2b82e5f4548a90353 /misc/mc
parent2d767d60b504a7a9b7ae24610e61f5b70ec47098 (diff)
downloadfreebsd-ports-gnome-f63771873791c007bfb04ec784126b1c7c161a39.tar.gz
freebsd-ports-gnome-f63771873791c007bfb04ec784126b1c7c161a39.tar.zst
freebsd-ports-gnome-f63771873791c007bfb04ec784126b1c7c161a39.zip
Fix "Cannot create pipe streams" when running shell commands using the Filtered
View menu item on the File menu. PR: 199366 Reported by: Trond.Endrestol@ximalas.info Patch by: Ben Woods (maintainer)
Diffstat (limited to 'misc/mc')
-rw-r--r--misc/mc/Makefile1
-rw-r--r--misc/mc/files/patch-lib_utilunix.c11
2 files changed, 12 insertions, 0 deletions
diff --git a/misc/mc/Makefile b/misc/mc/Makefile
index d5689c49b412..56d45bc6ea2e 100644
--- a/misc/mc/Makefile
+++ b/misc/mc/Makefile
@@ -3,6 +3,7 @@
PORTNAME= mc
PORTVERSION= 4.8.14
+PORTREVISION= 1
CATEGORIES= misc shells
MASTER_SITES= http://ftp.midnight-commander.org/ \
http://ftp.osuosl.org/pub/midnightcommander/ \
diff --git a/misc/mc/files/patch-lib_utilunix.c b/misc/mc/files/patch-lib_utilunix.c
new file mode 100644
index 000000000000..28b94cd2a67c
--- /dev/null
+++ b/misc/mc/files/patch-lib_utilunix.c
@@ -0,0 +1,11 @@
+--- lib/utilunix.c.orig 2015-04-12 03:04:27 UTC
++++ lib/utilunix.c
+@@ -528,7 +528,7 @@ mc_popen (const char *command, GError **
+ goto ret_err;
+ }
+
+- if (!g_spawn_async_with_pipes (NULL, argv, NULL, G_SPAWN_DO_NOT_REAP_CHILD, NULL, NULL,
++ if (!g_spawn_async_with_pipes (NULL, argv, NULL, G_SPAWN_DO_NOT_REAP_CHILD | G_SPAWN_SEARCH_PATH, NULL, NULL,
+ &p->child_pid, NULL, &p->out.fd, &p->err.fd, error))
+ {
+ mc_replace_error (error, MC_PIPE_ERROR_CREATE_PIPE_STREAM, "%s",