aboutsummaryrefslogtreecommitdiffstats
path: root/misc/pinfo
diff options
context:
space:
mode:
authorsperber <sperber@FreeBSD.org>2012-12-01 07:50:02 +0800
committersperber <sperber@FreeBSD.org>2012-12-01 07:50:02 +0800
commitc80553d371b3c85afffb39fd49fa932ee7fcfba5 (patch)
treeda4bbf771f2c1ab82f9260542b2473d8ae10c69a /misc/pinfo
parentd88210f2071c1e77439b05b0172907f1ba333db1 (diff)
downloadfreebsd-ports-gnome-c80553d371b3c85afffb39fd49fa932ee7fcfba5.tar.gz
freebsd-ports-gnome-c80553d371b3c85afffb39fd49fa932ee7fcfba5.tar.zst
freebsd-ports-gnome-c80553d371b3c85afffb39fd49fa932ee7fcfba5.zip
- Update to version 0.6.10
- Add MAKE_JOBS_SAFE - Convert to optionsng PR: ports/170158 Submitted by: KATO Tsuguru <tkato432 _at_ yahoo.com> Approved by: beat (mentor) Feature safe: yes
Diffstat (limited to 'misc/pinfo')
-rw-r--r--misc/pinfo/Makefile46
-rw-r--r--misc/pinfo/distinfo4
-rw-r--r--misc/pinfo/files/patch-src__filehandling_functions.c34
-rw-r--r--misc/pinfo/files/patch-src__manual.c20
-rw-r--r--misc/pinfo/files/patch-src__utils.c76
-rw-r--r--misc/pinfo/files/patch-src__video.c58
-rw-r--r--misc/pinfo/pkg-plist13
7 files changed, 37 insertions, 214 deletions
diff --git a/misc/pinfo/Makefile b/misc/pinfo/Makefile
index 60f434444a7f..da5f15c61767 100644
--- a/misc/pinfo/Makefile
+++ b/misc/pinfo/Makefile
@@ -1,24 +1,32 @@
-# New ports collection makefile for: pinfo
-# Date created: 19 May 1999
-# Whom: Thomas Gellekum <tg@FreeBSD.org>
-#
+# Created by: Thomas Gellekum <tg@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= pinfo
-PORTVERSION= 0.6.9
-PORTREVISION= 4
+PORTVERSION= 0.6.10
CATEGORIES= misc
-MASTER_SITES= http://alioth.debian.org/frs/download.php/1502/
+MASTER_SITES= http://alioth.debian.org/frs/download.php/3351/
MAINTAINER= ports@FreeBSD.org
COMMENT= Ncurses based, lynx style info documentation browser
-GNU_CONFIGURE= yes
+LICENSE= GPLv2
+
+OPTIONS_DEFINE= READLINE
+OPTIONS_DEFAULT=READLINE
+READLINE_DESC= Enable readline support
+
+USE_BZIP2= yes
+USE_NCURSES= yes
+USE_GETTEXT= yes
+USE_AUTOTOOLS= libtoolize aclocal autoheader automake autoconf
+LIBTOOLIZE_ARGS=--force
+ACLOCAL_ARGS= -I macros
+AUTOMAKE_ARGS= --add-missing --force-missing
+CONFIGURE_ARGS= --with-localedir=${PREFIX}/share/locale
+MAKE_JOBS_SAFE= yes
+
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-CONFIGURE_ARGS= --with-readline \
- --with-localedir=${PREFIX}/share/locale
MAN1= pinfo.1
INFO= pinfo
@@ -31,4 +39,20 @@ USE_GETTEXT= yes
PLIST_SUB+= NLS=""
.endif
+PLIST_FILES= bin/pinfo etc/pinforc
+.for lang in cs de eu ja nl pl pt_BR ro ru sv vi
+PLIST_FILES+= %%NLS%%share/locale/${lang}/LC_MESSAGES/pinfo.mo
+.endfor
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MREADLINE}
+USE_READLINE= yes
+.else
+CONFIGURE_ARGS+=--without-readline
+.endif
+
+pre-configure:
+ @(cd ${WRKSRC} && ${LOCALBASE}/bin/autopoint)
+
.include <bsd.port.mk>
diff --git a/misc/pinfo/distinfo b/misc/pinfo/distinfo
index 72ac90c264d7..f770742032f4 100644
--- a/misc/pinfo/distinfo
+++ b/misc/pinfo/distinfo
@@ -1,2 +1,2 @@
-SHA256 (pinfo-0.6.9.tar.gz) = c25f08e115a5e796f40838a28d0e9816c755f4cb9e7bcc77f6d4c9ddaf0a1651
-SIZE (pinfo-0.6.9.tar.gz) = 554213
+SHA256 (pinfo-0.6.10.tar.bz2) = 122180a0c23d11bc9eb569a4de3ff97d3052af96e32466fa62f2daf46ff61c5d
+SIZE (pinfo-0.6.10.tar.bz2) = 133059
diff --git a/misc/pinfo/files/patch-src__filehandling_functions.c b/misc/pinfo/files/patch-src__filehandling_functions.c
deleted file mode 100644
index d23b27b10a7c..000000000000
--- a/misc/pinfo/files/patch-src__filehandling_functions.c
+++ /dev/null
@@ -1,34 +0,0 @@
---- src/filehandling_functions.c.orig Fri Mar 17 00:15:02 2006
-+++ src/filehandling_functions.c Fri Mar 17 15:57:06 2006
-@@ -139,14 +139,13 @@
- char name[256];
- char file[256];
- int i;
-+ char *nameend, *filestart, *fileend, *dot;
-
- id = opendirfile(0);
- if (!id)
- return 0;
-
- read_item(id, type, message, lines);
--
-- char *nameend, *filestart, *fileend, *dot;
-
- /* search for node-links in every line */
- for (i = 1; i < Lines; i++)
-@@ -163,6 +162,7 @@
-
- /* skip this hit if it is not a perfect match and
- * we have already found a previous partial match */
-+ char *tmp = name;
- if ( ! ( (nameend - Message[i]) - 2 == filenamelen )
- && goodHit )
- {
-@@ -170,7 +170,6 @@
- }
-
- /* find the name of the node link */
-- char *tmp = name;
- strncpy(file, filestart + 1, fileend - filestart - 1);
- file[fileend - filestart - 1] = 0;
- strncpy(name, fileend + 1, dot - fileend - 1);
diff --git a/misc/pinfo/files/patch-src__manual.c b/misc/pinfo/files/patch-src__manual.c
deleted file mode 100644
index a8a02c996eb0..000000000000
--- a/misc/pinfo/files/patch-src__manual.c
+++ /dev/null
@@ -1,20 +0,0 @@
---- src/manual.c.orig Thu Mar 16 23:14:30 2006
-+++ src/manual.c Fri Mar 17 16:00:02 2006
-@@ -797,7 +797,7 @@
- if ((!strchr(p_t1, '(')) &&(!is_in_manlinks(manlinks, p_t1)))
- {
- char tempchar;
-- int breakpos;
-+ int breakpos, cols_before_link;
- i = mylink - tmp - 1;
- if (i < 0)
- i++;
-@@ -830,7 +830,7 @@
- */
-
- /* calculate the number of columns in front of the link */
-- int cols_before_link = width_of_string(tmp, i-1);
-+ cols_before_link = width_of_string(tmp, i-1);
-
- /* a small check */
- if (!((use_apropos) &&(manualhistorylength == 0)))
diff --git a/misc/pinfo/files/patch-src__utils.c b/misc/pinfo/files/patch-src__utils.c
deleted file mode 100644
index 551475e7a2a6..000000000000
--- a/misc/pinfo/files/patch-src__utils.c
+++ /dev/null
@@ -1,76 +0,0 @@
---- src/utils.c.orig Thu Mar 16 23:14:30 2006
-+++ src/utils.c Fri Mar 17 16:04:57 2006
-@@ -553,6 +553,10 @@
- int
- check_node_name( const char * const node_name, const char * const node_header)
- {
-+ size_t header_len;
-+ char *header, *str_start, *c;
-+ int res;
-+
- /* if either one of node_name or node_header is NULL or a zero
- * sized string, we have nothing to check, so return success */
- if ( (node_name==NULL) || (node_header==NULL)
-@@ -561,15 +565,15 @@
- return 1;
- }
-
-- size_t header_len = strlen(node_header);
-+ header_len = strlen(node_header);
-
- /* copy node_header to a local string which can be mutilated */
- /* don't use strdup here, as xmalloc handles all errors */
-- char *header = xmalloc( header_len + 1 );
-+ header = xmalloc( header_len + 1 );
- strcpy(header, node_header);
-
- /* search for "Node: foobar," in node_header */
-- char *str_start = strstr(header, "Node: ");
-+ str_start = strstr(header, "Node: ");
- if (str_start==NULL) /* no match */
- {
- return 0;
-@@ -577,14 +581,14 @@
- /* advance str_start to the start of the node name */
- str_start += strlen("Node: ");
- /* and search for the next comma, tab, or newline */
-- char *c = str_start;
-+ c = str_start;
- while ( (*c!=',') && (*c!='\t') && (*c!='\n') && (*c!='\0') ) c++;
- *c = '\0';
-
- /* so, now str_start point to a \0-terminated string containing the
- * node name from the header.
- * Let's compare it with the node_name we're looking for */
-- int res = strcmp(str_start, node_name);
-+ res = strcmp(str_start, node_name);
-
- /* we're done, so free alloc'ed vars */
- xfree(header);
-@@ -637,20 +641,22 @@
- int
- width_of_string( const char * const mbs, const int len)
- {
-+ int width;
-+ char *str;
-+ wchar_t *wstr;
-+
- if (len<0) return -1;
- if (len==0) return 0;
-
-- int width;
--
- /* copy the string to a local buffer, because we only want to
- * compare the first len bytes */
-- char *str = xmalloc(len+1);
-+ str = xmalloc(len+1);
- memcpy(str, mbs, len);
-
- #ifdef USE_WCHAR
-
- /* allocate a widestring */
-- wchar_t *wstr = xmalloc( (len+1)*sizeof(wchar_t) );
-+ wstr = xmalloc( (len+1)*sizeof(wchar_t) );
-
- mbstowcs(wstr, str, len);
- width = wcswidth(wstr, len);
diff --git a/misc/pinfo/files/patch-src__video.c b/misc/pinfo/files/patch-src__video.c
deleted file mode 100644
index 0bd260048aec..000000000000
--- a/misc/pinfo/files/patch-src__video.c
+++ /dev/null
@@ -1,58 +0,0 @@
---- src/video.c.orig Thu Mar 16 06:54:56 2006
-+++ src/video.c Fri Mar 17 16:08:37 2006
-@@ -88,9 +88,11 @@
- attrset(normal);
- for (i = pos;(i < lines) &&(i < pos + maxy - 2); i++)
- {
-+ int tmp;
-+
- if (!message[i]) continue;
-
-- int tmp = strlen(message[i]) - 1;
-+ tmp = strlen(message[i]) - 1;
- message[i][tmp] = 0;
- if (tmp>column)
- mvaddstr(i + 1 - pos, 0, message[i]+column);
-@@ -263,12 +265,14 @@
- {
- regmatch_t pmatch[1];
- long maxpos = pos +(maxy - 2);
-+ int maxregexp;
-+
- if (maxpos > lines)
- {
- maxpos = lines;
- }
-
-- int maxregexp = aftersearch ? h_regexp_num + 1 : h_regexp_num;
-+ maxregexp = aftersearch ? h_regexp_num + 1 : h_regexp_num;
- /*
- * if it is after search, then we have user defined regexps+
- * a searched regexp to highlight
-@@ -285,19 +289,22 @@
- /* check if this regexp is present on this line */
- while (!regexec(&h_regexp[j], str, 1, pmatch, 0))
- {
-+ int n, x, y;
-+ char tmp;
-+
- /* yes, found something, so highlight it */
-- int n = pmatch[0].rm_eo - pmatch[0].rm_so;
-+ n = pmatch[0].rm_eo - pmatch[0].rm_so;
-
- /* point str at start of match */
- str += pmatch[0].rm_so;
-
- /* calculate position on screen */
-- int x = calculate_len(message[i], str);
-- int y = i - pos + 1;
-+ x = calculate_len(message[i], str);
-+ y = i - pos + 1;
-
- /* save the char after the end of the match,
- * and replace it by \0 */
-- char tmp = str[n];
-+ tmp = str[n];
- str[n] = 0;
-
- /* write out the highlighted match to screen */
diff --git a/misc/pinfo/pkg-plist b/misc/pinfo/pkg-plist
deleted file mode 100644
index 289deb9e7eeb..000000000000
--- a/misc/pinfo/pkg-plist
+++ /dev/null
@@ -1,13 +0,0 @@
-bin/pinfo
-etc/pinforc
-%%NLS%%share/locale/cs/LC_MESSAGES/pinfo.mo
-%%NLS%%share/locale/de/LC_MESSAGES/pinfo.mo
-%%NLS%%share/locale/eu/LC_MESSAGES/pinfo.mo
-%%NLS%%share/locale/ja/LC_MESSAGES/pinfo.mo
-%%NLS%%share/locale/nl/LC_MESSAGES/pinfo.mo
-%%NLS%%share/locale/pl/LC_MESSAGES/pinfo.mo
-%%NLS%%share/locale/pt_BR/LC_MESSAGES/pinfo.mo
-%%NLS%%share/locale/ro/LC_MESSAGES/pinfo.mo
-%%NLS%%share/locale/ru/LC_MESSAGES/pinfo.mo
-%%NLS%%share/locale/sv/LC_MESSAGES/pinfo.mo
-%%NLS%%share/locale/vi/LC_MESSAGES/pinfo.mo