aboutsummaryrefslogtreecommitdiffstats
path: root/misc/pointless/Makefile
diff options
context:
space:
mode:
authorerwin <erwin@FreeBSD.org>2004-01-30 23:59:20 +0800
committererwin <erwin@FreeBSD.org>2004-01-30 23:59:20 +0800
commit6819d66b988a591aee1b6203ea45889eb89b35a5 (patch)
tree37ace46233cdcd2641df377150d5fea6550fab0f /misc/pointless/Makefile
parent9efa7fb861372b19a2b3c4c2ac9a133895f9cee6 (diff)
downloadfreebsd-ports-gnome-6819d66b988a591aee1b6203ea45889eb89b35a5.tar.gz
freebsd-ports-gnome-6819d66b988a591aee1b6203ea45889eb89b35a5.tar.zst
freebsd-ports-gnome-6819d66b988a591aee1b6203ea45889eb89b35a5.zip
This release contains a large number of fixes (including fixes for
a few crashbugs and for serious problems with fullscreen support). A number of new features has been added as well: tables, scaling of pll-embedded content (like LaTeX or Metapost), pll-to-tgz packing etc. It should also be mentioned that pointless no longer uses python embedded but has become a plain python extension. Finally pointless now uses far less memory and cpu cycles. PR: 62012 Submitted by: maintainer
Diffstat (limited to 'misc/pointless/Makefile')
-rw-r--r--misc/pointless/Makefile10
1 files changed, 4 insertions, 6 deletions
diff --git a/misc/pointless/Makefile b/misc/pointless/Makefile
index b40a8d2624f4..9900d341372e 100644
--- a/misc/pointless/Makefile
+++ b/misc/pointless/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= pointless
-PORTVERSION= 0.4
-PORTREVISION= 1
+PORTVERSION= 0.5
CATEGORIES= misc
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -27,17 +26,16 @@ BUILD_DEPENDS= ${LOCALBASE}/bin/gnuplot:${PORTSDIR}/math/gnuplot \
${LOCALBASE}/bin/mpost:${PORTSDIR}/print/teTeX
RUN_DEPENDS= ${BUILD_DEPENDS}
-USE_MESA= yes
+USE_GL= yes
USE_PYTHON= yes
-PYTHON_VERSION= python2.2
HAS_CONFIGURE= yes
CONFIGURE_ARGS+= --prefix=${PREFIX}
-CONFIGURE_ENV+= CPPFLAGS=-I${LOCALBASE}/include
+CONFIGURE_ENV+= CPPFLAGS=-I${LOCALBASE}/include LDFLAGS=-L${LOCALBASE}/lib/${PYTHON_VERSION}/config/
MAN1= pointless.1
-CXXFLAGS= -DHAVE_PYTHON2_2
+INSTALL_TARGET= install install-modules
pre-fetch:
.if !defined(WITH_GHOSTSCRIPT_AFPL) || ${WITH_GHOSTSCRIPT_AFPL} != yes