aboutsummaryrefslogtreecommitdiffstats
path: root/misc/quotes
diff options
context:
space:
mode:
authordanilo <danilo@FreeBSD.org>2013-12-09 21:35:01 +0800
committerdanilo <danilo@FreeBSD.org>2013-12-09 21:35:01 +0800
commit230cbc97a908570bdb0491e19dd69443d301a2f2 (patch)
tree4b7a7ac9bf6f4390fac84271701d7e331026aa47 /misc/quotes
parentc23f1e7fbeea9257cd2d115f2c0244aa5a499194 (diff)
downloadfreebsd-ports-gnome-230cbc97a908570bdb0491e19dd69443d301a2f2.tar.gz
freebsd-ports-gnome-230cbc97a908570bdb0491e19dd69443d301a2f2.tar.zst
freebsd-ports-gnome-230cbc97a908570bdb0491e19dd69443d301a2f2.zip
- Remove MASTER_SITES sources, distfile unavailable.
- Add stage support - Add DOCS and EXAMPLES options
Diffstat (limited to 'misc/quotes')
-rw-r--r--misc/quotes/Makefile25
1 files changed, 9 insertions, 16 deletions
diff --git a/misc/quotes/Makefile b/misc/quotes/Makefile
index d8a333ee2f02..13edac4698ea 100644
--- a/misc/quotes/Makefile
+++ b/misc/quotes/Makefile
@@ -5,9 +5,7 @@ PORTNAME= quotes
DISTVERSION= 1.7-2
PORTREVISION= 1
CATEGORIES= misc
-MASTER_SITES= ${MASTER_SITE_TUCOWS} \
- http://freebsd.unixfreunde.de/sources/
-MASTER_SITE_SUBDIR= console/office
+MASTER_SITES= #
MAINTAINER= ports@FreeBSD.org
COMMENT= Quote, currency, and Slashdot headline fetcher based on Perl
@@ -16,24 +14,19 @@ NO_BUILD= yes
USES= shebangfix perl5
SHEBANG_FILES= quotes quotesmailer QuExample.pm
-NO_STAGE= yes
-.include <bsd.port.options.mk>
+OPTIONS_DEFINE= DOCS EXAMPLES
post-patch:
@${REINPLACE_CMD} -i '' -e "s:/usr/local/lib/Quotes:${PREFIX}/etc:" \
-e "s:/usr/local:${PREFIX}:" ${WRKSRC}/quotes
do-install:
- @ ${INSTALL_SCRIPT} ${WRKSRC}/quotes ${PREFIX}/bin
- @ ${INSTALL_SCRIPT} ${WRKSRC}/quotesmailer ${PREFIX}/bin
- @ ${INSTALL_DATA} ${WRKSRC}/sample.quotesrc ${PREFIX}/etc/quotesrc.sample
-.if ${PORT_OPTIONS:MDOCS}
- @ ${MKDIR} ${DOCSDIR}
- @ ${INSTALL_DATA} ${WRKSRC}/quotes.txt ${DOCSDIR}
-.endif
-.if ${PORT_OPTIONS:MEXAMPLES}
- @ ${MKDIR} ${EXAMPLESDIR}
- @ ${INSTALL_DATA} ${WRKSRC}/QuExample.pm ${EXAMPLESDIR}
-.endif
+ ${INSTALL_SCRIPT} ${WRKSRC}/quotes ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/quotesmailer ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/sample.quotesrc ${STAGEDIR}${PREFIX}/etc/quotesrc.sample
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/quotes.txt ${STAGEDIR}${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/QuExample.pm ${STAGEDIR}${EXAMPLESDIR}
.include <bsd.port.mk>